Reference

SiteSeeker Search Module SDK

SiteSeeker Search Module SDK (3.3)
Reference
The SiteSeeker Search Module is divided into several namespaces, which will help you while developing solutions using the module. The development namespace is where modifications for each installation is made, i.e. in web user controls and in data transfer objects (DTO). No modifications should be done in the SiteSeeker namespace to ensure compatibility with upcoming releases of the search module.

Namespaces

Namespace | Description
development.search | Namespace for search page and user controls for search form, search result list and search overview.
development.search.DTO | Data transfer objects for hits, best bets, filter and other listable data types. Data transfer objects contains view-specfic presentation logic.
development.search.Extras | Additional user controls for query suggestions, on the search page (query refinements) and in the search form (query completion).
SiteSeeker.Compatibility | Namespace for classes specific to a certain content management tool, e.g. EPiServer.
SiteSeeker.Control | Namespace for control classes (i.e. Connector).
SiteSeeker.Environment | Classes defining the module environment, i.e. global settings for SiteSeeker connectability and settings local to the current search page.
SiteSeeker.HttpHandlers |
SiteSeeker.Model | Classes encapsulating the SiteSeeker web service API.
SiteSeeker.Util | Utility classes.

Send comments on this topic to support@euroling.se

Copyright © 2011 Euroling AB


development.search Namespace

development.search Namespace
Namespace for search page and user controls for search form, search result list and search overview.

Classes

Class | Description
Find | Find class.
Form | Form class.
HitCounter | Summary description for HitCounter.
LoadStats | Summary description for LoadStats.
Overview | Overview UserControl
PresetSearch | PresetSearch class.
Result | Result class.
ShowCache | Summary description for ShowCache.
SiteSeekerTreeTab | Fliken för att visa statistik i edit-läge.


Find Class

Find Class
Members See Also
Find class.
Main aspx form

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Find : FindBase

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
PageBase
SimplePage
EditPage
TemplatePage
SiteSeeker.Compatibility..::.FindBase
development.search..::.Find

See Also

Find Members
development.search Namespace


Find Members

[image]

SiteSeeker Search Module SDK (3.3)
Find Members
Find Class Constructors Methods Fields Properties See Also

The Find type exposes the following members.

Constructors

Name | Description
Find |

Methods

Name | Description
OnInit | Creates the Connector, and adds necessary event handlers. (Overrides PageBase..::.OnInit(EventArgs).)
Page_PreRender | On postback, performs a redirect in order the get update the URL/query string with new search parameters. Otherwise, saves the current query string (for a possible future postback).

Fields

Name | Description
browsable |
mainConnectorID |
overview | overview control.
searchForm | searchForm control.
searchResults | searchResults control.
session |

Properties

Name | Description
Browsable | Indicates if this search page should be browsable, i.e. if an empty search query should return all hits. This may be used if it is desired that the user is shown hits, even if no query has been entered. Combined with categories shown in the overview, this may be used to enable browsing of pages while still allowing search queries.

See Also

Find Class
development.search Namespace


Find Constructor

Find Constructor
Find Class See Also
Initializes a new instance of the Find class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Find()

See Also

Find Class
development.search Namespace


Find Fields

[image]

SiteSeeker Search Module SDK (3.3)
Find Fields
Find Class See Also

The Find type exposes the following fields.

Fields

Name | Description
browsable |
mainConnectorID |
overview | overview control.
searchForm | searchForm control.
searchResults | searchResults control.
session |

See Also

Find Class
development.search Namespace


browsable Field

Find..::.browsable Field
Find Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected bool browsable

See Also

Find Class
development.search Namespace


mainConnectorID Field

Find..::.mainConnectorID Field
Find Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string mainConnectorID

See Also

Find Class
development.search Namespace


overview Field

Find..::.overview Field
Find Class See Also
overview control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Overview overview

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Find Class
development.search Namespace


searchForm Field

Find..::.searchForm Field
Find Class See Also
searchForm control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Form searchForm

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Find Class
development.search Namespace


searchResults Field

Find..::.searchResults Field
Find Class See Also
searchResults control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Result searchResults

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Find Class
development.search Namespace


session Field

Find..::.session Field
Find Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Session session

See Also

Find Class
development.search Namespace


Find Methods

[image]

SiteSeeker Search Module SDK (3.3)
Find Methods
Find Class See Also

The Find type exposes the following methods.

Methods

Name | Description
OnInit | Creates the Connector, and adds necessary event handlers. (Overrides PageBase..::.OnInit(EventArgs).)
Page_PreRender | On postback, performs a redirect in order the get update the URL/query string with new search parameters. Otherwise, saves the current query string (for a possible future postback).

See Also

Find Class
development.search Namespace


OnInit Method

Find..::.OnInit Method
Find Class See Also
Creates the Connector, and adds necessary event handlers.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
Event arguments.

See Also

Find Class
development.search Namespace


Page_PreRender Method

Find..::.Page_PreRender Method
Find Class See Also
On postback, performs a redirect in order the get update the URL/query string with new search parameters. Otherwise, saves the current query string (for a possible future postback).

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Page_PreRender(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System..::.EventArgs
Event arguments.

See Also

Find Class
development.search Namespace


Find Properties

[image]

SiteSeeker Search Module SDK (3.3)
Find Properties
Find Class See Also

The Find type exposes the following properties.

Properties

Name | Description
Browsable | Indicates if this search page should be browsable, i.e. if an empty search query should return all hits. This may be used if it is desired that the user is shown hits, even if no query has been entered. Combined with categories shown in the overview, this may be used to enable browsing of pages while still allowing search queries.

See Also

Find Class
development.search Namespace


Browsable Property

Find..::.Browsable Property
Find Class See Also
Indicates if this search page should be browsable, i.e. if an empty search query should return all hits. This may be used if it is desired that the user is shown hits, even if no query has been entered. Combined with categories shown in the overview, this may be used to enable browsing of pages while still allowing search queries.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool Browsable { get; set; }

See Also

Find Class
development.search Namespace


Form Class

Form Class
Members See Also
Form class.
Search Form User Control

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Form : EssUserControlBase

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
SiteSeeker.Control..::.EssUserControlBase
development.search..::.Form

See Also

Form Members
development.search Namespace


Form Members

[image]

SiteSeeker Search Module SDK (3.3)
Form Members
Form Class Constructors Methods Fields Properties See Also

The Form type exposes the following members.

Constructors

Name | Description
Form |

Methods

Name | Description
Ages_OnDataBound |
CategoriesCheckBoxList_OnDataBound |
FileFormats_OnDataBound |
GroupsRepeater_OnItemDataBound |
HelpLink_Click |
SearchButton_Click |
UpdateUrl | Updates the URL with posted search form values.
UpdateView | Attaches JavaScript to the control, sets localised labels and sets states for input elements. (Overrides EssUserControlBase ..::. UpdateView()()().)

Fields

Name | Description
AgePanel | AgePanel control.
Ages | Ages control.
CategoryAny | CategoryAny control.
CategoryLimit | CategoryLimit control.
CategoryPanel | CategoryPanel control.
FileFormatPanel | FileFormatPanel control.
FileFormats | FileFormats control.
GroupsRepeater | GroupsRepeater control.
HelpLink | HelpLink control.
Label1 | Label1 control.
LanguageAny | LanguageAny control.
LanguageLimit | LanguageLimit control.
LanguagePanel | LanguagePanel control.
LanguageSel | LanguageSel control.
SearchButton | SearchButton control.
SearchQuery | SearchQuery control.
StemmingOff | StemmingOff control.
StemmingOn | StemmingOn control.
StemmingPanel | StemmingPanel control.
WasSubmitted |

Properties

Name | Description
HelpLinkUrl |
IncludeJQuery | Set this property to true if the control should include the jQuery JavaScript library. Click tracking and search statistics requires jQuery 1.3.2, but if your already include jQuery, you may set this property to false.
ResetFiltersOnSubmit | Indicates if current search filters (e.g. categories) should be reset when the user submits the form (e.g. when entering a new search query). This property has no effect for filters that have a field present in the search form. Default is true.
ShowHelpLink |

See Also

Form Class
development.search Namespace


Form Constructor

Form Constructor
Form Class See Also
Initializes a new instance of the Form class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Form()

See Also

Form Class
development.search Namespace


Form Fields

[image]

SiteSeeker Search Module SDK (3.3)
Form Fields
Form Class See Also

The Form type exposes the following fields.

Fields

Name | Description
AgePanel | AgePanel control.
Ages | Ages control.
CategoryAny | CategoryAny control.
CategoryLimit | CategoryLimit control.
CategoryPanel | CategoryPanel control.
FileFormatPanel | FileFormatPanel control.
FileFormats | FileFormats control.
GroupsRepeater | GroupsRepeater control.
HelpLink | HelpLink control.
Label1 | Label1 control.
LanguageAny | LanguageAny control.
LanguageLimit | LanguageLimit control.
LanguagePanel | LanguagePanel control.
LanguageSel | LanguageSel control.
SearchButton | SearchButton control.
SearchQuery | SearchQuery control.
StemmingOff | StemmingOff control.
StemmingOn | StemmingOn control.
StemmingPanel | StemmingPanel control.
WasSubmitted |

See Also

Form Class
development.search Namespace


AgePanel Field

Form..::.AgePanel Field
Form Class See Also
AgePanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel AgePanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


Ages Field

Form..::.Ages Field
Form Class See Also
Ages control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButtonList Ages

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


CategoryAny Field

Form..::.CategoryAny Field
Form Class See Also
CategoryAny control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButton CategoryAny

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


CategoryLimit Field

Form..::.CategoryLimit Field
Form Class See Also
CategoryLimit control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButton CategoryLimit

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


CategoryPanel Field

Form..::.CategoryPanel Field
Form Class See Also
CategoryPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel CategoryPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


FileFormatPanel Field

Form..::.FileFormatPanel Field
Form Class See Also
FileFormatPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel FileFormatPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


FileFormats Field

Form..::.FileFormats Field
Form Class See Also
FileFormats control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButtonList FileFormats

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


GroupsRepeater Field

Form..::.GroupsRepeater Field
Form Class See Also
GroupsRepeater control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater GroupsRepeater

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


HelpLink Field

Form..::.HelpLink Field
Form Class See Also
HelpLink control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected HyperLink HelpLink

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


Label1 Field

Form..::.Label1 Field
Form Class See Also
Label1 control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label Label1

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


LanguageAny Field

Form..::.LanguageAny Field
Form Class See Also
LanguageAny control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButton LanguageAny

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


LanguageLimit Field

Form..::.LanguageLimit Field
Form Class See Also
LanguageLimit control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButton LanguageLimit

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


LanguagePanel Field

Form..::.LanguagePanel Field
Form Class See Also
LanguagePanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel LanguagePanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


LanguageSel Field

Form..::.LanguageSel Field
Form Class See Also
LanguageSel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected DropDownList LanguageSel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


SearchButton Field

Form..::.SearchButton Field
Form Class See Also
SearchButton control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Button SearchButton

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


SearchQuery Field

Form..::.SearchQuery Field
Form Class See Also
SearchQuery control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox SearchQuery

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


StemmingOff Field

Form..::.StemmingOff Field
Form Class See Also
StemmingOff control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButton StemmingOff

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


StemmingOn Field

Form..::.StemmingOn Field
Form Class See Also
StemmingOn control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected RadioButton StemmingOn

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


StemmingPanel Field

Form..::.StemmingPanel Field
Form Class See Also
StemmingPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel StemmingPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Form Class
development.search Namespace


WasSubmitted Field

Form..::.WasSubmitted Field
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool WasSubmitted

See Also

Form Class
development.search Namespace


Form Methods

[image]

SiteSeeker Search Module SDK (3.3)
Form Methods
Form Class See Also

The Form type exposes the following methods.

Methods

Name | Description
Ages_OnDataBound |
CategoriesCheckBoxList_OnDataBound |
FileFormats_OnDataBound |
GroupsRepeater_OnItemDataBound |
HelpLink_Click |
SearchButton_Click |
UpdateUrl | Updates the URL with posted search form values.
UpdateView | Attaches JavaScript to the control, sets localised labels and sets states for input elements. (Overrides EssUserControlBase ..::. UpdateView()()().)

See Also

Form Class
development.search Namespace


Ages_OnDataBound Method

Form..::.Ages_OnDataBound Method
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Ages_OnDataBound(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Form Class
development.search Namespace


CategoriesCheckBoxList_OnDataBound Method

Form..::.CategoriesCheckBoxList_OnDataBound Method
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void CategoriesCheckBoxList_OnDataBound(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Form Class
development.search Namespace


FileFormats_OnDataBound Method

Form..::.FileFormats_OnDataBound Method
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void FileFormats_OnDataBound(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Form Class
development.search Namespace


GroupsRepeater_OnItemDataBound Method

Form..::.GroupsRepeater_OnItemDataBound Method
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void GroupsRepeater_OnItemDataBound(
    Object sender,
    RepeaterItemEventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System.Web.UI.WebControls..::.RepeaterItemEventArgs

See Also

Form Class
development.search Namespace


HelpLink_Click Method

Form..::.HelpLink_Click Method
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void HelpLink_Click(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Form Class
development.search Namespace


SearchButton_Click Method

Form..::.SearchButton_Click Method
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void SearchButton_Click(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Form Class
development.search Namespace


UpdateUrl Method

Form..::.UpdateUrl Method
Form Class See Also
Updates the URL with posted search form values.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void UpdateUrl(
    UrlBuilder url
)

Parameters

url
Type: SiteSeeker.Util..::.UrlBuilder

See Also

Form Class
development.search Namespace


UpdateView Method

Form..::.UpdateView Method
Form Class See Also
Attaches JavaScript to the control, sets localised labels and sets states for input elements.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void UpdateView()

See Also

Form Class
development.search Namespace


Form Properties

[image]

SiteSeeker Search Module SDK (3.3)
Form Properties
Form Class See Also

The Form type exposes the following properties.

Properties

Name | Description
HelpLinkUrl |
IncludeJQuery | Set this property to true if the control should include the jQuery JavaScript library. Click tracking and search statistics requires jQuery 1.3.2, but if your already include jQuery, you may set this property to false.
ResetFiltersOnSubmit | Indicates if current search filters (e.g. categories) should be reset when the user submits the form (e.g. when entering a new search query). This property has no effect for filters that have a field present in the search form. Default is true.
ShowHelpLink |

See Also

Form Class
development.search Namespace


HelpLinkUrl Property

Form..::.HelpLinkUrl Property
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string HelpLinkUrl { get; }

See Also

Form Class
development.search Namespace


IncludeJQuery Property

Form..::.IncludeJQuery Property
Form Class See Also
Set this property to true if the control should include the jQuery JavaScript library. Click tracking and search statistics requires jQuery 1.3.2, but if your already include jQuery, you may set this property to false.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IncludeJQuery { get; set; }

Remarks

Default is true.

See Also

Form Class
development.search Namespace


ResetFiltersOnSubmit Property

Form..::.ResetFiltersOnSubmit Property
Form Class See Also
Indicates if current search filters (e.g. categories) should be reset when the user submits the form (e.g. when entering a new search query). This property has no effect for filters that have a field present in the search form. Default is true.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ResetFiltersOnSubmit { get; set; }

See Also

Form Class
development.search Namespace


ShowHelpLink Property

Form..::.ShowHelpLink Property
Form Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected bool ShowHelpLink { get; }

See Also

Form Class
development.search Namespace


HitCounter Class

HitCounter Class
Members See Also
Summary description for HitCounter.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class HitCounter : Page

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
development.search..::.HitCounter

See Also

HitCounter Members
development.search Namespace


HitCounter Members

[image]

SiteSeeker Search Module SDK (3.3)
HitCounter Members
HitCounter Class Constructors Methods Properties See Also

The HitCounter type exposes the following members.

Constructors

Name | Description
HitCounter |

Methods

Name | Description
OnInit | (Overrides Page ..::. OnInit(EventArgs).)
Page_Load |

Properties

Name | Description
Config | Returns the SiteSeeker.Environment.GlobalSettings object.

See Also

HitCounter Class
development.search Namespace


HitCounter Constructor

HitCounter Constructor
HitCounter Class See Also
Initializes a new instance of the HitCounter class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public HitCounter()

See Also

HitCounter Class
development.search Namespace


HitCounter Methods

[image]

SiteSeeker Search Module SDK (3.3)
HitCounter Methods
HitCounter Class See Also

The HitCounter type exposes the following methods.

Methods

Name | Description
OnInit | (Overrides Page ..::. OnInit(EventArgs).)
Page_Load |

See Also

HitCounter Class
development.search Namespace


OnInit Method

HitCounter..::.OnInit Method
HitCounter Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

HitCounter Class
development.search Namespace


Page_Load Method

HitCounter..::.Page_Load Method
HitCounter Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

HitCounter Class
development.search Namespace


HitCounter Properties

[image]

SiteSeeker Search Module SDK (3.3)
HitCounter Properties
HitCounter Class See Also

The HitCounter type exposes the following properties.

Properties

Name | Description
Config | Returns the SiteSeeker.Environment.GlobalSettings object.

See Also

HitCounter Class
development.search Namespace


Config Property

HitCounter..::.Config Property
HitCounter Class See Also
Returns the SiteSeeker.Environment.GlobalSettings object.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettings Config { get; }

Return Value

The SiteSeeker.Environment.GlobalSettings object

See Also

HitCounter Class
development.search Namespace


LoadStats Class

LoadStats Class
Members See Also
Summary description for LoadStats.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class LoadStats : Page

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
development.search..::.LoadStats

See Also

LoadStats Members
development.search Namespace


LoadStats Members

[image]

SiteSeeker Search Module SDK (3.3)
LoadStats Members
LoadStats Class Constructors Methods Fields See Also

The LoadStats type exposes the following members.

Constructors

Name | Description
LoadStats |

Methods

Name | Description
HandleError |
OnInit | (Overrides Page ..::. OnInit(EventArgs).)

Fields

Name | Description
ErrorMessage |
FramePanel |
StatUrl |

See Also

LoadStats Class
development.search Namespace


LoadStats Constructor

LoadStats Constructor
LoadStats Class See Also
Initializes a new instance of the LoadStats class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public LoadStats()

See Also

LoadStats Class
development.search Namespace


LoadStats Fields

[image]

SiteSeeker Search Module SDK (3.3)
LoadStats Fields
LoadStats Class See Also

The LoadStats type exposes the following fields.

Fields

Name | Description
ErrorMessage |
FramePanel |
StatUrl |

See Also

LoadStats Class
development.search Namespace


ErrorMessage Field

LoadStats..::.ErrorMessage Field
LoadStats Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label ErrorMessage

See Also

LoadStats Class
development.search Namespace


FramePanel Field

LoadStats..::.FramePanel Field
LoadStats Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel FramePanel

See Also

LoadStats Class
development.search Namespace


StatUrl Field

LoadStats..::.StatUrl Field
LoadStats Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string StatUrl

See Also

LoadStats Class
development.search Namespace


LoadStats Methods

[image]

SiteSeeker Search Module SDK (3.3)
LoadStats Methods
LoadStats Class See Also

The LoadStats type exposes the following methods.

Methods

Name | Description
HandleError |
OnInit | (Overrides Page ..::. OnInit(EventArgs).)

See Also

LoadStats Class
development.search Namespace


HandleError Method

LoadStats..::.HandleError Method
LoadStats Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected virtual void HandleError(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

LoadStats Class
development.search Namespace


OnInit Method

LoadStats..::.OnInit Method
LoadStats Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

LoadStats Class
development.search Namespace


Overview Class

Overview Class
Members See Also
Overview UserControl
Overview class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Overview : EssUserControlBase

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
SiteSeeker.Control..::.EssUserControlBase
development.search..::.Overview

See Also

Overview Members
development.search Namespace


Overview Members

[image]

SiteSeeker Search Module SDK (3.3)
Overview Members
Overview Class Constructors Methods Fields Properties See Also

The Overview type exposes the following members.

Constructors

Name | Description
Overview |

Methods

Name | Description
UpdateView | (Overrides EssUserControlBase ..::. UpdateView()()().)

Fields

Name | Description
Ages |
CategoryGroup |
CategoryGroups |
FileFormats |
FilterGroupsRepeater | FilterGroupsRepeater control.
Languages |
RemoveFilter | RemoveFilter control.
RemoveFilterLabel |
RemoveFilterLink | RemoveFilterLink control.
SearchAllPanel | SearchAllPanel control.

Properties

Name | Description
ShowRemoveFilter |
VisibleFilterGroups | A list of comma separated values defining the filter groups to appear in the overview. Valid values are: LANGUAGES, FILEFORMATS, CATEGORYGROUPS and/or CATEGORYGROUP:[name of category group]

See Also

Overview Class
development.search Namespace


Overview Constructor

Overview Constructor
Overview Class See Also
Initializes a new instance of the Overview class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Overview()

See Also

Overview Class
development.search Namespace


Overview Fields

[image]

SiteSeeker Search Module SDK (3.3)
Overview Fields
Overview Class See Also

The Overview type exposes the following fields.

Fields

Name | Description
Ages |
CategoryGroup |
CategoryGroups |
FileFormats |
FilterGroupsRepeater | FilterGroupsRepeater control.
Languages |
RemoveFilter | RemoveFilter control.
RemoveFilterLabel |
RemoveFilterLink | RemoveFilterLink control.
SearchAllPanel | SearchAllPanel control.

See Also

Overview Class
development.search Namespace


Ages Field

Overview..::.Ages Field
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Ages

See Also

Overview Class
development.search Namespace


CategoryGroup Field

Overview..::.CategoryGroup Field
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string CategoryGroup

See Also

Overview Class
development.search Namespace


CategoryGroups Field

Overview..::.CategoryGroups Field
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string CategoryGroups

See Also

Overview Class
development.search Namespace


FileFormats Field

Overview..::.FileFormats Field
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string FileFormats

See Also

Overview Class
development.search Namespace


FilterGroupsRepeater Field

Overview..::.FilterGroupsRepeater Field
Overview Class See Also
FilterGroupsRepeater control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater FilterGroupsRepeater

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Overview Class
development.search Namespace


Languages Field

Overview..::.Languages Field
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Languages

See Also

Overview Class
development.search Namespace


RemoveFilter Field

Overview..::.RemoveFilter Field
Overview Class See Also
RemoveFilter control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label RemoveFilter

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Overview Class
development.search Namespace


RemoveFilterLabel Field

Overview..::.RemoveFilterLabel Field
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string RemoveFilterLabel

See Also

Overview Class
development.search Namespace


RemoveFilterLink Field

Overview..::.RemoveFilterLink Field
Overview Class See Also
RemoveFilterLink control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected HyperLink RemoveFilterLink

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Overview Class
development.search Namespace


SearchAllPanel Field

Overview..::.SearchAllPanel Field
Overview Class See Also
SearchAllPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel SearchAllPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Overview Class
development.search Namespace


Overview Methods

[image]

SiteSeeker Search Module SDK (3.3)
Overview Methods
Overview Class See Also

The Overview type exposes the following methods.

Methods

Name | Description
UpdateView | (Overrides EssUserControlBase ..::. UpdateView()()().)

See Also

Overview Class
development.search Namespace


UpdateView Method

Overview..::.UpdateView Method
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void UpdateView()

See Also

Overview Class
development.search Namespace


Overview Properties

[image]

SiteSeeker Search Module SDK (3.3)
Overview Properties
Overview Class See Also

The Overview type exposes the following properties.

Properties

Name | Description
ShowRemoveFilter |
VisibleFilterGroups | A list of comma separated values defining the filter groups to appear in the overview. Valid values are: LANGUAGES, FILEFORMATS, CATEGORYGROUPS and/or CATEGORYGROUP:[name of category group]

See Also

Overview Class
development.search Namespace


ShowRemoveFilter Property

Overview..::.ShowRemoveFilter Property
Overview Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowRemoveFilter { get; set; }

See Also

Overview Class
development.search Namespace


VisibleFilterGroups Property

Overview..::.VisibleFilterGroups Property
Overview Class See Also
A list of comma separated values defining the filter groups to appear in the overview. Valid values are: LANGUAGES, FILEFORMATS, CATEGORYGROUPS and/or CATEGORYGROUP:[name of category group]

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string VisibleFilterGroups { get; set; }

See Also

Overview Class
development.search Namespace


PresetSearch Class

PresetSearch Class
Members See Also
PresetSearch class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class PresetSearch : UserControlBase

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
UserControlBase
development.search..::.PresetSearch

See Also

PresetSearch Members
development.search Namespace


PresetSearch Members

[image]

SiteSeeker Search Module SDK (3.3)
PresetSearch Members
PresetSearch Class Constructors Methods Fields Properties See Also

The PresetSearch type exposes the following members.

Constructors

Name | Description
PresetSearch |

Methods

Name | Description
Page_Load | Creates a connector and attaches event handler for BeforeSearch.
SetRequest | Sets the search query. This must be made after the Connector is initalised, but before the search is performed. This is an event handler for the BeforeSearch event.
UpdateView | Performs data binding for the result lists.

Fields

Name | Description
BestBets | BestBets control.
PresetSearchControl | PresetSearchControl control.
SearchResult | SearchResult control.

Properties

Name | Description
BestBetsVisible | Show best bets. Default is false.
Connector |
ExtractsVisible | Show text extracts for hits and descriptions for best bets. Default is false.
HitsVisible | Show hits. Default is true.
NHits | Number of hits to show. Default value is 5.
Query | Search query. Default is the empty string, i.e. no search will be performed.
RelatedPages | Show related pages. If set to true, pages related to the current page will be shown. Note that BestBetsVisible and HitsVisible have no effect if RelatedPages is set to true. The Query, if set, is appended to the query for related pages. Default is false.
RelatedPagesProperty | Show relatade pages if a page property with this name exists and is set to true. If the property either does not exist or is false, no related pages are shown, and furthermore, no ordinary hits or best bets are shown (since BestBetsVisible and HitsVisible have no effect if RelatedPagesProperty is set to a non-empty string).

See Also

PresetSearch Class
development.search Namespace


PresetSearch Constructor

PresetSearch Constructor
PresetSearch Class See Also
Initializes a new instance of the PresetSearch class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public PresetSearch()

See Also

PresetSearch Class
development.search Namespace


PresetSearch Fields

[image]

SiteSeeker Search Module SDK (3.3)
PresetSearch Fields
PresetSearch Class See Also

The PresetSearch type exposes the following fields.

Fields

Name | Description
BestBets | BestBets control.
PresetSearchControl | PresetSearchControl control.
SearchResult | SearchResult control.

See Also

PresetSearch Class
development.search Namespace


BestBets Field

PresetSearch..::.BestBets Field
PresetSearch Class See Also
BestBets control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater BestBets

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PresetSearch Class
development.search Namespace


PresetSearchControl Field

PresetSearch..::.PresetSearchControl Field
PresetSearch Class See Also
PresetSearchControl control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected PlaceHolder PresetSearchControl

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PresetSearch Class
development.search Namespace


SearchResult Field

PresetSearch..::.SearchResult Field
PresetSearch Class See Also
SearchResult control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater SearchResult

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

PresetSearch Class
development.search Namespace


PresetSearch Methods

[image]

SiteSeeker Search Module SDK (3.3)
PresetSearch Methods
PresetSearch Class See Also

The PresetSearch type exposes the following methods.

Methods

Name | Description
Page_Load | Creates a connector and attaches event handler for BeforeSearch.
SetRequest | Sets the search query. This must be made after the Connector is initalised, but before the search is performed. This is an event handler for the BeforeSearch event.
UpdateView | Performs data binding for the result lists.

See Also

PresetSearch Class
development.search Namespace


Page_Load Method

PresetSearch..::.Page_Load Method
PresetSearch Class See Also
Creates a connector and attaches event handler for BeforeSearch.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
Event sender.
e
Type: System..::.EventArgs
Event arguments.

See Also

PresetSearch Class
development.search Namespace


SetRequest Method

PresetSearch..::.SetRequest Method
PresetSearch Class See Also
Sets the search query. This must be made after the Connector is initalised, but before the search is performed. This is an event handler for the BeforeSearch event.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void SetRequest(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
Event sender (i.e. the Connector).
e
Type: System..::.EventArgs
Event arguments.

See Also

PresetSearch Class
development.search Namespace


UpdateView Method

PresetSearch..::.UpdateView Method
PresetSearch Class See Also
Performs data binding for the result lists.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void UpdateView()

See Also

PresetSearch Class
development.search Namespace


PresetSearch Properties

[image]

SiteSeeker Search Module SDK (3.3)
PresetSearch Properties
PresetSearch Class See Also

The PresetSearch type exposes the following properties.

Properties

Name | Description
BestBetsVisible | Show best bets. Default is false.
Connector |
ExtractsVisible | Show text extracts for hits and descriptions for best bets. Default is false.
HitsVisible | Show hits. Default is true.
NHits | Number of hits to show. Default value is 5.
Query | Search query. Default is the empty string, i.e. no search will be performed.
RelatedPages | Show related pages. If set to true, pages related to the current page will be shown. Note that BestBetsVisible and HitsVisible have no effect if RelatedPages is set to true. The Query, if set, is appended to the query for related pages. Default is false.
RelatedPagesProperty | Show relatade pages if a page property with this name exists and is set to true. If the property either does not exist or is false, no related pages are shown, and furthermore, no ordinary hits or best bets are shown (since BestBetsVisible and HitsVisible have no effect if RelatedPagesProperty is set to a non-empty string).

See Also

PresetSearch Class
development.search Namespace


BestBetsVisible Property

PresetSearch..::.BestBetsVisible Property
PresetSearch Class See Also
Show best bets. Default is false.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool BestBetsVisible { get; set; }

See Also

PresetSearch Class
development.search Namespace


Connector Property

PresetSearch..::.Connector Property
PresetSearch Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Connector Connector { get; set; }

See Also

PresetSearch Class
development.search Namespace


ExtractsVisible Property

PresetSearch..::.ExtractsVisible Property
PresetSearch Class See Also
Show text extracts for hits and descriptions for best bets. Default is false.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ExtractsVisible { get; set; }

See Also

PresetSearch Class
development.search Namespace


HitsVisible Property

PresetSearch..::.HitsVisible Property
PresetSearch Class See Also
Show hits. Default is true.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool HitsVisible { get; set; }

See Also

PresetSearch Class
development.search Namespace


NHits Property

PresetSearch..::.NHits Property
PresetSearch Class See Also
Number of hits to show. Default value is 5.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NHits { get; set; }

See Also

PresetSearch Class
development.search Namespace


Query Property

PresetSearch..::.Query Property
PresetSearch Class See Also
Search query. Default is the empty string, i.e. no search will be performed.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Query { get; set; }

See Also

PresetSearch Class
development.search Namespace


RelatedPages Property

PresetSearch..::.RelatedPages Property
PresetSearch Class See Also
Show related pages. If set to true, pages related to the current page will be shown. Note that BestBetsVisible and HitsVisible have no effect if RelatedPages is set to true. The Query, if set, is appended to the query for related pages. Default is false.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool RelatedPages { get; set; }

See Also

PresetSearch Class
development.search Namespace


RelatedPagesProperty Property

PresetSearch..::.RelatedPagesProperty Property
PresetSearch Class See Also
Show relatade pages if a page property with this name exists and is set to true. If the property either does not exist or is false, no related pages are shown, and furthermore, no ordinary hits or best bets are shown (since BestBetsVisible and HitsVisible have no effect if RelatedPagesProperty is set to a non-empty string).

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string RelatedPagesProperty { get; set; }

See Also

PresetSearch Class
development.search Namespace


Result Class

Result Class
Members See Also
Result class.
This class renders the list of hits for a certain query. It is also responsible for the pagination and sorting of the hits.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Result : EssUserControlBase

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
SiteSeeker.Control..::.EssUserControlBase
development.search..::.Result

See Also

Result Members
development.search Namespace


Result Members

[image]

SiteSeeker Search Module SDK (3.3)
Result Members
Result Class Constructors Methods Fields See Also

The Result type exposes the following members.

Constructors

Name | Description
Result |

Methods

Name | Description
UpdateView | (Overrides EssUserControlBase ..::. UpdateView()()().)

Fields

Name | Description
BestBets | BestBets control.
BestBetsPanel | BestBetsPanel control.
ErrorMessageLabel | ErrorMessageLabel control.
NoHitsPanel | NoHitsPanel control.
NoQueryPanel | NoQueryPanel control.
PageFlicker | PageFlicker control.
PageLinks |
SearchResult | SearchResult control.
SearchSummary |
SortLinkList | SortLinkList control.
SortOrderDateUrl |
SortOrderRelevanceUrl |
SortPanel | SortPanel control.
SpellingPanel | SpellingPanel control.
SpellingSuggestion | SpellingSuggestion control.

See Also

Result Class
development.search Namespace


Result Constructor

Result Constructor
Result Class See Also
Initializes a new instance of the Result class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Result()

See Also

Result Class
development.search Namespace


Result Fields

[image]

SiteSeeker Search Module SDK (3.3)
Result Fields
Result Class See Also

The Result type exposes the following fields.

Fields

Name | Description
BestBets | BestBets control.
BestBetsPanel | BestBetsPanel control.
ErrorMessageLabel | ErrorMessageLabel control.
NoHitsPanel | NoHitsPanel control.
NoQueryPanel | NoQueryPanel control.
PageFlicker | PageFlicker control.
PageLinks |
SearchResult | SearchResult control.
SearchSummary |
SortLinkList | SortLinkList control.
SortOrderDateUrl |
SortOrderRelevanceUrl |
SortPanel | SortPanel control.
SpellingPanel | SpellingPanel control.
SpellingSuggestion | SpellingSuggestion control.

See Also

Result Class
development.search Namespace


BestBets Field

Result..::.BestBets Field
Result Class See Also
BestBets control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater BestBets

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


BestBetsPanel Field

Result..::.BestBetsPanel Field
Result Class See Also
BestBetsPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel BestBetsPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


ErrorMessageLabel Field

Result..::.ErrorMessageLabel Field
Result Class See Also
ErrorMessageLabel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label ErrorMessageLabel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


NoHitsPanel Field

Result..::.NoHitsPanel Field
Result Class See Also
NoHitsPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel NoHitsPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


NoQueryPanel Field

Result..::.NoQueryPanel Field
Result Class See Also
NoQueryPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel NoQueryPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


PageFlicker Field

Result..::.PageFlicker Field
Result Class See Also
PageFlicker control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater PageFlicker

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


PageLinks Field

Result..::.PageLinks Field
Result Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected PageLinkDTOList PageLinks

See Also

Result Class
development.search Namespace


SearchResult Field

Result..::.SearchResult Field
Result Class See Also
SearchResult control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater SearchResult

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


SearchSummary Field

Result..::.SearchSummary Field
Result Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string SearchSummary

See Also

Result Class
development.search Namespace


SortLinkList Field

Result..::.SortLinkList Field
Result Class See Also
SortLinkList control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected DataList SortLinkList

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


SortOrderDateUrl Field

Result..::.SortOrderDateUrl Field
Result Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string SortOrderDateUrl

See Also

Result Class
development.search Namespace


SortOrderRelevanceUrl Field

Result..::.SortOrderRelevanceUrl Field
Result Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string SortOrderRelevanceUrl

See Also

Result Class
development.search Namespace


SortPanel Field

Result..::.SortPanel Field
Result Class See Also
SortPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel SortPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


SpellingPanel Field

Result..::.SpellingPanel Field
Result Class See Also
SpellingPanel control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel SpellingPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


SpellingSuggestion Field

Result..::.SpellingSuggestion Field
Result Class See Also
SpellingSuggestion control.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater SpellingSuggestion

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Result Class
development.search Namespace


Result Methods

[image]

SiteSeeker Search Module SDK (3.3)
Result Methods
Result Class See Also

The Result type exposes the following methods.

Methods

Name | Description
UpdateView | (Overrides EssUserControlBase ..::. UpdateView()()().)

See Also

Result Class
development.search Namespace


UpdateView Method

Result..::.UpdateView Method
Result Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void UpdateView()

See Also

Result Class
development.search Namespace


ShowCache Class

ShowCache Class
Members See Also
Summary description for ShowCache.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class ShowCache : Page

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
development.search..::.ShowCache

See Also

ShowCache Members
development.search Namespace


ShowCache Members

[image]

SiteSeeker Search Module SDK (3.3)
ShowCache Members
ShowCache Class Constructors Methods Fields Properties See Also

The ShowCache type exposes the following members.

Constructors

Name | Description
ShowCache |

Methods

Name | Description
IntArrayToString |
OnInit | (Overrides Page ..::. OnInit(EventArgs).)

Fields

Name | Description
baseUrl |
description |
disclaimer |
docUrl |
firstAnchor |
ilang |
KwicBody |
KwicHeader |
lastAnchor |

Properties

Name | Description
Seeker |

See Also

ShowCache Class
development.search Namespace


ShowCache Constructor

ShowCache Constructor
ShowCache Class See Also
Initializes a new instance of the ShowCache class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ShowCache()

See Also

ShowCache Class
development.search Namespace


ShowCache Fields

[image]

SiteSeeker Search Module SDK (3.3)
ShowCache Fields
ShowCache Class See Also

The ShowCache type exposes the following fields.

Fields

Name | Description
baseUrl |
description |
disclaimer |
docUrl |
firstAnchor |
ilang |
KwicBody |
KwicHeader |
lastAnchor |

See Also

ShowCache Class
development.search Namespace


baseUrl Field

ShowCache..::.baseUrl Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string baseUrl

See Also

ShowCache Class
development.search Namespace


description Field

ShowCache..::.description Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string description

See Also

ShowCache Class
development.search Namespace


disclaimer Field

ShowCache..::.disclaimer Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string disclaimer

See Also

ShowCache Class
development.search Namespace


docUrl Field

ShowCache..::.docUrl Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string docUrl

See Also

ShowCache Class
development.search Namespace


firstAnchor Field

ShowCache..::.firstAnchor Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string firstAnchor

See Also

ShowCache Class
development.search Namespace


ilang Field

ShowCache..::.ilang Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string ilang

See Also

ShowCache Class
development.search Namespace


KwicBody Field

ShowCache..::.KwicBody Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected PlaceHolder KwicBody

See Also

ShowCache Class
development.search Namespace


KwicHeader Field

ShowCache..::.KwicHeader Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected PlaceHolder KwicHeader

See Also

ShowCache Class
development.search Namespace


lastAnchor Field

ShowCache..::.lastAnchor Field
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string lastAnchor

See Also

ShowCache Class
development.search Namespace


ShowCache Methods

[image]

SiteSeeker Search Module SDK (3.3)
ShowCache Methods
ShowCache Class See Also

The ShowCache type exposes the following methods.

Methods

Name | Description
IntArrayToString |
OnInit | (Overrides Page ..::. OnInit(EventArgs).)

See Also

ShowCache Class
development.search Namespace


IntArrayToString Method

ShowCache..::.IntArrayToString Method
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string IntArrayToString(
    int[] array
)

Parameters

array
Type: array< System..::.Int32 >[]()[]

See Also

ShowCache Class
development.search Namespace


OnInit Method

ShowCache..::.OnInit Method
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

ShowCache Class
development.search Namespace


ShowCache Properties

[image]

SiteSeeker Search Module SDK (3.3)
ShowCache Properties
ShowCache Class See Also

The ShowCache type exposes the following properties.

Properties

Name | Description
Seeker |

See Also

ShowCache Class
development.search Namespace


Seeker Property

ShowCache..::.Seeker Property
ShowCache Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected SiteSeeker Seeker { get; }

See Also

ShowCache Class
development.search Namespace


SiteSeekerTreeTab Class

SiteSeekerTreeTab Class
Members See Also
Fliken för att visa statistik i edit-läge.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SiteSeekerTreeTab : UserControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
development.search..::.SiteSeekerTreeTab

See Also

SiteSeekerTreeTab Members
development.search Namespace


SiteSeekerTreeTab Members

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerTreeTab Members
SiteSeekerTreeTab Class Constructors Methods Fields See Also

The SiteSeekerTreeTab type exposes the following members.

Constructors

Name | Description
SiteSeekerTreeTab |

Methods

Name | Description
OnInit | (Overrides UserControl ..::. OnInit(EventArgs).)

Fields

Name | Description
HyperLink1 |

See Also

SiteSeekerTreeTab Class
development.search Namespace


SiteSeekerTreeTab Constructor

SiteSeekerTreeTab Constructor
SiteSeekerTreeTab Class See Also
Initializes a new instance of the SiteSeekerTreeTab class.

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SiteSeekerTreeTab()

See Also

SiteSeekerTreeTab Class
development.search Namespace


SiteSeekerTreeTab Fields

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerTreeTab Fields
SiteSeekerTreeTab Class See Also

The SiteSeekerTreeTab type exposes the following fields.

Fields

Name | Description
HyperLink1 |

See Also

SiteSeekerTreeTab Class
development.search Namespace


HyperLink1 Field

SiteSeekerTreeTab..::.HyperLink1 Field
SiteSeekerTreeTab Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected HyperLink HyperLink1

See Also

SiteSeekerTreeTab Class
development.search Namespace


SiteSeekerTreeTab Methods

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerTreeTab Methods
SiteSeekerTreeTab Class See Also

The SiteSeekerTreeTab type exposes the following methods.

Methods

Name | Description
OnInit | (Overrides UserControl ..::. OnInit(EventArgs).)

See Also

SiteSeekerTreeTab Class
development.search Namespace


OnInit Method

SiteSeekerTreeTab..::.OnInit Method
SiteSeekerTreeTab Class See Also

Namespace: development.search
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

SiteSeekerTreeTab Class
development.search Namespace


development.search.DTO Namespace

development.search.DTO Namespace
Data transfer objects for hits, best bets, filter and other listable data types. Data transfer objects contains view-specfic presentation logic.

Classes

Class | Description
BetDTO | This class represents a best bet, a special kind of hit comparable to a sponsored link.
DTO | A base class for Data Transfer Objects, i.e. DTOs. DTO objects contains ready formated data to be used for generating views in a convient manner. A great amount of the DTOs wraps a particular value object from the namespace SiteSeeker.Model.
DTOList<(Of <(T>)>) | A list of DTO objects. Use this class for generating a list of DTO objects that wraps objects from the SiteSeeker.Model namespace.
FilterDTO | Describes a search filter used for filtering a search result.
FilterGroupDTO | A group of related search filters.
HitDTO | A search hit, describing the document found.
PageLinkDTO | This DTO holds data for generating page links which is used for paginating the search result. A page link has a ClickUrl pointing at the result page with the page number defined by the PageNumber propery.
PageLinkDTOList | A PageLinkDTOList represents a pager for paginating hits in the result A pager allows the user to select which page (i.e. batch of hits) to be displayed. The number of hits to be returned in each batch can be set in the SearchRequest.
QueryRefinementDTO | Describes a spelling suggestion.
SortLinkDTO |
SortLinkDTOList | A list of sort links pointing at different sort orders, e.g., relevance and date.
SpellingSuggestionDTO | Describes a spelling suggestion.


BetDTO Class

BetDTO Class
Members See Also
This class represents a best bet, a special kind of hit comparable to a sponsored link.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class BetDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.BetDTO

See Also

BetDTO Members
development.search.DTO Namespace
SiteSeeker.Model..::.Bet


BetDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
BetDTO Members
BetDTO Class Constructors Methods Fields Properties See Also

The BetDTO type exposes the following members.

Constructors

Name | Description
BetDTO |

Methods

Name | Description
Init | Initializes this DTO. (Overrides DTO ..::. Init(Object).)

Fields

Name | Description
bet |

Properties

Name | Description
BetNumber | Ordinal number of returned best bet, starting with 1.
ClickUrl | The URL to be used for registering user clicks on this best bet. See HitCounter.aspx.
ClickUrlHtml | Same as ClickUrl but with ampersands replaced with HTML enitities.
Description | Description of the bet. The description may contain HTML code.
Title | Title of the best bet. Should be displayed as link text.
Url | The complete URL, including protocol prefix, of the best bet. If URL rewriting is enabled, the original URL is rewritten by using Regex.Replace.
UrlHtml | Same as Url but with ampersands replaced with HTML enitities.

See Also

BetDTO Class
development.search.DTO Namespace


BetDTO Constructor

BetDTO Constructor
BetDTO Class See Also
Initializes a new instance of the BetDTO class.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public BetDTO()

See Also

BetDTO Class
development.search.DTO Namespace


BetDTO Fields

[image]

SiteSeeker Search Module SDK (3.3)
BetDTO Fields
BetDTO Class See Also

The BetDTO type exposes the following fields.

Fields

Name | Description
bet |

See Also

BetDTO Class
development.search.DTO Namespace


bet Field

BetDTO..::.bet Field
BetDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Bet bet

See Also

BetDTO Class
development.search.DTO Namespace


BetDTO Methods

[image]

SiteSeeker Search Module SDK (3.3)
BetDTO Methods
BetDTO Class See Also

The BetDTO type exposes the following methods.

Methods

Name | Description
Init | Initializes this DTO. (Overrides DTO ..::. Init(Object).)

See Also

BetDTO Class
development.search.DTO Namespace


Init Method

BetDTO..::.Init Method
BetDTO Class See Also
Initializes this DTO.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override void Init(
    Object o
)

Parameters

o
Type: System..::.Object
A Bet object.

See Also

BetDTO Class
development.search.DTO Namespace


BetDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
BetDTO Properties
BetDTO Class See Also

The BetDTO type exposes the following properties.

Properties

Name | Description
BetNumber | Ordinal number of returned best bet, starting with 1.
ClickUrl | The URL to be used for registering user clicks on this best bet. See HitCounter.aspx.
ClickUrlHtml | Same as ClickUrl but with ampersands replaced with HTML enitities.
Description | Description of the bet. The description may contain HTML code.
Title | Title of the best bet. Should be displayed as link text.
Url | The complete URL, including protocol prefix, of the best bet. If URL rewriting is enabled, the original URL is rewritten by using Regex.Replace.
UrlHtml | Same as Url but with ampersands replaced with HTML enitities.

See Also

BetDTO Class
development.search.DTO Namespace


BetNumber Property

BetDTO..::.BetNumber Property
BetDTO Class See Also
Ordinal number of returned best bet, starting with 1.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int BetNumber { get; }

See Also

BetDTO Class
development.search.DTO Namespace


ClickUrl Property

BetDTO..::.ClickUrl Property
BetDTO Class See Also
The URL to be used for registering user clicks on this best bet. See HitCounter.aspx.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; }

See Also

BetDTO Class
development.search.DTO Namespace


ClickUrlHtml Property

BetDTO..::.ClickUrlHtml Property
BetDTO Class See Also
Same as ClickUrl but with ampersands replaced with HTML enitities.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrlHtml { get; }

See Also

BetDTO Class
development.search.DTO Namespace


Description Property

BetDTO..::.Description Property
BetDTO Class See Also
Description of the bet. The description may contain HTML code.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Description { get; }

See Also

BetDTO Class
development.search.DTO Namespace


Title Property

BetDTO..::.Title Property
BetDTO Class See Also
Title of the best bet. Should be displayed as link text.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Title { get; }

See Also

BetDTO Class
development.search.DTO Namespace


Url Property

BetDTO..::.Url Property
BetDTO Class See Also
The complete URL, including protocol prefix, of the best bet. If URL rewriting is enabled, the original URL is rewritten by using Regex.Replace.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Url { get; }

See Also

BetDTO Class
development.search.DTO Namespace


UrlHtml Property

BetDTO..::.UrlHtml Property
BetDTO Class See Also
Same as Url but with ampersands replaced with HTML enitities.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string UrlHtml { get; }

See Also

BetDTO Class
development.search.DTO Namespace


DTO Class

DTO Class
Members See Also
A base class for Data Transfer Objects, i.e. DTOs. DTO objects contains ready formated data to be used for generating views in a convient manner. A great amount of the DTOs wraps a particular value object from the namespace SiteSeeker.Model.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.SortLinkDTO
development.search.DTO..::.BetDTO
development.search.DTO..::.FilterDTO
development.search.DTO..::.FilterGroupDTO
development.search.DTO..::.HitDTO
development.search.DTO..::.QueryRefinementDTO
development.search.DTO..::.SpellingSuggestionDTO
development.search.DTO..::.PageLinkDTO

See Also

DTO Members
development.search.DTO Namespace


DTO Members

[image]

SiteSeeker Search Module SDK (3.3)
DTO Members
DTO Class Constructors Methods Properties See Also

The DTO type exposes the following members.

Constructors

Name | Description
DTO |

Methods

Name | Description
CreateKey |
Init | Initialized the DTO based on o which typically is an object from the namespace SiteSeeker.Model.

Properties

Name | Description
Connector | The Connector to be used for translation and other framework dependent tasks.

See Also

DTO Class
development.search.DTO Namespace


DTO Constructor

DTO Constructor
DTO Class See Also
Initializes a new instance of the DTO class.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DTO()

See Also

DTO Class
development.search.DTO Namespace


DTO Methods

[image]

SiteSeeker Search Module SDK (3.3)
DTO Methods
DTO Class See Also

The DTO type exposes the following methods.

Methods

Name | Description
CreateKey |
Init | Initialized the DTO based on o which typically is an object from the namespace SiteSeeker.Model.

See Also

DTO Class
development.search.DTO Namespace


CreateKey Method

DTO..::.CreateKey Method
DTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected static string CreateKey(
    string s
)

Parameters

s
Type: System..::.String

See Also

DTO Class
development.search.DTO Namespace


Init Method

DTO..::.Init Method
DTO Class See Also
Initialized the DTO based on o which typically is an object from the namespace SiteSeeker.Model.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public virtual void Init(
    Object o
)

Parameters

o
Type: System..::.Object
An object (usually from SiteSeeker.Model) to be wrapped by this object.

See Also

DTO Class
development.search.DTO Namespace


DTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
DTO Properties
DTO Class See Also

The DTO type exposes the following properties.

Properties

Name | Description
Connector | The Connector to be used for translation and other framework dependent tasks.

See Also

DTO Class
development.search.DTO Namespace


Connector Property

DTO..::.Connector Property
DTO Class See Also
The Connector to be used for translation and other framework dependent tasks.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Connector Connector { get; set; }

See Also

DTO Class
development.search.DTO Namespace


DTOList(T) Generic Class

DTOList<(Of <(T>)>) Generic Class
Members See Also
A list of DTO objects. Use this class for generating a list of DTO objects that wraps objects from the SiteSeeker.Model namespace.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class DTOList<T> : List<T> where T : new(), DTO

Type Parameters

T

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( T >)>)
development.search.DTO..::.DTOList<(Of <(T>)>)

See Also

DTOList<(Of <(T>)>) Members
development.search.DTO Namespace


DTOList(T) Members

[image]

SiteSeeker Search Module SDK (3.3)
DTOList<(Of <(T>)>) Members
DTOList<(Of <(T>)>) Class Constructors Methods See Also

The DTOList<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
DTOList<(Of <(T>)>) | Constructs a new DTOList.

Methods

Name | Description
Populate<(Of <(M>)>) | Populates the list with DTO objects based on the modelObjects. This method constructs and initializes new DTO objects. See Init(Object).

See Also

DTOList<(Of <(T>)>) Class
development.search.DTO Namespace


DTOList(T) Constructor

DTOList<(Of <(T>)>) Constructor
DTOList<(Of <(T>)>) Class See Also
Constructs a new DTOList.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DTOList(
    Connector c
)

Parameters

c
Type: SiteSeeker.Control..::.Connector
The connector to be used by each DTO object in the list.

See Also

DTOList<(Of <(T>)>) Class
development.search.DTO Namespace


DTOList(T) Methods

[image]

SiteSeeker Search Module SDK (3.3)
DTOList<(Of <(T>)>) Methods
DTOList<(Of <(T>)>) Class See Also

The DTOList<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Populate<(Of <(M>)>) | Populates the list with DTO objects based on the modelObjects. This method constructs and initializes new DTO objects. See Init(Object).

See Also

DTOList<(Of <(T>)>) Class
development.search.DTO Namespace


Populate(M) Generic Method

DTOList<(Of <(T>)>)..::.Populate<(Of <(M>)>) Generic Method
DTOList<(Of <(T>)>) Class See Also
Populates the list with DTO objects based on the modelObjects. This method constructs and initializes new DTO objects. See Init(Object).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void Populate<M>(
    List<M> modelObjects
)

Parameters

modelObjects
Type: System.Collections.Generic..::.List <(Of <(M>)>)

Type Parameters

M

See Also

DTOList<(Of <(T>)>) Class
development.search.DTO Namespace


FilterDTO Class

FilterDTO Class
Members See Also
Describes a search filter used for filtering a search result.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class FilterDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.FilterDTO

See Also

FilterDTO Members
development.search.DTO Namespace
SiteSeeker.Model..::.SearchFilter


FilterDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
FilterDTO Members
FilterDTO Class Constructors Properties See Also

The FilterDTO type exposes the following members.

Constructors

Name | Description
FilterDTO | Constructs a new FilterDTO.

Properties

Name | Description
ClickUrl | Url to apply this filter.
ClickUrlHtml | Same as ClickUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).
ID | The SiteSeeker-specific ID for this search filter.
IsSelected | Indicates wheter this filter is selected.
Name | The name of the search filter.
NameCss |
NameHtml | Same as Name, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).
NHits | The number of documents that matches this search filter.
SelectedCss | Returns the string ess-cat-current if this filter is selected, string.Empty otherwise.

See Also

FilterDTO Class
development.search.DTO Namespace


FilterDTO Constructor

FilterDTO Constructor
FilterDTO Class See Also
Constructs a new FilterDTO.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FilterDTO(
    string name,
    int id,
    int nHits,
    string url,
    bool isSelected
)

Parameters

name
Type: System..::.String
The name of the search filter.
id
Type: System..::.Int32
nHits
Type: System..::.Int32
The number of documents that matches this search filter.
url
Type: System..::.String
The URL to be used for selecting this filter.
isSelected
Type: System..::.Boolean
Indicates wheter this filter is selected.

See Also

FilterDTO Class
development.search.DTO Namespace


FilterDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
FilterDTO Properties
FilterDTO Class See Also

The FilterDTO type exposes the following properties.

Properties

Name | Description
ClickUrl | Url to apply this filter.
ClickUrlHtml | Same as ClickUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).
ID | The SiteSeeker-specific ID for this search filter.
IsSelected | Indicates wheter this filter is selected.
Name | The name of the search filter.
NameCss |
NameHtml | Same as Name, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).
NHits | The number of documents that matches this search filter.
SelectedCss | Returns the string ess-cat-current if this filter is selected, string.Empty otherwise.

See Also

FilterDTO Class
development.search.DTO Namespace


ClickUrl Property

FilterDTO..::.ClickUrl Property
FilterDTO Class See Also
Url to apply this filter.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; set; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded. Suitable for the NavigateUrl property in asp:HyperLink.

See Also

FilterDTO Class
development.search.DTO Namespace


ClickUrlHtml Property

FilterDTO..::.ClickUrlHtml Property
FilterDTO Class See Also
Same as ClickUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrlHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

FilterDTO Class
development.search.DTO Namespace


ID Property

FilterDTO..::.ID Property
FilterDTO Class See Also
The SiteSeeker-specific ID for this search filter.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int ID { get; set; }

Remarks

This property is commonly only used in the search form, and not in the overview or elsewhere.

See Also

FilterDTO Class
development.search.DTO Namespace


IsSelected Property

FilterDTO..::.IsSelected Property
FilterDTO Class See Also
Indicates wheter this filter is selected.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsSelected { get; }

See Also

FilterDTO Class
development.search.DTO Namespace


Name Property

FilterDTO..::.Name Property
FilterDTO Class See Also
The name of the search filter.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Name { get; set; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded. Suitable for the ToolTip property in asp:HyperLink.

See Also

FilterDTO Class
development.search.DTO Namespace


NameCss Property

FilterDTO..::.NameCss Property
FilterDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NameCss { get; }

See Also

FilterDTO Class
development.search.DTO Namespace


NameHtml Property

FilterDTO..::.NameHtml Property
FilterDTO Class See Also
Same as Name, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NameHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

FilterDTO Class
development.search.DTO Namespace


NHits Property

FilterDTO..::.NHits Property
FilterDTO Class See Also
The number of documents that matches this search filter.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NHits { get; }

See Also

FilterDTO Class
development.search.DTO Namespace


SelectedCss Property

FilterDTO..::.SelectedCss Property
FilterDTO Class See Also
Returns the string ess-cat-current if this filter is selected, string.Empty otherwise.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SelectedCss { get; }

See Also

FilterDTO Class
development.search.DTO Namespace


FilterGroupDTO Class

FilterGroupDTO Class
Members See Also
A group of related search filters.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class FilterGroupDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.FilterGroupDTO

See Also

FilterGroupDTO Members
development.search.DTO Namespace


FilterGroupDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
FilterGroupDTO Members
FilterGroupDTO Class Constructors Methods Properties See Also

The FilterGroupDTO type exposes the following members.

Constructors

Name | Description
FilterGroupDTO | Overloaded.

Methods

Name | Description
AddFilters<(Of <(T>)>) | Adds a collection of search filters to this group.
AllElementsExcept | Returns the search filters in this filter group except search filters having an id matching the specifed parameter values

Properties

Name | Description
Filters | The search filters in this filter group.
Name | The name of the filter group.
NameHtml | Same as Name, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).

See Also

FilterGroupDTO Class
development.search.DTO Namespace


FilterGroupDTO Constructor

[image]

SiteSeeker Search Module SDK (3.3)
FilterGroupDTO Constructor
FilterGroupDTO Class See Also

Overload List

Name | Description
FilterGroupDTO(String, Connector, String, SearchFilter, String) | Constructs a new FilterGroupDTO
FilterGroupDTO(String, Connector, String, array<SearchFilter>[]()[], String) | Constructs a new FilterGroupDTO

See Also

FilterGroupDTO Class
FilterGroupDTO Members
development.search.DTO Namespace


FilterGroupDTO Constructor (String, Connector, String, SearchFilter, String)

FilterGroupDTO Constructor (String, Connector, String, SearchFilter, String)
FilterGroupDTO Class See Also
Constructs a new FilterGroupDTO

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FilterGroupDTO(
    string name,
    Connector c,
    string parameterName,
    SearchFilter selectedFilter,
    string translationPath
)

Parameters

name
Type: System..::.String
The name of the filter group.
c
Type: SiteSeeker.Control..::.Connector
A connector instance
parameterName
Type: System..::.String
The name of the HTTP parameter to use for constructing URL:s for each filter.
selectedFilter
Type: SiteSeeker.Model..::.SearchFilter
The selected filter in this group
translationPath
Type: System..::.String
The path to the XML element for this filter in the language file. This value will be concatenated with the SiteSeker.Model.SearchFilter.Key in order to lookup the names of the filters.

See Also

FilterGroupDTO Class
FilterGroupDTO Overload
development.search.DTO Namespace
SiteSeeker.Model..::.SearchFilter


FilterGroupDTO Constructor (String, Connector, String, SearchFilter[], String)

FilterGroupDTO Constructor (String, Connector, String, array<SearchFilter>[]()[], String)
FilterGroupDTO Class See Also
Constructs a new FilterGroupDTO

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FilterGroupDTO(
    string name,
    Connector c,
    string parameterName,
    SearchFilter[] selectedFilters,
    string translationPath
)

Parameters

name
Type: System..::.String
The name of the filter group.
c
Type: SiteSeeker.Control..::.Connector
A connector instance
parameterName
Type: System..::.String
The name of the HTTP parameter to use for constructing URL:s for each filter.
selectedFilters
Type: array< SiteSeeker.Model..::.SearchFilter >[]()[]
An array of the selected filters in this group
translationPath
Type: System..::.String
The path to the XML element for this filter in the language file. This value will be concatenated with the SiteSeker.Model.SearchFilter.Key in order to lookup the names of the filters.

See Also

FilterGroupDTO Class
FilterGroupDTO Overload
development.search.DTO Namespace
SiteSeeker.Model..::.SearchFilter


FilterGroupDTO Methods

[image]

SiteSeeker Search Module SDK (3.3)
FilterGroupDTO Methods
FilterGroupDTO Class See Also

The FilterGroupDTO type exposes the following methods.

Methods

Name | Description
AddFilters<(Of <(T>)>) | Adds a collection of search filters to this group.
AllElementsExcept | Returns the search filters in this filter group except search filters having an id matching the specifed parameter values

See Also

FilterGroupDTO Class
development.search.DTO Namespace


AddFilters(T) Generic Method

FilterGroupDTO..::.AddFilters<(Of <(T>)>) Generic Method
FilterGroupDTO Class See Also
Adds a collection of search filters to this group.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void AddFilters<T>(
    List<T> filters
) where T : SearchFilter

Parameters

filters
Type: System.Collections.Generic..::.List <(Of <(T>)>)

Type Parameters

T

See Also

FilterGroupDTO Class
development.search.DTO Namespace


AllElementsExcept Method

FilterGroupDTO..::.AllElementsExcept Method
FilterGroupDTO Class See Also
Returns the search filters in this filter group except search filters having an id matching the specifed parameter values

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<FilterDTO> AllElementsExcept(
    params int[] ids
)

Parameters

ids
Type: array< System..::.Int32 >[]()[]
One or more ids of the search filters to be excluded from the list to be returned.

Return Value

All the search filters except filters having an id matching any of the specifed parameter values.

See Also

FilterGroupDTO Class
development.search.DTO Namespace


FilterGroupDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
FilterGroupDTO Properties
FilterGroupDTO Class See Also

The FilterGroupDTO type exposes the following properties.

Properties

Name | Description
Filters | The search filters in this filter group.
Name | The name of the filter group.
NameHtml | Same as Name, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).

See Also

FilterGroupDTO Class
development.search.DTO Namespace


Filters Property

FilterGroupDTO..::.Filters Property
FilterGroupDTO Class See Also
The search filters in this filter group.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<FilterDTO> Filters { get; }

See Also

FilterGroupDTO Class
development.search.DTO Namespace


Name Property

FilterGroupDTO..::.Name Property
FilterGroupDTO Class See Also
The name of the filter group.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Name { get; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded. Suitable for the ToolTip property in asp:HyperLink.

See Also

FilterGroupDTO Class
development.search.DTO Namespace


NameHtml Property

FilterGroupDTO..::.NameHtml Property
FilterGroupDTO Class See Also
Same as Name, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &mp;).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NameHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

FilterGroupDTO Class
development.search.DTO Namespace


HitDTO Class

HitDTO Class
Members See Also
A search hit, describing the document found.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class HitDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.HitDTO

See Also

HitDTO Members
development.search.DTO Namespace
SiteSeeker.Model..::.Hit


HitDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
HitDTO Members
HitDTO Class Constructors Methods Fields Properties See Also

The HitDTO type exposes the following members.

Constructors

Name | Description
HitDTO |

Methods

Name | Description
Init | Initializes the HitDTO. (Overrides DTO ..::. Init(Object).)

Fields

Name | Description
hit |

Properties

Name Description
Attachments
Attachments to this hit (i.e. this hit is a cover page). Please note that this list may be empty, even if AttachmentsTotalCount is non-zero.
AttachmentsTotalCount
Total number of attachments for this hit. Please note that the returned number of attachments (i.e. HitDTO.Attachments.Count) may be lower than the total number of attachments.
CacheUrl
URL to the ShowCache page that displays a cached snapshot of a hit (page/document) with the query terms highlighted. Add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.
CacheUrlHtml
Same as CacheUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;).
CategoriesStr
A string containing a formatted list of the categories to which this hit belong. Category group names are marked with the HTML tag <strong>.
ClickUrl
The URL to be used for registering user clicks on this hit. See HitCounter.aspx.
ClickUrlHtml
Same as ClickUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;).
ContextLink
URL of the document containing the image (including protocol prefix). This property is only defined when the hit is an image.
ContextLinkHtml
Same as ContextLink, but formatted for output, with XML special characters encoded (e.g. & is encoded as &amp;).
CssCategory
A white space separated list of the names of the categories to which this hit belong. This value can e.g. be used as a css class name. The name has the format ess-c-CATGROUP_CAT, where CAT and CATGROUP are the name of the category/group but with white spaces replaced by underscores and non ASCII characters are replaced by the characters a-z/A-Z.
CssCatGroup
A white space separated list of the names of the category groups to which this hit belong. This value can e.g. be used as a css class name. The name has the format ess-g-CATGROUP, where CATGROUP is the name of the category group but with white spaces replaced by underscores and non ASCII characters are replaced by the characters a-z/A-Z.
Date
The modification date of the document.
Description
Text extract from document containing query terms if present. Occurrences of query terms are marked with the HTML tag <strong>.
DocumentID
The identifier of the document. The id is used for access control of the hit.
FileFormatIcon
The file name of the graphic icon representing the file format of this hit. If no icon exist for the current file format, a default document icon is used.
FileFormatKey
A logical name of the file format. This name can e.g. be used for generating css class names.
FileFormatName
The name of the file format of the document of this hit.
HasAttachments
True if this hit has attachments (i.e. is a cover page). Please note that this property may be false, even if AttachmentsTotalCount is non-zero.
HasCategories
Indicates wheter the document of this hit belongs to a category.
HasMoreAttachments
Indicates if this his hase more attachments than those that are returned with the hit, e.g. if AttachmentsTotalCount is higher than
CopyC#
Attachments.Count
.
HitNumber
The ordinal number of the hit in the result, starting with 1.
IndexedAttachmentCount Obsolete.
Deprecated. Please use AttachmentsTotalCount instead.
InFrame
Indicates whether indexed document was found in a frame or not.
IsImage
Indicates wheter this hit is an image.
LinkTitle
A special formatted title of the hit intended to be used as link title (i.e. inside an HTML anchor element). This title is prefixed by the file format.
MetaAttributes
A map of meta attributes contained in the document.
MetaDescription
The meta description of the document of the hit (or other meta data defined to be used as decription).
Rank
The rank of the hit. Value between 0 and 30, higher value corresponds to higher ranking.
Size
The size in bytes of the document of the hit.
SourceLink
The original URL of the document (including protocol prefix).
SpecialText
Special text extract from the document of the hit. Such extracts can be defined using certain HTML comments in the document. May contain HTML code.
Title
The title of the document of the hit. The search engine migth modify the title if the original title is considered bad. Occurrences of query terms are marked with the HTML tag <strong>.
Url
The URL of the document. If URL rewriting is enabled, the original URL (SourceLink) is rewritten by using Regex.Replace. Otherwise, Url is identical to SourceLink. Compare to UrlHtml, where this property may be used in asp:HyperLink's NavigateUrl argument.
UrlHtml
Same as Url, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;). This property may be used e.g. in an <%# Eval("UrlHtml"); %> statement.

See Also

HitDTO Class
development.search.DTO Namespace


HitDTO Constructor

HitDTO Constructor
HitDTO Class See Also
Initializes a new instance of the HitDTO class.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public HitDTO()

See Also

HitDTO Class
development.search.DTO Namespace


HitDTO Fields

[image]

SiteSeeker Search Module SDK (3.3)
HitDTO Fields
HitDTO Class See Also

The HitDTO type exposes the following fields.

Fields

Name | Description
hit |

See Also

HitDTO Class
development.search.DTO Namespace


hit Field

HitDTO..::.hit Field
HitDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Hit hit

See Also

HitDTO Class
development.search.DTO Namespace


HitDTO Methods

[image]

SiteSeeker Search Module SDK (3.3)
HitDTO Methods
HitDTO Class See Also

The HitDTO type exposes the following methods.

Methods

Name | Description
Init | Initializes the HitDTO. (Overrides DTO ..::. Init(Object).)

See Also

HitDTO Class
development.search.DTO Namespace


Init Method

HitDTO..::.Init Method
HitDTO Class See Also
Initializes the HitDTO.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override void Init(
    Object o
)

Parameters

o
Type: System..::.Object
An instance of Hit

See Also

HitDTO Class
development.search.DTO Namespace


HitDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
HitDTO Properties
HitDTO Class See Also

The HitDTO type exposes the following properties.

Properties

Name Description
Attachments
Attachments to this hit (i.e. this hit is a cover page). Please note that this list may be empty, even if AttachmentsTotalCount is non-zero.
AttachmentsTotalCount
Total number of attachments for this hit. Please note that the returned number of attachments (i.e. HitDTO.Attachments.Count) may be lower than the total number of attachments.
CacheUrl
URL to the ShowCache page that displays a cached snapshot of a hit (page/document) with the query terms highlighted. Add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.
CacheUrlHtml
Same as CacheUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;).
CategoriesStr
A string containing a formatted list of the categories to which this hit belong. Category group names are marked with the HTML tag <strong>.
ClickUrl
The URL to be used for registering user clicks on this hit. See HitCounter.aspx.
ClickUrlHtml
Same as ClickUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;).
ContextLink
URL of the document containing the image (including protocol prefix). This property is only defined when the hit is an image.
ContextLinkHtml
Same as ContextLink, but formatted for output, with XML special characters encoded (e.g. & is encoded as &amp;).
CssCategory
A white space separated list of the names of the categories to which this hit belong. This value can e.g. be used as a css class name. The name has the format ess-c-CATGROUP_CAT, where CAT and CATGROUP are the name of the category/group but with white spaces replaced by underscores and non ASCII characters are replaced by the characters a-z/A-Z.
CssCatGroup
A white space separated list of the names of the category groups to which this hit belong. This value can e.g. be used as a css class name. The name has the format ess-g-CATGROUP, where CATGROUP is the name of the category group but with white spaces replaced by underscores and non ASCII characters are replaced by the characters a-z/A-Z.
Date
The modification date of the document.
Description
Text extract from document containing query terms if present. Occurrences of query terms are marked with the HTML tag <strong>.
DocumentID
The identifier of the document. The id is used for access control of the hit.
FileFormatIcon
The file name of the graphic icon representing the file format of this hit. If no icon exist for the current file format, a default document icon is used.
FileFormatKey
A logical name of the file format. This name can e.g. be used for generating css class names.
FileFormatName
The name of the file format of the document of this hit.
HasAttachments
True if this hit has attachments (i.e. is a cover page). Please note that this property may be false, even if AttachmentsTotalCount is non-zero.
HasCategories
Indicates wheter the document of this hit belongs to a category.
HasMoreAttachments
Indicates if this his hase more attachments than those that are returned with the hit, e.g. if AttachmentsTotalCount is higher than
CopyC#
Attachments.Count
.
HitNumber
The ordinal number of the hit in the result, starting with 1.
IndexedAttachmentCount Obsolete.
Deprecated. Please use AttachmentsTotalCount instead.
InFrame
Indicates whether indexed document was found in a frame or not.
IsImage
Indicates wheter this hit is an image.
LinkTitle
A special formatted title of the hit intended to be used as link title (i.e. inside an HTML anchor element). This title is prefixed by the file format.
MetaAttributes
A map of meta attributes contained in the document.
MetaDescription
The meta description of the document of the hit (or other meta data defined to be used as decription).
Rank
The rank of the hit. Value between 0 and 30, higher value corresponds to higher ranking.
Size
The size in bytes of the document of the hit.
SourceLink
The original URL of the document (including protocol prefix).
SpecialText
Special text extract from the document of the hit. Such extracts can be defined using certain HTML comments in the document. May contain HTML code.
Title
The title of the document of the hit. The search engine migth modify the title if the original title is considered bad. Occurrences of query terms are marked with the HTML tag <strong>.
Url
The URL of the document. If URL rewriting is enabled, the original URL (SourceLink) is rewritten by using Regex.Replace. Otherwise, Url is identical to SourceLink. Compare to UrlHtml, where this property may be used in asp:HyperLink's NavigateUrl argument.
UrlHtml
Same as Url, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;). This property may be used e.g. in an <%# Eval("UrlHtml"); %> statement.

See Also

HitDTO Class
development.search.DTO Namespace


Attachments Property

HitDTO..::.Attachments Property
HitDTO Class See Also
Attachments to this hit (i.e. this hit is a cover page). Please note that this list may be empty, even if AttachmentsTotalCount is non-zero.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<HitDTO> Attachments { get; }

See Also

HitDTO Class
development.search.DTO Namespace


AttachmentsTotalCount Property

HitDTO..::.AttachmentsTotalCount Property
HitDTO Class See Also
Total number of attachments for this hit. Please note that the returned number of attachments (i.e. HitDTO.Attachments.Count) may be lower than the total number of attachments.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int AttachmentsTotalCount { get; }

Remarks

Value cannot be negative.

See Also

HitDTO Class
development.search.DTO Namespace


CacheUrl Property

HitDTO..::.CacheUrl Property
HitDTO Class See Also
URL to the ShowCache page that displays a cached snapshot of a hit (page/document) with the query terms highlighted. Add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CacheUrl { get; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded.

See Also

HitDTO Class
development.search.DTO Namespace


CacheUrlHtml Property

HitDTO..::.CacheUrlHtml Property
HitDTO Class See Also
Same as CacheUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CacheUrlHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

HitDTO Class
development.search.DTO Namespace


CategoriesStr Property

HitDTO..::.CategoriesStr Property
HitDTO Class Example See Also
A string containing a formatted list of the categories to which this hit belong. Category group names are marked with the HTML tag <strong>.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CategoriesStr { get; }

Remarks

This string contains XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) and <strong>...</strong> tags.

Examples

Typical contents for a hit that has two categories, Stockholm and London:
CopyC#
<strong class="ess-groupname">Cities:</strong> Stockholm, London

See Also

HitDTO Class
development.search.DTO Namespace


ClickUrl Property

HitDTO..::.ClickUrl Property
HitDTO Class See Also
The URL to be used for registering user clicks on this hit. See HitCounter.aspx.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded.

See Also

HitDTO Class
development.search.DTO Namespace


ClickUrlHtml Property

HitDTO..::.ClickUrlHtml Property
HitDTO Class See Also
Same as ClickUrl, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrlHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

HitDTO Class
development.search.DTO Namespace


ContextLink Property

HitDTO..::.ContextLink Property
HitDTO Class See Also
URL of the document containing the image (including protocol prefix). This property is only defined when the hit is an image.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ContextLink { get; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded.

See Also

HitDTO Class
development.search.DTO Namespace


ContextLinkHtml Property

HitDTO..::.ContextLinkHtml Property
HitDTO Class See Also
Same as ContextLink, but formatted for output, with XML special characters encoded (e.g. & is encoded as &amp;).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ContextLinkHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

HitDTO Class
development.search.DTO Namespace


CssCategory Property

HitDTO..::.CssCategory Property
HitDTO Class See Also
A white space separated list of the names of the categories to which this hit belong. This value can e.g. be used as a css class name. The name has the format ess-c-CATGROUP_CAT, where CAT and CATGROUP are the name of the category/group but with white spaces replaced by underscores and non ASCII characters are replaced by the characters a-z/A-Z.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CssCategory { get; }

See Also

HitDTO Class
development.search.DTO Namespace


CssCatGroup Property

HitDTO..::.CssCatGroup Property
HitDTO Class See Also
A white space separated list of the names of the category groups to which this hit belong. This value can e.g. be used as a css class name. The name has the format ess-g-CATGROUP, where CATGROUP is the name of the category group but with white spaces replaced by underscores and non ASCII characters are replaced by the characters a-z/A-Z.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CssCatGroup { get; }

See Also

HitDTO Class
development.search.DTO Namespace


Date Property

HitDTO..::.Date Property
HitDTO Class See Also
The modification date of the document.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Date { get; }

See Also

HitDTO Class
development.search.DTO Namespace


Description Property

HitDTO..::.Description Property
HitDTO Class See Also
Text extract from document containing query terms if present. Occurrences of query terms are marked with the HTML tag <strong>.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Description { get; }

Remarks

This string contains XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) and <strong>...</strong> tags.

See Also

HitDTO Class
development.search.DTO Namespace


DocumentID Property

HitDTO..::.DocumentID Property
HitDTO Class See Also
The identifier of the document. The id is used for access control of the hit.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string DocumentID { get; }

Remarks

This string contains the document/page ID, exactly as found in the page.

See Also

HitDTO Class
development.search.DTO Namespace


FileFormatIcon Property

HitDTO..::.FileFormatIcon Property
HitDTO Class See Also
The file name of the graphic icon representing the file format of this hit. If no icon exist for the current file format, a default document icon is used.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string FileFormatIcon { get; }

See Also

HitDTO Class
development.search.DTO Namespace


FileFormatKey Property

HitDTO..::.FileFormatKey Property
HitDTO Class See Also
A logical name of the file format. This name can e.g. be used for generating css class names.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string FileFormatKey { get; }

See Also

HitDTO Class
development.search.DTO Namespace


FileFormatName Property

HitDTO..::.FileFormatName Property
HitDTO Class See Also
The name of the file format of the document of this hit.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string FileFormatName { get; }

See Also

HitDTO Class
development.search.DTO Namespace


HasAttachments Property

HitDTO..::.HasAttachments Property
HitDTO Class See Also
True if this hit has attachments (i.e. is a cover page). Please note that this property may be false, even if AttachmentsTotalCount is non-zero.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool HasAttachments { get; }

See Also

HitDTO Class
development.search.DTO Namespace


HasCategories Property

HitDTO..::.HasCategories Property
HitDTO Class See Also
Indicates wheter the document of this hit belongs to a category.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool HasCategories { get; }

See Also

HitDTO Class
development.search.DTO Namespace


HasMoreAttachments Property

HitDTO..::.HasMoreAttachments Property
HitDTO Class See Also
Indicates if this his hase more attachments than those that are returned with the hit, e.g. if AttachmentsTotalCount is higher than
CopyC#
Attachments.Count
.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool HasMoreAttachments { get; }

Remarks

Will return true if AttachmentsTotalCount is non-zero and Attachments is null or empty.

See Also

HitDTO Class
development.search.DTO Namespace


HitNumber Property

HitDTO..::.HitNumber Property
HitDTO Class See Also
The ordinal number of the hit in the result, starting with 1.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int HitNumber { get; }

See Also

HitDTO Class
development.search.DTO Namespace


IndexedAttachmentCount Property

HitDTO..::.IndexedAttachmentCount Property
HitDTO Class See Also
Deprecated. Please use AttachmentsTotalCount instead.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
[ObsoleteAttribute("Use AttachmentsTotalCount instead.")]
public int IndexedAttachmentCount { get; }

See Also

HitDTO Class
development.search.DTO Namespace


InFrame Property

HitDTO..::.InFrame Property
HitDTO Class See Also
Indicates whether indexed document was found in a frame or not.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool InFrame { get; }

See Also

HitDTO Class
development.search.DTO Namespace


IsImage Property

HitDTO..::.IsImage Property
HitDTO Class See Also
Indicates wheter this hit is an image.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsImage { get; }

See Also

HitDTO Class
development.search.DTO Namespace


LinkTitle Property

HitDTO..::.LinkTitle Property
HitDTO Class See Also
A special formatted title of the hit intended to be used as link title (i.e. inside an HTML anchor element). This title is prefixed by the file format.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string LinkTitle { get; }

Remarks

This string contains XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

HitDTO Class
development.search.DTO Namespace


MetaAttributes Property

HitDTO..::.MetaAttributes Property
HitDTO Class See Also
A map of meta attributes contained in the document.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public MetaAttributes MetaAttributes { get; }

See Also

HitDTO Class
development.search.DTO Namespace


MetaDescription Property

HitDTO..::.MetaDescription Property
HitDTO Class See Also
The meta description of the document of the hit (or other meta data defined to be used as decription).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string MetaDescription { get; }

Remarks

This string contains XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) and <strong>...</strong> tags.

See Also

HitDTO Class
development.search.DTO Namespace


Rank Property

HitDTO..::.Rank Property
HitDTO Class See Also
The rank of the hit. Value between 0 and 30, higher value corresponds to higher ranking.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int Rank { get; }

See Also

HitDTO Class
development.search.DTO Namespace


Size Property

HitDTO..::.Size Property
HitDTO Class See Also
The size in bytes of the document of the hit.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Size { get; }

See Also

HitDTO Class
development.search.DTO Namespace


SourceLink Property

HitDTO..::.SourceLink Property
HitDTO Class See Also
The original URL of the document (including protocol prefix).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SourceLink { get; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded.

See Also

HitDTO Class
development.search.DTO Namespace


SpecialText Property

HitDTO..::.SpecialText Property
HitDTO Class See Also
Special text extract from the document of the hit. Such extracts can be defined using certain HTML comments in the document. May contain HTML code.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SpecialText { get; }

Remarks

This string contains XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;), and may contain HTML (valid or invalid) and HTML entities. Since this string is read from the indexed pages (<!--eri-desc--> blocks), it may be advisable to check for common HTML insertion attacks if indexing external pages.

See Also

HitDTO Class
development.search.DTO Namespace


Title Property

HitDTO..::.Title Property
HitDTO Class See Also
The title of the document of the hit. The search engine migth modify the title if the original title is considered bad. Occurrences of query terms are marked with the HTML tag <strong>.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Title { get; }

Remarks

This string contains XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) and <strong>...</strong> tags.

See Also

HitDTO Class
development.search.DTO Namespace


Url Property

HitDTO..::.Url Property
HitDTO Class See Also
The URL of the document. If URL rewriting is enabled, the original URL (SourceLink) is rewritten by using Regex.Replace. Otherwise, Url is identical to SourceLink. Compare to UrlHtml, where this property may be used in asp:HyperLink's NavigateUrl argument.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Url { get; }

Remarks

This string contains no XML entities, i.e. & (ampersand) is not encoded.

See Also

HitDTO Class
development.search.DTO Namespace


UrlHtml Property

HitDTO..::.UrlHtml Property
HitDTO Class See Also
Same as Url, but formatted for direct output, with XML special characters encoded (e.g. & is encoded as &amp;). This property may be used e.g. in an <%# Eval("UrlHtml"); %> statement.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string UrlHtml { get; }

Remarks

This string may contain XML entities (&amp;, &quot;, &apos;, &gt;, and &lt;) but no HTML markup.

See Also

HitDTO Class
development.search.DTO Namespace


PageLinkDTO Class

PageLinkDTO Class
Members See Also
This DTO holds data for generating page links which is used for paginating the search result. A page link has a ClickUrl pointing at the result page with the page number defined by the PageNumber propery.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class PageLinkDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.PageLinkDTO

See Also

PageLinkDTO Members
development.search.DTO Namespace


PageLinkDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTO Members
PageLinkDTO Class Constructors Fields Properties See Also

The PageLinkDTO type exposes the following members.

Constructors

Name | Description
PageLinkDTO | Overloaded.

Fields

Name | Description
Hidden | An instanace of a PageLinkDTO representing a hidden page link in the pager. A hidden page link is usually displayed as dots (...) in the pager view.

Properties

Name | Description
ClickUrl | The URL pointing at the result page.
IsHidden | Determines wheter this page link is hidden in the pager. A hidden page link is usually displayed as dots (...) in the pager view.
IsSelected | Determines wheter this page link points at the currently viewed/selected page.
PageNumber | The number of the search result page that this link points at. First page has page number number 1.

See Also

PageLinkDTO Class
development.search.DTO Namespace


PageLinkDTO Constructor

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTO Constructor
PageLinkDTO Class See Also

Overload List

Name | Description
PageLinkDTO(Int32, String, Boolean) | Constructs a new PageLinkDTO
PageLinkDTO(Int32, String, Boolean, Boolean) | Constructs a new PageLinkDTO

See Also

PageLinkDTO Class
PageLinkDTO Members
development.search.DTO Namespace


PageLinkDTO Constructor (Int32, String, Boolean)

PageLinkDTO Constructor (Int32, String, Boolean)
PageLinkDTO Class See Also
Constructs a new PageLinkDTO

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public PageLinkDTO(
    int pageNumber,
    string url,
    bool isSelected
)

Parameters

pageNumber
Type: System..::.Int32
The page number, first page has page number 1
url
Type: System..::.String
The URL pointing at the search result page
isSelected
Type: System..::.Boolean
If this page is currently selected/viewed in the pager

See Also

PageLinkDTO Class
PageLinkDTO Overload
development.search.DTO Namespace


PageLinkDTO Constructor (Int32, String, Boolean, Boolean)

PageLinkDTO Constructor (Int32, String, Boolean, Boolean)
PageLinkDTO Class See Also
Constructs a new PageLinkDTO

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public PageLinkDTO(
    int pageNumber,
    string url,
    bool isSelected,
    bool isHidden
)

Parameters

pageNumber
Type: System..::.Int32
The page number, first page has page number 1
url
Type: System..::.String
The URL pointing at the search result page
isSelected
Type: System..::.Boolean
If this page is currently selected/viewed in the pager
isHidden
Type: System..::.Boolean
If this page is hidden in the pager

See Also

PageLinkDTO Class
PageLinkDTO Overload
development.search.DTO Namespace


PageLinkDTO Fields

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTO Fields
PageLinkDTO Class See Also

The PageLinkDTO type exposes the following fields.

Fields

Name | Description
Hidden | An instanace of a PageLinkDTO representing a hidden page link in the pager. A hidden page link is usually displayed as dots (...) in the pager view.

See Also

PageLinkDTO Class
development.search.DTO Namespace


Hidden Field

PageLinkDTO..::.Hidden Field
PageLinkDTO Class See Also
An instanace of a PageLinkDTO representing a hidden page link in the pager. A hidden page link is usually displayed as dots (...) in the pager view.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static PageLinkDTO Hidden

See Also

PageLinkDTO Class
development.search.DTO Namespace


PageLinkDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTO Properties
PageLinkDTO Class See Also

The PageLinkDTO type exposes the following properties.

Properties

Name | Description
ClickUrl | The URL pointing at the result page.
IsHidden | Determines wheter this page link is hidden in the pager. A hidden page link is usually displayed as dots (...) in the pager view.
IsSelected | Determines wheter this page link points at the currently viewed/selected page.
PageNumber | The number of the search result page that this link points at. First page has page number number 1.

See Also

PageLinkDTO Class
development.search.DTO Namespace


ClickUrl Property

PageLinkDTO..::.ClickUrl Property
PageLinkDTO Class See Also
The URL pointing at the result page.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; }

See Also

PageLinkDTO Class
development.search.DTO Namespace


IsHidden Property

PageLinkDTO..::.IsHidden Property
PageLinkDTO Class See Also
Determines wheter this page link is hidden in the pager. A hidden page link is usually displayed as dots (...) in the pager view.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsHidden { get; }

See Also

PageLinkDTO Class
development.search.DTO Namespace


IsSelected Property

PageLinkDTO..::.IsSelected Property
PageLinkDTO Class See Also
Determines wheter this page link points at the currently viewed/selected page.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsSelected { get; }

See Also

PageLinkDTO Class
development.search.DTO Namespace


PageNumber Property

PageLinkDTO..::.PageNumber Property
PageLinkDTO Class See Also
The number of the search result page that this link points at. First page has page number number 1.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int PageNumber { get; }

See Also

PageLinkDTO Class
development.search.DTO Namespace


PageLinkDTOList Class

PageLinkDTOList Class
Members See Also
A PageLinkDTOList represents a pager for paginating hits in the result A pager allows the user to select which page (i.e. batch of hits) to be displayed. The number of hits to be returned in each batch can be set in the SearchRequest.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class PageLinkDTOList : List<PageLinkDTO>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( PageLinkDTO >)>)
development.search.DTO..::.PageLinkDTOList

See Also

PageLinkDTOList Members
development.search.DTO Namespace


PageLinkDTOList Members

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTOList Members
PageLinkDTOList Class Constructors Methods Properties See Also

The PageLinkDTOList type exposes the following members.

Constructors

Name | Description
PageLinkDTOList | Constructs a new PageLinkDTOList.

Methods

Name | Description
Add | Adds a page link to this pager.
CreatePageLinks | Creates the list of page links.

Properties

Name | Description
NextExist | Returns true if the search result contains batches with batch numbers greater than the current page number.
NextUrl | The URL to the next page/batch (current page number + 1). If a next page does not exist, this method returns null.
NVisiblePageLinks | The number of visible page links in the pager. Hidden page links will appear in the pager if the number of batches for the current SearchResponse exceed the number of visible page links.
PreviousExist | Returns true if the current page/batch number is greater than 1, i.e. previous page(s) exist.
PreviousUrl | The URL to the previous page/batch (current page number - 1). If a next page does not exist, this method returns null.

See Also

PageLinkDTOList Class
development.search.DTO Namespace


PageLinkDTOList Constructor

PageLinkDTOList Constructor
PageLinkDTOList Class See Also
Constructs a new PageLinkDTOList.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public PageLinkDTOList(
    Connector connector
)

Parameters

connector
Type: SiteSeeker.Control..::.Connector
The connector to be used for accessing the current search response.

See Also

PageLinkDTOList Class
development.search.DTO Namespace


PageLinkDTOList Methods

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTOList Methods
PageLinkDTOList Class See Also

The PageLinkDTOList type exposes the following methods.

Methods

Name | Description
Add | Adds a page link to this pager.
CreatePageLinks | Creates the list of page links.

See Also

PageLinkDTOList Class
development.search.DTO Namespace


Add Method

PageLinkDTOList..::.Add Method
PageLinkDTOList Class See Also
Adds a page link to this pager.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void Add(
    int batchNumber
)

Parameters

batchNumber
Type: System..::.Int32
The batch/page number for the page link to add.

See Also

PageLinkDTOList Class
development.search.DTO Namespace


CreatePageLinks Method

PageLinkDTOList..::.CreatePageLinks Method
PageLinkDTOList Class See Also
Creates the list of page links.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void CreatePageLinks()

See Also

PageLinkDTOList Class
development.search.DTO Namespace


PageLinkDTOList Properties

[image]

SiteSeeker Search Module SDK (3.3)
PageLinkDTOList Properties
PageLinkDTOList Class See Also

The PageLinkDTOList type exposes the following properties.

Properties

Name | Description
NextExist | Returns true if the search result contains batches with batch numbers greater than the current page number.
NextUrl | The URL to the next page/batch (current page number + 1). If a next page does not exist, this method returns null.
NVisiblePageLinks | The number of visible page links in the pager. Hidden page links will appear in the pager if the number of batches for the current SearchResponse exceed the number of visible page links.
PreviousExist | Returns true if the current page/batch number is greater than 1, i.e. previous page(s) exist.
PreviousUrl | The URL to the previous page/batch (current page number - 1). If a next page does not exist, this method returns null.

See Also

PageLinkDTOList Class
development.search.DTO Namespace


NextExist Property

PageLinkDTOList..::.NextExist Property
PageLinkDTOList Class See Also
Returns true if the search result contains batches with batch numbers greater than the current page number.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool NextExist { get; }

See Also

PageLinkDTOList Class
development.search.DTO Namespace


NextUrl Property

PageLinkDTOList..::.NextUrl Property
PageLinkDTOList Class See Also
The URL to the next page/batch (current page number + 1). If a next page does not exist, this method returns null.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NextUrl { get; }

See Also

PageLinkDTOList Class
development.search.DTO Namespace


NVisiblePageLinks Property

PageLinkDTOList..::.NVisiblePageLinks Property
PageLinkDTOList Class See Also
The number of visible page links in the pager. Hidden page links will appear in the pager if the number of batches for the current SearchResponse exceed the number of visible page links.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NVisiblePageLinks { get; set; }

See Also

PageLinkDTOList Class
development.search.DTO Namespace


PreviousExist Property

PageLinkDTOList..::.PreviousExist Property
PageLinkDTOList Class See Also
Returns true if the current page/batch number is greater than 1, i.e. previous page(s) exist.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool PreviousExist { get; }

See Also

PageLinkDTOList Class
development.search.DTO Namespace


PreviousUrl Property

PageLinkDTOList..::.PreviousUrl Property
PageLinkDTOList Class See Also
The URL to the previous page/batch (current page number - 1). If a next page does not exist, this method returns null.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string PreviousUrl { get; }

See Also

PageLinkDTOList Class
development.search.DTO Namespace


QueryRefinementDTO Class

QueryRefinementDTO Class
Members See Also
Describes a spelling suggestion.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class QueryRefinementDTO : DTO, IComparable

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.QueryRefinementDTO

See Also

QueryRefinementDTO Members
development.search.DTO Namespace
[!:SiteSeeker.Model.CO]


QueryRefinementDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
QueryRefinementDTO Members
QueryRefinementDTO Class Constructors Methods Fields Properties See Also

The QueryRefinementDTO type exposes the following members.

Constructors

Name | Description
QueryRefinementDTO |

Methods

Name | Description
CompareTo |
Init | Initializes this DTO. (Overrides DTO ..::. Init(Object).)

Fields

Name | Description
queryRefinement |
rank |

Properties

Name | Description
ClickUrl | The current URL with a corrected search query parameter. This URL should be used when a user clicks at this spelling suggestion.
NewTerms | The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.
Query | The spelling suggestion to be used as a new query.
Rank |

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


QueryRefinementDTO Constructor

QueryRefinementDTO Constructor
QueryRefinementDTO Class See Also
Initializes a new instance of the QueryRefinementDTO class.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public QueryRefinementDTO()

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


QueryRefinementDTO Fields

[image]

SiteSeeker Search Module SDK (3.3)
QueryRefinementDTO Fields
QueryRefinementDTO Class See Also

The QueryRefinementDTO type exposes the following fields.

Fields

Name | Description
queryRefinement |
rank |

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


queryRefinement Field

QueryRefinementDTO..::.queryRefinement Field
QueryRefinementDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected QueryRefinement queryRefinement

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


rank Field

QueryRefinementDTO..::.rank Field
QueryRefinementDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected int rank

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


QueryRefinementDTO Methods

[image]

SiteSeeker Search Module SDK (3.3)
QueryRefinementDTO Methods
QueryRefinementDTO Class See Also

The QueryRefinementDTO type exposes the following methods.

Methods

Name | Description
CompareTo |
Init | Initializes this DTO. (Overrides DTO ..::. Init(Object).)

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


CompareTo Method

QueryRefinementDTO..::.CompareTo Method
QueryRefinementDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::.Object

Implements

IComparable..::.CompareTo(Object)

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


Init Method

QueryRefinementDTO..::.Init Method
QueryRefinementDTO Class See Also
Initializes this DTO.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override void Init(
    Object queryRefinement
)

Parameters

queryRefinement
Type: System..::.Object

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


QueryRefinementDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
QueryRefinementDTO Properties
QueryRefinementDTO Class See Also

The QueryRefinementDTO type exposes the following properties.

Properties

Name | Description
ClickUrl | The current URL with a corrected search query parameter. This URL should be used when a user clicks at this spelling suggestion.
NewTerms | The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.
Query | The spelling suggestion to be used as a new query.
Rank |

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


ClickUrl Property

QueryRefinementDTO..::.ClickUrl Property
QueryRefinementDTO Class See Also
The current URL with a corrected search query parameter. This URL should be used when a user clicks at this spelling suggestion.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; }

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


NewTerms Property

QueryRefinementDTO..::.NewTerms Property
QueryRefinementDTO Class See Also
The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NewTerms { get; }

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


Query Property

QueryRefinementDTO..::.Query Property
QueryRefinementDTO Class See Also
The spelling suggestion to be used as a new query.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Query { get; }

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


Rank Property

QueryRefinementDTO..::.Rank Property
QueryRefinementDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int Rank { get; set; }

See Also

QueryRefinementDTO Class
development.search.DTO Namespace


SortLinkDTO Class

SortLinkDTO Class
Members See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SortLinkDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.SortLinkDTO

See Also

SortLinkDTO Members
development.search.DTO Namespace


SortLinkDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
SortLinkDTO Members
SortLinkDTO Class Constructors Properties See Also

The SortLinkDTO type exposes the following members.

Constructors

Name | Description
SortLinkDTO | Constructs a new SortLinkDTO for the specified SortOrder (e.g. relevance, date).

Properties

Name | Description
ClickUrl | The URL to click inorder to choose this sort order.
Name | The name of the sort order.
Selected | Inidicates wheter this sort link is selected.

See Also

SortLinkDTO Class
development.search.DTO Namespace


SortLinkDTO Constructor

SortLinkDTO Constructor
SortLinkDTO Class See Also
Constructs a new SortLinkDTO for the specified SortOrder (e.g. relevance, date).

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SortLinkDTO(
    SortOrder so,
    Connector connector
)

Parameters

so
Type: SiteSeeker.Model..::.SortOrder
The SortOrder that will be used when selecting this sort link.
connector
Type: SiteSeeker.Control..::.Connector
The Connector to be used for getting URL:s and translating sort order names.

See Also

SortLinkDTO Class
development.search.DTO Namespace
SiteSeeker.Model..::.SortOrder


SortLinkDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
SortLinkDTO Properties
SortLinkDTO Class See Also

The SortLinkDTO type exposes the following properties.

Properties

Name | Description
ClickUrl | The URL to click inorder to choose this sort order.
Name | The name of the sort order.
Selected | Inidicates wheter this sort link is selected.

See Also

SortLinkDTO Class
development.search.DTO Namespace


ClickUrl Property

SortLinkDTO..::.ClickUrl Property
SortLinkDTO Class See Also
The URL to click inorder to choose this sort order.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; }

See Also

SortLinkDTO Class
development.search.DTO Namespace


Name Property

SortLinkDTO..::.Name Property
SortLinkDTO Class See Also
The name of the sort order.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Name { get; }

See Also

SortLinkDTO Class
development.search.DTO Namespace


Selected Property

SortLinkDTO..::.Selected Property
SortLinkDTO Class See Also
Inidicates wheter this sort link is selected.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool Selected { get; }

See Also

SortLinkDTO Class
development.search.DTO Namespace


SortLinkDTOList Class

SortLinkDTOList Class
Members See Also
A list of sort links pointing at different sort orders, e.g., relevance and date.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SortLinkDTOList : List<SortLinkDTO>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( SortLinkDTO >)>)
development.search.DTO..::.SortLinkDTOList

See Also

SortLinkDTOList Members
development.search.DTO Namespace


SortLinkDTOList Members

[image]

SiteSeeker Search Module SDK (3.3)
SortLinkDTOList Members
SortLinkDTOList Class Constructors Properties See Also

The SortLinkDTOList type exposes the following members.

Constructors

Name | Description
SortLinkDTOList |

Properties

Name | Description
SelectedIndex | The index of the selected sort order

See Also

SortLinkDTOList Class
development.search.DTO Namespace


SortLinkDTOList Constructor

SortLinkDTOList Constructor
SortLinkDTOList Class See Also
Initializes a new instance of the SortLinkDTOList class.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SortLinkDTOList()

See Also

SortLinkDTOList Class
development.search.DTO Namespace


SortLinkDTOList Properties

[image]

SiteSeeker Search Module SDK (3.3)
SortLinkDTOList Properties
SortLinkDTOList Class See Also

The SortLinkDTOList type exposes the following properties.

Properties

Name | Description
SelectedIndex | The index of the selected sort order

See Also

SortLinkDTOList Class
development.search.DTO Namespace


SelectedIndex Property

SortLinkDTOList..::.SelectedIndex Property
SortLinkDTOList Class See Also
The index of the selected sort order

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int SelectedIndex { get; }

See Also

SortLinkDTOList Class
development.search.DTO Namespace
development.search.DTO..::.SortLinkDTO
SiteSeeker.Model..::.SortOrder


SpellingSuggestionDTO Class

SpellingSuggestionDTO Class
Members See Also
Describes a spelling suggestion.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SpellingSuggestionDTO : DTO

Inheritance Hierarchy

System..::.Object
development.search.DTO..::.DTO
development.search.DTO..::.SpellingSuggestionDTO

See Also

SpellingSuggestionDTO Members
development.search.DTO Namespace
SiteSeeker.Model..::.SpellingSuggestion


SpellingSuggestionDTO Members

[image]

SiteSeeker Search Module SDK (3.3)
SpellingSuggestionDTO Members
SpellingSuggestionDTO Class Constructors Methods Fields Properties See Also

The SpellingSuggestionDTO type exposes the following members.

Constructors

Name | Description
SpellingSuggestionDTO |

Methods

Name | Description
Init | Initializes this DTO. (Overrides DTO ..::. Init(Object).)

Fields

Name | Description
ss |

Properties

Name | Description
ClickUrl | The current URL with a corrected search query parameter. This URL should be used when a user clicks at this spelling suggestion.
NewQuery | The spelling suggestion to be used as a new query.
NewQueryHtml | The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


SpellingSuggestionDTO Constructor

SpellingSuggestionDTO Constructor
SpellingSuggestionDTO Class See Also
Initializes a new instance of the SpellingSuggestionDTO class.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SpellingSuggestionDTO()

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


SpellingSuggestionDTO Fields

[image]

SiteSeeker Search Module SDK (3.3)
SpellingSuggestionDTO Fields
SpellingSuggestionDTO Class See Also

The SpellingSuggestionDTO type exposes the following fields.

Fields

Name | Description
ss |

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


ss Field

SpellingSuggestionDTO..::.ss Field
SpellingSuggestionDTO Class See Also

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected SpellingSuggestion ss

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


SpellingSuggestionDTO Methods

[image]

SiteSeeker Search Module SDK (3.3)
SpellingSuggestionDTO Methods
SpellingSuggestionDTO Class See Also

The SpellingSuggestionDTO type exposes the following methods.

Methods

Name | Description
Init | Initializes this DTO. (Overrides DTO ..::. Init(Object).)

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


Init Method

SpellingSuggestionDTO..::.Init Method
SpellingSuggestionDTO Class See Also
Initializes this DTO.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override void Init(
    Object spellingSuggestion
)

Parameters

spellingSuggestion
Type: System..::.Object
A SpellingSuggestion object.

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


SpellingSuggestionDTO Properties

[image]

SiteSeeker Search Module SDK (3.3)
SpellingSuggestionDTO Properties
SpellingSuggestionDTO Class See Also

The SpellingSuggestionDTO type exposes the following properties.

Properties

Name | Description
ClickUrl | The current URL with a corrected search query parameter. This URL should be used when a user clicks at this spelling suggestion.
NewQuery | The spelling suggestion to be used as a new query.
NewQueryHtml | The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


ClickUrl Property

SpellingSuggestionDTO..::.ClickUrl Property
SpellingSuggestionDTO Class See Also
The current URL with a corrected search query parameter. This URL should be used when a user clicks at this spelling suggestion.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ClickUrl { get; }

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


NewQuery Property

SpellingSuggestionDTO..::.NewQuery Property
SpellingSuggestionDTO Class See Also
The spelling suggestion to be used as a new query.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NewQuery { get; }

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


NewQueryHtml Property

SpellingSuggestionDTO..::.NewQueryHtml Property
SpellingSuggestionDTO Class See Also
The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.

Namespace: development.search.DTO
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NewQueryHtml { get; }

See Also

SpellingSuggestionDTO Class
development.search.DTO Namespace


development.search.Extras Namespace

development.search.Extras Namespace
Additional user controls for query suggestions, on the search page (query refinements) and in the search form (query completion).

Classes

Class | Description
Cloud | Cloud class.
QueryCompletionScript | User control that emits necessary JavaScript variables to bind query completion to the quick search field.


Cloud Class

Cloud Class
Members See Also
Cloud class.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Cloud : EssUserControlBase

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
SiteSeeker.Control..::.EssUserControlBase
development.search.Extras..::.Cloud

See Also

Cloud Members
development.search.Extras Namespace


Cloud Members

[image]

SiteSeeker Search Module SDK (3.3)
Cloud Members
Cloud Class Constructors Methods Fields See Also

The Cloud type exposes the following members.

Constructors

Name | Description
Cloud |

Methods

Name | Description
UpdateView | (Overrides EssUserControlBase ..::. UpdateView()()().)

Fields

Name | Description
CloudPanel | CloudPanel control.
CloudRepeater | CloudRepeater control.

See Also

Cloud Class
development.search.Extras Namespace


Cloud Constructor

Cloud Constructor
Cloud Class See Also
Initializes a new instance of the Cloud class.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Cloud()

See Also

Cloud Class
development.search.Extras Namespace


Cloud Fields

[image]

SiteSeeker Search Module SDK (3.3)
Cloud Fields
Cloud Class See Also

The Cloud type exposes the following fields.

Fields

Name | Description
CloudPanel | CloudPanel control.
CloudRepeater | CloudRepeater control.

See Also

Cloud Class
development.search.Extras Namespace


CloudPanel Field

Cloud..::.CloudPanel Field
Cloud Class See Also
CloudPanel control.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel CloudPanel

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Cloud Class
development.search.Extras Namespace


CloudRepeater Field

Cloud..::.CloudRepeater Field
Cloud Class See Also
CloudRepeater control.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Repeater CloudRepeater

Remarks

Auto-generated field. To modify move field declaration from designer file to code-behind file.

See Also

Cloud Class
development.search.Extras Namespace


Cloud Methods

[image]

SiteSeeker Search Module SDK (3.3)
Cloud Methods
Cloud Class See Also

The Cloud type exposes the following methods.

Methods

Name | Description
UpdateView | (Overrides EssUserControlBase ..::. UpdateView()()().)

See Also

Cloud Class
development.search.Extras Namespace


UpdateView Method

Cloud..::.UpdateView Method
Cloud Class See Also

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void UpdateView()

See Also

Cloud Class
development.search.Extras Namespace


QueryCompletionScript Class

QueryCompletionScript Class
Members See Also
User control that emits necessary JavaScript variables to bind query completion to the quick search field.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class QueryCompletionScript : UserControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
development.search.Extras..::.QueryCompletionScript

See Also

QueryCompletionScript Members
development.search.Extras Namespace


QueryCompletionScript Members

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletionScript Members
QueryCompletionScript Class Constructors Methods Properties See Also

The QueryCompletionScript type exposes the following members.

Constructors

Name | Description
QueryCompletionScript |

Methods

Name | Description
Page_Load | Page load event handler. Includes JavaScripts for jQuery, jQuery.Autocomplete and SiteSeeker's query completion script.

Properties

Name | Description
IncludeJQuery | Set this property to true if the control should include the jQuery JavaScript library. Query completion requires jQuery 1.3.2, but if your already include jQuery, you may set this property to false.
IncludeJQueryAutocomplete | Set this property to true if the control should include the jQuery autocomplete plugin. Query completion requires jQuery.Autocomplete, but if your already include the autocomplete plugin, you may set this property to false.
Language | Returns the language for this request, e.g. "sv" or "en".
SearchButtonSelector | jQuery selector for the search button which should be clicked when the user selects a query completion.
SearchFieldSelector | jQuery selector for the search field (i.e. the text input field) which query completion should be attached to.

See Also

QueryCompletionScript Class
development.search.Extras Namespace


QueryCompletionScript Constructor

QueryCompletionScript Constructor
QueryCompletionScript Class See Also
Initializes a new instance of the QueryCompletionScript class.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public QueryCompletionScript()

See Also

QueryCompletionScript Class
development.search.Extras Namespace


QueryCompletionScript Methods

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletionScript Methods
QueryCompletionScript Class See Also

The QueryCompletionScript type exposes the following methods.

Methods

Name | Description
Page_Load | Page load event handler. Includes JavaScripts for jQuery, jQuery.Autocomplete and SiteSeeker's query completion script.

See Also

QueryCompletionScript Class
development.search.Extras Namespace


Page_Load Method

QueryCompletionScript..::.Page_Load Method
QueryCompletionScript Class See Also
Page load event handler. Includes JavaScripts for jQuery, jQuery.Autocomplete and SiteSeeker's query completion script.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
Sender.
e
Type: System..::.EventArgs
Event arguments.

See Also

QueryCompletionScript Class
development.search.Extras Namespace


QueryCompletionScript Properties

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletionScript Properties
QueryCompletionScript Class See Also

The QueryCompletionScript type exposes the following properties.

Properties

Name | Description
IncludeJQuery | Set this property to true if the control should include the jQuery JavaScript library. Query completion requires jQuery 1.3.2, but if your already include jQuery, you may set this property to false.
IncludeJQueryAutocomplete | Set this property to true if the control should include the jQuery autocomplete plugin. Query completion requires jQuery.Autocomplete, but if your already include the autocomplete plugin, you may set this property to false.
Language | Returns the language for this request, e.g. "sv" or "en".
SearchButtonSelector | jQuery selector for the search button which should be clicked when the user selects a query completion.
SearchFieldSelector | jQuery selector for the search field (i.e. the text input field) which query completion should be attached to.

See Also

QueryCompletionScript Class
development.search.Extras Namespace


IncludeJQuery Property

QueryCompletionScript..::.IncludeJQuery Property
QueryCompletionScript Class See Also
Set this property to true if the control should include the jQuery JavaScript library. Query completion requires jQuery 1.3.2, but if your already include jQuery, you may set this property to false.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IncludeJQuery { get; set; }

Remarks

Default is true.

See Also

QueryCompletionScript Class
development.search.Extras Namespace


IncludeJQueryAutocomplete Property

QueryCompletionScript..::.IncludeJQueryAutocomplete Property
QueryCompletionScript Class See Also
Set this property to true if the control should include the jQuery autocomplete plugin. Query completion requires jQuery.Autocomplete, but if your already include the autocomplete plugin, you may set this property to false.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IncludeJQueryAutocomplete { get; set; }

Remarks

Default is true.

See Also

QueryCompletionScript Class
development.search.Extras Namespace


Language Property

QueryCompletionScript..::.Language Property
QueryCompletionScript Class See Also
Returns the language for this request, e.g. "sv" or "en".

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string Language { get; }

See Also

QueryCompletionScript Class
development.search.Extras Namespace


SearchButtonSelector Property

QueryCompletionScript..::.SearchButtonSelector Property
QueryCompletionScript Class See Also
jQuery selector for the search button which should be clicked when the user selects a query completion.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SearchButtonSelector { get; set; }

See Also

QueryCompletionScript Class
development.search.Extras Namespace


SearchFieldSelector Property

QueryCompletionScript..::.SearchFieldSelector Property
QueryCompletionScript Class See Also
jQuery selector for the search field (i.e. the text input field) which query completion should be attached to.

Namespace: development.search.Extras
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SearchFieldSelector { get; set; }

See Also

QueryCompletionScript Class
development.search.Extras Namespace


SiteSeeker.Compatibility Namespace

SiteSeeker.Compatibility Namespace
Namespace for classes specific to a certain content management tool, e.g. EPiServer.

Classes

Class | Description
FileInformation | FileInformation module. Copyright (c) 2005-2006 Euroling AB
FindBase |
GlobalSettings |
GlobalSettingsBase |
IndexingControl | This function requires SiteSeeker 6.06 or later.
Lang |
MetaInfoHeader | Summary description for MetaInfoHeader.
ModuleContext | An immutable class for accessing configurable properties for the search module.
Page |
PageAccessController |
Security |
SiteSeekerSettings |
SiteSeekerSettingsBase |
UnifiedFile |
Url |
UrlRewriteControl |


FileInformation Class

FileInformation Class
Members See Also
FileInformation module. Copyright (c) 2005-2006 Euroling AB

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class FileInformation : Page

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
SiteSeeker.Compatibility..::.FileInformation

See Also

FileInformation Members
SiteSeeker.Compatibility Namespace


FileInformation Members

[image]

SiteSeeker Search Module SDK (3.3)
FileInformation Members
FileInformation Class Constructors Methods Properties See Also

The FileInformation type exposes the following members.

Constructors

Name | Description
FileInformation |

Methods

Name | Description
OnInit | (Overrides Page ..::. OnInit(EventArgs).)

Properties

Name | Description
BodyString |
MetaInfo |

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


FileInformation Constructor

FileInformation Constructor
FileInformation Class See Also
Initializes a new instance of the FileInformation class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileInformation()

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


FileInformation Methods

[image]

SiteSeeker Search Module SDK (3.3)
FileInformation Methods
FileInformation Class See Also

The FileInformation type exposes the following methods.

Methods

Name | Description
OnInit | (Overrides Page ..::. OnInit(EventArgs).)

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


OnInit Method

FileInformation..::.OnInit Method
FileInformation Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


FileInformation Properties

[image]

SiteSeeker Search Module SDK (3.3)
FileInformation Properties
FileInformation Class See Also

The FileInformation type exposes the following properties.

Properties

Name | Description
BodyString |
MetaInfo |

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


BodyString Property

FileInformation..::.BodyString Property
FileInformation Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string BodyString { get; }

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


MetaInfo Property

FileInformation..::.MetaInfo Property
FileInformation Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string MetaInfo { get; }

See Also

FileInformation Class
SiteSeeker.Compatibility Namespace


FindBase Class

FindBase Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class FindBase : TemplatePage

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
PageBase
SimplePage
EditPage
TemplatePage
SiteSeeker.Compatibility..::.FindBase
development.search..::.Find

See Also

FindBase Members
SiteSeeker.Compatibility Namespace


FindBase Members

[image]

SiteSeeker Search Module SDK (3.3)
FindBase Members
FindBase Class Constructors See Also

The FindBase type exposes the following members.

Constructors

Name | Description
FindBase |

See Also

FindBase Class
SiteSeeker.Compatibility Namespace


FindBase Constructor

FindBase Constructor
FindBase Class See Also
Initializes a new instance of the FindBase class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FindBase()

See Also

FindBase Class
SiteSeeker.Compatibility Namespace


GlobalSettings Class

GlobalSettings Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class GlobalSettings : GlobalSettingsBase

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.GlobalSettingsBase
SiteSeeker.Compatibility..::.GlobalSettings
SiteSeeker.Environment..::.GlobalSettings

See Also

GlobalSettings Members
SiteSeeker.Compatibility Namespace


GlobalSettings Members

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Members
GlobalSettings Class Constructors Methods Fields Properties See Also

The GlobalSettings type exposes the following members.

Constructors

Name | Description
GlobalSettings | Overloaded.

Methods

Name | Description
Load | Load plugin configuration, e.g. web service URL and login and other global options (typically specified in EPiServers admin mode). Will not reload settings if called more than once.
Save | Save settings to plugin configuration.

Fields

Name | Description
CheckPermissions |
CrawlerUsername |
DynCategories |
DynCategoriesPropName |
EPiCategories |
Password |
TopCategories |
TopCategoriesGroup |
Url |
UrlMatch |
UrlReplace |
UrlRewrite |
Username |

Properties

Name | Description
SeekerWebService | Get web service connection, which may be used to retrieve search results.

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


GlobalSettings Constructor

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Constructor
GlobalSettings Class See Also

Overload List

Name | Description
GlobalSettings()()() | Create a new settings object, and load plugin configuration.
GlobalSettings(String, String, String) | Create a new settings object, load plugin configuration, and then override url, username and password. May be used to test the web service connection. If any argument is null, the corresponding value from the plugin configuration will be used.

See Also

GlobalSettings Class
GlobalSettings Members
SiteSeeker.Compatibility Namespace


GlobalSettings Constructor

GlobalSettings Constructor
GlobalSettings Class See Also
Create a new settings object, and load plugin configuration.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettings()

See Also

GlobalSettings Class
GlobalSettings Overload
SiteSeeker.Compatibility Namespace


GlobalSettings Constructor (String, String, String)

GlobalSettings Constructor (String, String, String)
GlobalSettings Class See Also
Create a new settings object, load plugin configuration, and then override url, username and password. May be used to test the web service connection. If any argument is null, the corresponding value from the plugin configuration will be used.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettings(
    string url,
    string username,
    string password
)

Parameters

url
Type: System..::.String
Web service URL, including protocol and port number.
username
Type: System..::.String
Web service username.
password
Type: System..::.String
Web service password.

See Also

GlobalSettings Class
GlobalSettings Overload
SiteSeeker.Compatibility Namespace


GlobalSettings Fields

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Fields
GlobalSettings Class See Also

The GlobalSettings type exposes the following fields.

Fields

Name | Description
CheckPermissions |
CrawlerUsername |
DynCategories |
DynCategoriesPropName |
EPiCategories |
Password |
TopCategories |
TopCategoriesGroup |
Url |
UrlMatch |
UrlReplace |
UrlRewrite |
Username |

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


CheckPermissions Field

GlobalSettings..::.CheckPermissions Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool CheckPermissions

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


CrawlerUsername Field

GlobalSettings..::.CrawlerUsername Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CrawlerUsername

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


DynCategories Field

GlobalSettings..::.DynCategories Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool DynCategories

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


DynCategoriesPropName Field

GlobalSettings..::.DynCategoriesPropName Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string DynCategoriesPropName

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


EPiCategories Field

GlobalSettings..::.EPiCategories Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool EPiCategories

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


Password Field

GlobalSettings..::.Password Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Password

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


TopCategories Field

GlobalSettings..::.TopCategories Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool TopCategories

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


TopCategoriesGroup Field

GlobalSettings..::.TopCategoriesGroup Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string TopCategoriesGroup

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


Url Field

GlobalSettings..::.Url Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Url

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


UrlMatch Field

GlobalSettings..::.UrlMatch Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string UrlMatch

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


UrlReplace Field

GlobalSettings..::.UrlReplace Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string UrlReplace

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


UrlRewrite Field

GlobalSettings..::.UrlRewrite Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool UrlRewrite

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


Username Field

GlobalSettings..::.Username Field
GlobalSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Username

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


GlobalSettings Methods

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Methods
GlobalSettings Class See Also

The GlobalSettings type exposes the following methods.

Methods

Name | Description
Load | Load plugin configuration, e.g. web service URL and login and other global options (typically specified in EPiServers admin mode). Will not reload settings if called more than once.
Save | Save settings to plugin configuration.

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


Load Method

GlobalSettings..::.Load Method
GlobalSettings Class See Also
Load plugin configuration, e.g. web service URL and login and other global options (typically specified in EPiServers admin mode). Will not reload settings if called more than once.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void Load()

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


Save Method

GlobalSettings..::.Save Method
GlobalSettings Class See Also
Save settings to plugin configuration.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void Save()

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


GlobalSettings Properties

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Properties
GlobalSettings Class See Also

The GlobalSettings type exposes the following properties.

Properties

Name | Description
SeekerWebService | Get web service connection, which may be used to retrieve search results.

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


SeekerWebService Property

GlobalSettings..::.SeekerWebService Property
GlobalSettings Class See Also
Get web service connection, which may be used to retrieve search results.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SiteSeeker SeekerWebService { get; }

See Also

GlobalSettings Class
SiteSeeker.Compatibility Namespace


GlobalSettingsBase Class

GlobalSettingsBase Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class GlobalSettingsBase

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.GlobalSettingsBase
SiteSeeker.Compatibility..::.GlobalSettings

See Also

GlobalSettingsBase Members
SiteSeeker.Compatibility Namespace


GlobalSettingsBase Members

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettingsBase Members
GlobalSettingsBase Class Constructors Methods See Also

The GlobalSettingsBase type exposes the following members.

Constructors

Name | Description
GlobalSettingsBase |

Methods

Name | Description
SiteUrl |

See Also

GlobalSettingsBase Class
SiteSeeker.Compatibility Namespace


GlobalSettingsBase Constructor

GlobalSettingsBase Constructor
GlobalSettingsBase Class See Also
Initializes a new instance of the GlobalSettingsBase class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettingsBase()

See Also

GlobalSettingsBase Class
SiteSeeker.Compatibility Namespace


GlobalSettingsBase Methods

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettingsBase Methods
GlobalSettingsBase Class See Also

The GlobalSettingsBase type exposes the following methods.

Methods

Name | Description
SiteUrl |

See Also

GlobalSettingsBase Class
SiteSeeker.Compatibility Namespace


SiteUrl Method

GlobalSettingsBase..::.SiteUrl Method
GlobalSettingsBase Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string SiteUrl()

See Also

GlobalSettingsBase Class
SiteSeeker.Compatibility Namespace


IndexingControl Class

IndexingControl Class
Members See Also
This function requires SiteSeeker 6.06 or later.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class IndexingControl

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.IndexingControl

See Also

IndexingControl Members
SiteSeeker.Compatibility Namespace


IndexingControl Members

[image]

SiteSeeker Search Module SDK (3.3)
IndexingControl Members
IndexingControl Class Constructors Methods See Also

The IndexingControl type exposes the following members.

Constructors

Name | Description
IndexingControl |

Methods

Name | Description
Notify | Hook for the page publish event.

See Also

IndexingControl Class
SiteSeeker.Compatibility Namespace


IndexingControl Constructor

IndexingControl Constructor
IndexingControl Class See Also
Initializes a new instance of the IndexingControl class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public IndexingControl()

See Also

IndexingControl Class
SiteSeeker.Compatibility Namespace


IndexingControl Methods

[image]

SiteSeeker Search Module SDK (3.3)
IndexingControl Methods
IndexingControl Class See Also

The IndexingControl type exposes the following methods.

Methods

Name | Description
Notify | Hook for the page publish event.

See Also

IndexingControl Class
SiteSeeker.Compatibility Namespace


Notify Method

IndexingControl..::.Notify Method
IndexingControl Class See Also
Hook for the page publish event.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static void Notify(
    Object sender,
    PageEventArgs e
)

Parameters

sender
Type: System..::.Object
Sender.
e
Type: PageEventArgs
Page event arguments.

See Also

IndexingControl Class
SiteSeeker.Compatibility Namespace


Lang Class

Lang Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Lang

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.Lang

See Also

Lang Members
SiteSeeker.Compatibility Namespace


Lang Members

[image]

SiteSeeker Search Module SDK (3.3)
Lang Members
Lang Class Constructors Methods See Also

The Lang type exposes the following members.

Constructors

Name | Description
Lang |

Methods

Name | Description
CurrentLanguage |
Translate | Overloaded.

See Also

Lang Class
SiteSeeker.Compatibility Namespace


Lang Constructor

Lang Constructor
Lang Class See Also
Initializes a new instance of the Lang class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Lang()

See Also

Lang Class
SiteSeeker.Compatibility Namespace


Lang Methods

[image]

SiteSeeker Search Module SDK (3.3)
Lang Methods
Lang Class See Also

The Lang type exposes the following methods.

Methods

Name | Description
CurrentLanguage |
Translate | Overloaded.

See Also

Lang Class
SiteSeeker.Compatibility Namespace


CurrentLanguage Method

Lang..::.CurrentLanguage Method
Lang Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string CurrentLanguage()

See Also

Lang Class
SiteSeeker.Compatibility Namespace


Translate Method

[image]

SiteSeeker Search Module SDK (3.3)
Lang..::.Translate Method
Lang Class See Also

Overload List

Name | Description
Translate(String) |
Translate(String, String) |

See Also

Lang Class
Lang Members
SiteSeeker.Compatibility Namespace


Translate Method (String)

Lang..::.Translate Method (String)
Lang Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string Translate(
    string path
)

Parameters

path
Type: System..::.String

See Also

Lang Class
Translate Overload
SiteSeeker.Compatibility Namespace


Translate Method (String, String)

Lang..::.Translate Method (String, String)
Lang Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string Translate(
    string path,
    string language
)

Parameters

path
Type: System..::.String
language
Type: System..::.String

See Also

Lang Class
Translate Overload
SiteSeeker.Compatibility Namespace


MetaInfoHeader Class

MetaInfoHeader Class
Members See Also
Summary description for MetaInfoHeader.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class MetaInfoHeader : UserControlBase

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
UserControlBase
SiteSeeker.Compatibility..::.MetaInfoHeader

See Also

MetaInfoHeader Members
SiteSeeker.Compatibility Namespace


MetaInfoHeader Members

[image]

SiteSeeker Search Module SDK (3.3)
MetaInfoHeader Members
MetaInfoHeader Class Constructors Methods Fields Properties See Also

The MetaInfoHeader type exposes the following members.

Constructors

Name | Description
MetaInfoHeader |

Methods

Name | Description
GetTitleString | Returns the title to use for this page when indexing with SiteSeeker.
OnInit | (Overrides UserControl ..::. OnInit(EventArgs).)

Fields

Name | Description
CategoryPropertyName |
MetaTagGenerator |

Properties

Name | Description
IncludeParentInTitle | Set to true to include the page name of the parent page in the title for this page. May be desirable to provide the search user with context for the current page.
Title | You may provide a title which then will replace the ordinary title of the page.
TitlePropertyName | The name of a property containing a string to be used as title of the page.

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


MetaInfoHeader Constructor

MetaInfoHeader Constructor
MetaInfoHeader Class See Also
Initializes a new instance of the MetaInfoHeader class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public MetaInfoHeader()

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


MetaInfoHeader Fields

[image]

SiteSeeker Search Module SDK (3.3)
MetaInfoHeader Fields
MetaInfoHeader Class See Also

The MetaInfoHeader type exposes the following fields.

Fields

Name | Description
CategoryPropertyName |
MetaTagGenerator |

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


CategoryPropertyName Field

MetaInfoHeader..::.CategoryPropertyName Field
MetaInfoHeader Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CategoryPropertyName

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


MetaTagGenerator Field

MetaInfoHeader..::.MetaTagGenerator Field
MetaInfoHeader Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Literal MetaTagGenerator

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


MetaInfoHeader Methods

[image]

SiteSeeker Search Module SDK (3.3)
MetaInfoHeader Methods
MetaInfoHeader Class See Also

The MetaInfoHeader type exposes the following methods.

Methods

Name | Description
GetTitleString | Returns the title to use for this page when indexing with SiteSeeker.
OnInit | (Overrides UserControl ..::. OnInit(EventArgs).)

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


GetTitleString Method

MetaInfoHeader..::.GetTitleString Method
MetaInfoHeader Class See Also
Returns the title to use for this page when indexing with SiteSeeker.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string GetTitleString()

Return Value

This method will pick a title for the current page using one of the following methods, in this order: 1. The title provided as an attribute to this user control (if non-empty). 2. The title in the property with the name provided by TitlePropertyName (if provided and non-empty, default is "Heading"). 3. The page name of this page.

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


OnInit Method

MetaInfoHeader..::.OnInit Method
MetaInfoHeader Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


MetaInfoHeader Properties

[image]

SiteSeeker Search Module SDK (3.3)
MetaInfoHeader Properties
MetaInfoHeader Class See Also

The MetaInfoHeader type exposes the following properties.

Properties

Name | Description
IncludeParentInTitle | Set to true to include the page name of the parent page in the title for this page. May be desirable to provide the search user with context for the current page.
Title | You may provide a title which then will replace the ordinary title of the page.
TitlePropertyName | The name of a property containing a string to be used as title of the page.

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


IncludeParentInTitle Property

MetaInfoHeader..::.IncludeParentInTitle Property
MetaInfoHeader Class See Also
Set to true to include the page name of the parent page in the title for this page. May be desirable to provide the search user with context for the current page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IncludeParentInTitle { get; set; }

Remarks

This title will only be used by SiteSeeker, i.e. it will not be seen by other user agents.

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


Title Property

MetaInfoHeader..::.Title Property
MetaInfoHeader Class See Also
You may provide a title which then will replace the ordinary title of the page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Title { get; set; }

Remarks

This title will only be used by SiteSeeker, i.e. it will not be seen by other user agents.

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


TitlePropertyName Property

MetaInfoHeader..::.TitlePropertyName Property
MetaInfoHeader Class See Also
The name of a property containing a string to be used as title of the page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string TitlePropertyName { get; set; }

Remarks

This title will only be used by SiteSeeker, i.e. it will not be seen by other user agents.

See Also

MetaInfoHeader Class
SiteSeeker.Compatibility Namespace


ModuleContext Class

ModuleContext Class
Members See Also
An immutable class for accessing configurable properties for the search module.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class ModuleContext

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.ModuleContext
SiteSeeker.Environment..::.ModuleContext

See Also

ModuleContext Members
SiteSeeker.Compatibility Namespace


ModuleContext Members

[image]

SiteSeeker Search Module SDK (3.3)
ModuleContext Members
ModuleContext Class Constructors Methods Properties See Also

The ModuleContext type exposes the following members.

Constructors

Name | Description
ModuleContext | Overloaded.

Methods

Name | Description
GetProperty | Returns the named property.
HasProperty | Checks if search page has the given property.

Properties

Name | Description
CurrentLanguage | The language of the current page, expressed as the two-letter ISO code.
CurrentUrl | The URL of the current page.
FormShowCategories | Show categories in search form in order to let users limit the query to documents in one or many category(ies).
FormShowDates | Show dates in search form in order to let users limit the query to documents whose modification date is in a specific range.
FormShowFileFormats | Show file formats in search form in order to let users limit the query to documents of one specific file format.
FormShowLanguages | Show file formats in search form in order to let users limit the query to documents in one specific language.
FormShowStemming | Show an option in the search form which specifies wheter stemming should be used when evaluating a query.
HelpPageLink | The link, i.e. URL, to the help page.
IndexName | An alias for the index/entire site
QueryExtension | A default extension to the query. I.e., a string that will be concatenated onto the end of the search queries. Typically, a query extension is specified in order to limit the query to specific category(ies): "hidden:meta:category:My_Category".
ShowAgeOverview | Show ages in overview.
ShowCategoryLabel | Show document category(ies) for each hit in the result list.
ShowCategoryOverview | Show categores in overview.
ShowFileFormatOverview | Show file formats in overview.
ShowHelpPage | Show a link to the help page.
ShowLanguageOverview | Show languages in overview.
ShowRankLabel | Show rank label for each hit in the result list
UseTwoStepFiltering | Indicates wheter two step filtering should be enabled.

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ModuleContext Constructor

[image]

SiteSeeker Search Module SDK (3.3)
ModuleContext Constructor
ModuleContext Class See Also

Overload List

Name | Description
ModuleContext()()() | Constructs a new ModuleContext for non-interactive use (if used in an interactive setting, no advanced options will be shown, and paging and filter links will not work).
ModuleContext(PageData) | Constructs a new ModuleContext
ModuleContext(Object) | Constructs a new ModuleContext

See Also

ModuleContext Class
ModuleContext Members
SiteSeeker.Compatibility Namespace


ModuleContext Constructor

ModuleContext Constructor
ModuleContext Class See Also
Constructs a new ModuleContext for non-interactive use (if used in an interactive setting, no advanced options will be shown, and paging and filter links will not work).

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ModuleContext()

See Also

ModuleContext Class
ModuleContext Overload
SiteSeeker.Compatibility Namespace


ModuleContext Constructor ()

ModuleContext Constructor ()
ModuleContext Class See Also
Constructs a new ModuleContext

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ModuleContext(
    PageData searchPage
)

Parameters

searchPage
Type: PageData
The page data for the search page

Remarks

The search page parameter may be null, but only for a non-interactive search page, since no advanced options will be shown, and paging and filter links will not work.

See Also

ModuleContext Class
ModuleContext Overload
SiteSeeker.Compatibility Namespace


ModuleContext Constructor (Object)

ModuleContext Constructor (Object)
ModuleContext Class See Also
Constructs a new ModuleContext

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ModuleContext(
    Object searchPage
)

Parameters

searchPage
Type: System..::.Object
A search page object

Remarks

The search page parameter may be null, but only for a non-interactive search page, since no advanced options will be shown, and paging and filter links will not work.

See Also

ModuleContext Class
ModuleContext Overload
SiteSeeker.Compatibility Namespace


ModuleContext Methods

[image]

SiteSeeker Search Module SDK (3.3)
ModuleContext Methods
ModuleContext Class See Also

The ModuleContext type exposes the following methods.

Methods

Name | Description
GetProperty | Returns the named property.
HasProperty | Checks if search page has the given property.

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


GetProperty Method

ModuleContext..::.GetProperty Method
ModuleContext Class See Also
Returns the named property.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string GetProperty(
    string name
)

Parameters

name
Type: System..::.String
Name of the property

Return Value

Returns the property as a string if it exists, otherwise returns an empty string

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


HasProperty Method

ModuleContext..::.HasProperty Method
ModuleContext Class See Also
Checks if search page has the given property.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool HasProperty(
    string name
)

Parameters

name
Type: System..::.String
Name of the property

Return Value

true if the search has the property, false otherwise

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ModuleContext Properties

[image]

SiteSeeker Search Module SDK (3.3)
ModuleContext Properties
ModuleContext Class See Also

The ModuleContext type exposes the following properties.

Properties

Name | Description
CurrentLanguage | The language of the current page, expressed as the two-letter ISO code.
CurrentUrl | The URL of the current page.
FormShowCategories | Show categories in search form in order to let users limit the query to documents in one or many category(ies).
FormShowDates | Show dates in search form in order to let users limit the query to documents whose modification date is in a specific range.
FormShowFileFormats | Show file formats in search form in order to let users limit the query to documents of one specific file format.
FormShowLanguages | Show file formats in search form in order to let users limit the query to documents in one specific language.
FormShowStemming | Show an option in the search form which specifies wheter stemming should be used when evaluating a query.
HelpPageLink | The link, i.e. URL, to the help page.
IndexName | An alias for the index/entire site
QueryExtension | A default extension to the query. I.e., a string that will be concatenated onto the end of the search queries. Typically, a query extension is specified in order to limit the query to specific category(ies): "hidden:meta:category:My_Category".
ShowAgeOverview | Show ages in overview.
ShowCategoryLabel | Show document category(ies) for each hit in the result list.
ShowCategoryOverview | Show categores in overview.
ShowFileFormatOverview | Show file formats in overview.
ShowHelpPage | Show a link to the help page.
ShowLanguageOverview | Show languages in overview.
ShowRankLabel | Show rank label for each hit in the result list
UseTwoStepFiltering | Indicates wheter two step filtering should be enabled.

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


CurrentLanguage Property

ModuleContext..::.CurrentLanguage Property
ModuleContext Class See Also
The language of the current page, expressed as the two-letter ISO code.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CurrentLanguage { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


CurrentUrl Property

ModuleContext..::.CurrentUrl Property
ModuleContext Class See Also
The URL of the current page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CurrentUrl { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


FormShowCategories Property

ModuleContext..::.FormShowCategories Property
ModuleContext Class See Also
Show categories in search form in order to let users limit the query to documents in one or many category(ies).

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool FormShowCategories { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


FormShowDates Property

ModuleContext..::.FormShowDates Property
ModuleContext Class See Also
Show dates in search form in order to let users limit the query to documents whose modification date is in a specific range.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool FormShowDates { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


FormShowFileFormats Property

ModuleContext..::.FormShowFileFormats Property
ModuleContext Class See Also
Show file formats in search form in order to let users limit the query to documents of one specific file format.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool FormShowFileFormats { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


FormShowLanguages Property

ModuleContext..::.FormShowLanguages Property
ModuleContext Class See Also
Show file formats in search form in order to let users limit the query to documents in one specific language.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool FormShowLanguages { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


FormShowStemming Property

ModuleContext..::.FormShowStemming Property
ModuleContext Class See Also
Show an option in the search form which specifies wheter stemming should be used when evaluating a query.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool FormShowStemming { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


HelpPageLink Property

ModuleContext..::.HelpPageLink Property
ModuleContext Class See Also
The link, i.e. URL, to the help page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string HelpPageLink { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


IndexName Property

ModuleContext..::.IndexName Property
ModuleContext Class See Also
An alias for the index/entire site

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string IndexName { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


QueryExtension Property

ModuleContext..::.QueryExtension Property
ModuleContext Class See Also
A default extension to the query. I.e., a string that will be concatenated onto the end of the search queries. Typically, a query extension is specified in order to limit the query to specific category(ies): "hidden:meta:category:My_Category".

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string QueryExtension { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowAgeOverview Property

ModuleContext..::.ShowAgeOverview Property
ModuleContext Class See Also
Show ages in overview.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowAgeOverview { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowCategoryLabel Property

ModuleContext..::.ShowCategoryLabel Property
ModuleContext Class See Also
Show document category(ies) for each hit in the result list.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowCategoryLabel { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowCategoryOverview Property

ModuleContext..::.ShowCategoryOverview Property
ModuleContext Class See Also
Show categores in overview.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowCategoryOverview { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowFileFormatOverview Property

ModuleContext..::.ShowFileFormatOverview Property
ModuleContext Class See Also
Show file formats in overview.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowFileFormatOverview { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowHelpPage Property

ModuleContext..::.ShowHelpPage Property
ModuleContext Class See Also
Show a link to the help page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowHelpPage { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowLanguageOverview Property

ModuleContext..::.ShowLanguageOverview Property
ModuleContext Class See Also
Show languages in overview.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowLanguageOverview { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


ShowRankLabel Property

ModuleContext..::.ShowRankLabel Property
ModuleContext Class See Also
Show rank label for each hit in the result list

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ShowRankLabel { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


UseTwoStepFiltering Property

ModuleContext..::.UseTwoStepFiltering Property
ModuleContext Class See Also
Indicates wheter two step filtering should be enabled.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool UseTwoStepFiltering { get; }

See Also

ModuleContext Class
SiteSeeker.Compatibility Namespace


Page Class

Page Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Page

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.Page

See Also

Page Members
SiteSeeker.Compatibility Namespace


Page Members

[image]

SiteSeeker Search Module SDK (3.3)
Page Members
Page Class Constructors Methods Properties See Also

The Page type exposes the following members.

Constructors

Name | Description
Page |

Methods

Name | Description
GetPageData | Overloaded.

Properties

Name | Description
RootPage |

See Also

Page Class
SiteSeeker.Compatibility Namespace


Page Constructor

Page Constructor
Page Class See Also
Initializes a new instance of the Page class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Page()

See Also

Page Class
SiteSeeker.Compatibility Namespace


Page Methods

[image]

SiteSeeker Search Module SDK (3.3)
Page Methods
Page Class See Also

Methods

Name | Description
GetPageData | Overloaded.

See Also

Page Class
SiteSeeker.Compatibility Namespace


GetPageData Method

[image]

SiteSeeker Search Module SDK (3.3)
Page..::.GetPageData Method
Page Class See Also

Overload List

Name | Description
GetPageData(PageReference) |
GetPageData(PageReference, AccessLevel) |

See Also

Page Class
Page Members
SiteSeeker.Compatibility Namespace


GetPageData Method ()

Page..::.GetPageData Method ()
Page Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static PageData GetPageData(
    PageReference pr
)

Parameters

pr
Type: PageReference

See Also

Page Class
GetPageData Overload
SiteSeeker.Compatibility Namespace


GetPageData Method (, )

Page..::.GetPageData Method (, )
Page Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static PageData GetPageData(
    PageReference pr,
    AccessLevel level
)

Parameters

pr
Type: PageReference
level
Type: AccessLevel

See Also

Page Class
GetPageData Overload
SiteSeeker.Compatibility Namespace


Page Properties

[image]

SiteSeeker Search Module SDK (3.3)
Page Properties
Page Class See Also

The Page type exposes the following properties.

Properties

Name | Description
RootPage |

See Also

Page Class
SiteSeeker.Compatibility Namespace


RootPage Property

Page..::.RootPage Property
Page Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static PageReference RootPage { get; }

See Also

Page Class
SiteSeeker.Compatibility Namespace


PageAccessController Class

PageAccessController Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class PageAccessController : IAccessController

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.PageAccessController

See Also

PageAccessController Members
SiteSeeker.Compatibility Namespace


PageAccessController Members

[image]

SiteSeeker Search Module SDK (3.3)
PageAccessController Members
PageAccessController Class Constructors Methods See Also

The PageAccessController type exposes the following members.

Constructors

Name | Description
PageAccessController |

Methods

Name | Description
IsPageAccessible | Determines whether a page with the specified URL and document id is accessible or not.

See Also

PageAccessController Class
SiteSeeker.Compatibility Namespace


PageAccessController Constructor

PageAccessController Constructor
PageAccessController Class See Also
Initializes a new instance of the PageAccessController class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public PageAccessController()

See Also

PageAccessController Class
SiteSeeker.Compatibility Namespace


PageAccessController Methods

[image]

SiteSeeker Search Module SDK (3.3)
PageAccessController Methods
PageAccessController Class See Also

The PageAccessController type exposes the following methods.

Methods

Name | Description
IsPageAccessible | Determines whether a page with the specified URL and document id is accessible or not.

See Also

PageAccessController Class
SiteSeeker.Compatibility Namespace


IsPageAccessible Method

PageAccessController..::.IsPageAccessible Method
PageAccessController Class See Also
Determines whether a page with the specified URL and document id is accessible or not.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsPageAccessible(
    string url,
    string documentID
)

Parameters

url
Type: System..::.String
The url to the page
documentID
Type: System..::.String
The unique identifier of the page

Return Value

True if the page is accessible, false otherwise.

Implements

IAccessController..::.IsPageAccessible(String, String)

See Also

PageAccessController Class
SiteSeeker.Compatibility Namespace


Security Class

Security Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Security

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.Security

See Also

Security Members
SiteSeeker.Compatibility Namespace


Security Members

[image]

SiteSeeker Search Module SDK (3.3)
Security Members
Security Class Constructors Methods See Also

The Security type exposes the following members.

Constructors

Name | Description
Security |

Methods

Name | Description
GetACL |
GetRoleList |
GetUser |
HasReadAccess |

See Also

Security Class
SiteSeeker.Compatibility Namespace


Security Constructor

Security Constructor
Security Class See Also
Initializes a new instance of the Security class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Security()

See Also

Security Class
SiteSeeker.Compatibility Namespace


Security Methods

[image]

SiteSeeker Search Module SDK (3.3)
Security Methods
Security Class See Also

The Security type exposes the following methods.

Methods

Name | Description
GetACL |
GetRoleList |
GetUser |
HasReadAccess |

See Also

Security Class
SiteSeeker.Compatibility Namespace


GetACL Method

Security..::.GetACL Method
Security Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string GetACL(
    AccessControlList acl
)

Parameters

acl
Type: AccessControlList

See Also

Security Class
SiteSeeker.Compatibility Namespace


GetRoleList Method

Security..::.GetRoleList Method
Security Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string GetRoleList()

See Also

Security Class
SiteSeeker.Compatibility Namespace


GetUser Method

Security..::.GetUser Method
Security Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string GetUser()

See Also

Security Class
SiteSeeker.Compatibility Namespace


HasReadAccess Method

Security..::.HasReadAccess Method
Security Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static bool HasReadAccess(
    PageReference pr
)

Parameters

pr
Type: PageReference

See Also

Security Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettings Class

SiteSeekerSettings Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SiteSeekerSettings : SiteSeekerSettingsBase

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
PageBase
SystemPageBase
SiteSeeker.Compatibility..::.SiteSeekerSettingsBase
SiteSeeker.Compatibility..::.SiteSeekerSettings

See Also

SiteSeekerSettings Members
SiteSeeker.Compatibility Namespace


SiteSeekerSettings Members

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettings Members
SiteSeekerSettings Class Constructors Methods Fields Properties See Also

The SiteSeekerSettings type exposes the following members.

Constructors

Name | Description
SiteSeekerSettings |

Methods

Name | Description
btnCheckConnection_Click |
btnSave_Click |
OnInit | (Overrides PageBase..::.OnInit(EventArgs).)
OnPreInit | (Inherited from SiteSeekerSettingsBase.)
Page_Load | (Inherited from SiteSeekerSettingsBase.)

Fields

Name | Description
btnCheckConnection | (Inherited from SiteSeekerSettingsBase.)
btnSave | (Inherited from SiteSeekerSettingsBase.)
btnSaveConnectionTest | (Inherited from SiteSeekerSettingsBase.)
cbCheckPermissions |
cbDynCategories |
cbEPiCategories |
cbTopCategories |
cbUrlRewrite |
checkConnectionMessage |
lbCheckConnection |
lbCheckConnectionDetails |
lbVersion |
PasswordFieldValue |
phConnectionErrorExplanation |
saveMessage |
tbCrawlerUsername |
tbDynCategoriesPropName |
tbPassword |
tbTopCategoriesGroup |
tbUrl |
tbUrlMatch |
tbUrlReplace |
tbUsername |

Properties

Name | Description
CheckPermissions |
CrawlerUsername |
DynCategories |
DynCategoriesPropName |
EPiCategories |
Password |
SiteUrl |
TopCategories |
TopCategoriesGroup |
URL |
UrlMatch |
UrlReplace |
UrlRewrite |
Username |

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettings Constructor

SiteSeekerSettings Constructor
SiteSeekerSettings Class See Also
Initializes a new instance of the SiteSeekerSettings class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SiteSeekerSettings()

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettings Fields

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettings Fields
SiteSeekerSettings Class See Also

The SiteSeekerSettings type exposes the following fields.

Fields

Name | Description
btnCheckConnection | (Inherited from SiteSeekerSettingsBase.)
btnSave | (Inherited from SiteSeekerSettingsBase.)
btnSaveConnectionTest | (Inherited from SiteSeekerSettingsBase.)
cbCheckPermissions |
cbDynCategories |
cbEPiCategories |
cbTopCategories |
cbUrlRewrite |
checkConnectionMessage |
lbCheckConnection |
lbCheckConnectionDetails |
lbVersion |
PasswordFieldValue |
phConnectionErrorExplanation |
saveMessage |
tbCrawlerUsername |
tbDynCategoriesPropName |
tbPassword |
tbTopCategoriesGroup |
tbUrl |
tbUrlMatch |
tbUrlReplace |
tbUsername |

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


cbCheckPermissions Field

SiteSeekerSettings..::.cbCheckPermissions Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected CheckBox cbCheckPermissions

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


cbDynCategories Field

SiteSeekerSettings..::.cbDynCategories Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected CheckBox cbDynCategories

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


cbEPiCategories Field

SiteSeekerSettings..::.cbEPiCategories Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected CheckBox cbEPiCategories

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


cbTopCategories Field

SiteSeekerSettings..::.cbTopCategories Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected CheckBox cbTopCategories

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


cbUrlRewrite Field

SiteSeekerSettings..::.cbUrlRewrite Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected CheckBox cbUrlRewrite

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


checkConnectionMessage Field

SiteSeekerSettings..::.checkConnectionMessage Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel checkConnectionMessage

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


lbCheckConnection Field

SiteSeekerSettings..::.lbCheckConnection Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label lbCheckConnection

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


lbCheckConnectionDetails Field

SiteSeekerSettings..::.lbCheckConnectionDetails Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label lbCheckConnectionDetails

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


lbVersion Field

SiteSeekerSettings..::.lbVersion Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Label lbVersion

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


PasswordFieldValue Field

SiteSeekerSettings..::.PasswordFieldValue Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string PasswordFieldValue

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


phConnectionErrorExplanation Field

SiteSeekerSettings..::.phConnectionErrorExplanation Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected PlaceHolder phConnectionErrorExplanation

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


saveMessage Field

SiteSeekerSettings..::.saveMessage Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Panel saveMessage

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbCrawlerUsername Field

SiteSeekerSettings..::.tbCrawlerUsername Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbCrawlerUsername

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbDynCategoriesPropName Field

SiteSeekerSettings..::.tbDynCategoriesPropName Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbDynCategoriesPropName

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbPassword Field

SiteSeekerSettings..::.tbPassword Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbPassword

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbTopCategoriesGroup Field

SiteSeekerSettings..::.tbTopCategoriesGroup Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbTopCategoriesGroup

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbUrl Field

SiteSeekerSettings..::.tbUrl Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbUrl

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbUrlMatch Field

SiteSeekerSettings..::.tbUrlMatch Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbUrlMatch

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbUrlReplace Field

SiteSeekerSettings..::.tbUrlReplace Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbUrlReplace

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


tbUsername Field

SiteSeekerSettings..::.tbUsername Field
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected TextBox tbUsername

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettings Methods

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettings Methods
SiteSeekerSettings Class See Also

The SiteSeekerSettings type exposes the following methods.

Methods

Name | Description
btnCheckConnection_Click |
btnSave_Click |
OnInit | (Overrides PageBase..::.OnInit(EventArgs).)
OnPreInit | (Inherited from SiteSeekerSettingsBase.)
Page_Load | (Inherited from SiteSeekerSettingsBase.)

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


btnCheckConnection_Click Method

SiteSeekerSettings..::.btnCheckConnection_Click Method
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void btnCheckConnection_Click(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


btnSave_Click Method

SiteSeekerSettings..::.btnSave_Click Method
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void btnSave_Click(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


OnInit Method

SiteSeekerSettings..::.OnInit Method
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettings Properties

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettings Properties
SiteSeekerSettings Class See Also

The SiteSeekerSettings type exposes the following properties.

Properties

Name | Description
CheckPermissions |
CrawlerUsername |
DynCategories |
DynCategoriesPropName |
EPiCategories |
Password |
SiteUrl |
TopCategories |
TopCategoriesGroup |
URL |
UrlMatch |
UrlReplace |
UrlRewrite |
Username |

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


CheckPermissions Property

SiteSeekerSettings..::.CheckPermissions Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool CheckPermissions { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


CrawlerUsername Property

SiteSeekerSettings..::.CrawlerUsername Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string CrawlerUsername { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


DynCategories Property

SiteSeekerSettings..::.DynCategories Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool DynCategories { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


DynCategoriesPropName Property

SiteSeekerSettings..::.DynCategoriesPropName Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string DynCategoriesPropName { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


EPiCategories Property

SiteSeekerSettings..::.EPiCategories Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool EPiCategories { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


Password Property

SiteSeekerSettings..::.Password Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Password { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


SiteUrl Property

SiteSeekerSettings..::.SiteUrl Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string SiteUrl { get; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


TopCategories Property

SiteSeekerSettings..::.TopCategories Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool TopCategories { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


TopCategoriesGroup Property

SiteSeekerSettings..::.TopCategoriesGroup Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string TopCategoriesGroup { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


URL Property

SiteSeekerSettings..::.URL Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string URL { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


UrlMatch Property

SiteSeekerSettings..::.UrlMatch Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool UrlMatch { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


UrlReplace Property

SiteSeekerSettings..::.UrlReplace Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool UrlReplace { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


UrlRewrite Property

SiteSeekerSettings..::.UrlRewrite Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool UrlRewrite { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


Username Property

SiteSeekerSettings..::.Username Property
SiteSeekerSettings Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Username { get; set; }

See Also

SiteSeekerSettings Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettingsBase Class

SiteSeekerSettingsBase Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SiteSeekerSettingsBase : SystemPageBase

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
PageBase
SystemPageBase
SiteSeeker.Compatibility..::.SiteSeekerSettingsBase
SiteSeeker.Compatibility..::.SiteSeekerSettings

See Also

SiteSeekerSettingsBase Members
SiteSeeker.Compatibility Namespace


SiteSeekerSettingsBase Members

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettingsBase Members
SiteSeekerSettingsBase Class Constructors Methods Fields See Also

The SiteSeekerSettingsBase type exposes the following members.

Constructors

Name | Description
SiteSeekerSettingsBase |

Methods

Name | Description
OnPreInit | (Overrides Page ..::. OnPreInit(EventArgs).)
Page_Load |

Fields

Name | Description
btnCheckConnection |
btnSave |
btnSaveConnectionTest |

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettingsBase Constructor

SiteSeekerSettingsBase Constructor
SiteSeekerSettingsBase Class See Also
Initializes a new instance of the SiteSeekerSettingsBase class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SiteSeekerSettingsBase()

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettingsBase Fields

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettingsBase Fields
SiteSeekerSettingsBase Class See Also

The SiteSeekerSettingsBase type exposes the following fields.

Fields

Name | Description
btnCheckConnection |
btnSave |
btnSaveConnectionTest |

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


btnCheckConnection Field

SiteSeekerSettingsBase..::.btnCheckConnection Field
SiteSeekerSettingsBase Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected ToolButton btnCheckConnection

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


btnSave Field

SiteSeekerSettingsBase..::.btnSave Field
SiteSeekerSettingsBase Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected ToolButton btnSave

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


btnSaveConnectionTest Field

SiteSeekerSettingsBase..::.btnSaveConnectionTest Field
SiteSeekerSettingsBase Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected ToolButton btnSaveConnectionTest

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


SiteSeekerSettingsBase Methods

[image]

SiteSeeker Search Module SDK (3.3)
SiteSeekerSettingsBase Methods
SiteSeekerSettingsBase Class See Also

The SiteSeekerSettingsBase type exposes the following methods.

Methods

Name | Description
OnPreInit | (Overrides Page ..::. OnPreInit(EventArgs).)
Page_Load |

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


OnPreInit Method

SiteSeekerSettingsBase..::.OnPreInit Method
SiteSeekerSettingsBase Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnPreInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


Page_Load Method

SiteSeekerSettingsBase..::.Page_Load Method
SiteSeekerSettingsBase Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

SiteSeekerSettingsBase Class
SiteSeeker.Compatibility Namespace


UnifiedFile Class

UnifiedFile Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class UnifiedFile

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.UnifiedFile

See Also

UnifiedFile Members
SiteSeeker.Compatibility Namespace


UnifiedFile Members

[image]

SiteSeeker Search Module SDK (3.3)
UnifiedFile Members
UnifiedFile Class Constructors Methods Properties See Also

The UnifiedFile type exposes the following members.

Constructors

Name | Description
UnifiedFile |

Methods

Name | Description
GetFile |

Properties

Name | Description
ACL |
Description |
Dictionary |
Title |
WrappedFile |

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


UnifiedFile Constructor

UnifiedFile Constructor
UnifiedFile Class See Also
Initializes a new instance of the UnifiedFile class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UnifiedFile(
    UnifiedFile wrappedFile
)

Parameters

wrappedFile
Type: UnifiedFile

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


UnifiedFile Methods

[image]

SiteSeeker Search Module SDK (3.3)
UnifiedFile Methods
UnifiedFile Class See Also

The UnifiedFile type exposes the following methods.

Methods

Name | Description
GetFile |

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


GetFile Method

UnifiedFile..::.GetFile Method
UnifiedFile Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static UnifiedFile GetFile(
    string filename
)

Parameters

filename
Type: System..::.String

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


UnifiedFile Properties

[image]

SiteSeeker Search Module SDK (3.3)
UnifiedFile Properties
UnifiedFile Class See Also

The UnifiedFile type exposes the following properties.

Properties

Name | Description
ACL |
Description |
Dictionary |
Title |
WrappedFile |

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


ACL Property

UnifiedFile..::.ACL Property
UnifiedFile Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public AccessControlList ACL { get; }

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


Description Property

UnifiedFile..::.Description Property
UnifiedFile Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Description { get; }

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


Dictionary Property

UnifiedFile..::.Dictionary Property
UnifiedFile Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public IDictionary Dictionary { get; }

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


Title Property

UnifiedFile..::.Title Property
UnifiedFile Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Title { get; }

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


WrappedFile Property

UnifiedFile..::.WrappedFile Property
UnifiedFile Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UnifiedFile WrappedFile { get; }

See Also

UnifiedFile Class
SiteSeeker.Compatibility Namespace


Url Class

Url Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Url

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.Url

See Also

Url Members
SiteSeeker.Compatibility Namespace


Url Members

[image]

SiteSeeker Search Module SDK (3.3)
Url Members
Url Class Constructors Methods See Also

The Url type exposes the following members.

Constructors

Name | Description
Url |

Methods

Name | Description
GetPageUrl | Returns the URL for the current page.
GetQueryString | Returns the query string for the given HTTP request. Needed because of behaviour in EPiServer 4 with FriendlyUrl enabled.
Transform | Transforms a UrlBuilder object. The quick search params are removed from the url. The language param is removed (EPiServer 4 only), and the page id param is removed if robot links are in use (EPiServer 4 only).

See Also

Url Class
SiteSeeker.Compatibility Namespace


Url Constructor

Url Constructor
Url Class See Also
Initializes a new instance of the Url class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Url()

See Also

Url Class
SiteSeeker.Compatibility Namespace


Url Methods

[image]

SiteSeeker Search Module SDK (3.3)
Url Methods
Url Class See Also

The Url type exposes the following methods.

Methods

Name | Description
GetPageUrl | Returns the URL for the current page.
GetQueryString | Returns the query string for the given HTTP request. Needed because of behaviour in EPiServer 4 with FriendlyUrl enabled.
Transform | Transforms a UrlBuilder object. The quick search params are removed from the url. The language param is removed (EPiServer 4 only), and the page id param is removed if robot links are in use (EPiServer 4 only).

See Also

Url Class
SiteSeeker.Compatibility Namespace


GetPageUrl Method

Url..::.GetPageUrl Method
Url Class See Also
Returns the URL for the current page.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string GetPageUrl(
    PageData currentPage
)

Parameters

currentPage
Type: PageData

See Also

Url Class
SiteSeeker.Compatibility Namespace


GetQueryString Method

Url..::.GetQueryString Method
Url Class See Also
Returns the query string for the given HTTP request. Needed because of behaviour in EPiServer 4 with FriendlyUrl enabled.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static NameValueCollection GetQueryString(
    HttpRequest request
)

Parameters

request
Type: System.Web..::.HttpRequest
The HTTP request

Return Value

A name-value collection with all query string parameters

See Also

Url Class
SiteSeeker.Compatibility Namespace


Transform Method

Url..::.Transform Method
Url Class See Also
Transforms a UrlBuilder object. The quick search params are removed from the url. The language param is removed (EPiServer 4 only), and the page id param is removed if robot links are in use (EPiServer 4 only).

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static void Transform(
    UrlBuilder url
)

Parameters

url
Type: SiteSeeker.Util..::.UrlBuilder

See Also

Url Class
SiteSeeker.Compatibility Namespace


UrlRewriteControl Class

UrlRewriteControl Class
Members See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class UrlRewriteControl

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.UrlRewriteControl

See Also

UrlRewriteControl Members
SiteSeeker.Compatibility Namespace


UrlRewriteControl Members

[image]

SiteSeeker Search Module SDK (3.3)
UrlRewriteControl Members
UrlRewriteControl Class Constructors Methods See Also

The UrlRewriteControl type exposes the following members.

Constructors

Name | Description
UrlRewriteControl |

Methods

Name | Description
Initialize |

See Also

UrlRewriteControl Class
SiteSeeker.Compatibility Namespace


UrlRewriteControl Constructor

UrlRewriteControl Constructor
UrlRewriteControl Class See Also
Initializes a new instance of the UrlRewriteControl class.

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlRewriteControl()

See Also

UrlRewriteControl Class
SiteSeeker.Compatibility Namespace


UrlRewriteControl Methods

[image]

SiteSeeker Search Module SDK (3.3)
UrlRewriteControl Methods
UrlRewriteControl Class See Also

The UrlRewriteControl type exposes the following methods.

Methods

Name | Description
Initialize |

See Also

UrlRewriteControl Class
SiteSeeker.Compatibility Namespace


Initialize Method

UrlRewriteControl..::.Initialize Method
UrlRewriteControl Class See Also

Namespace: SiteSeeker.Compatibility
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static void Initialize(
    int optionFlag
)

Parameters

optionFlag
Type: System..::.Int32

See Also

UrlRewriteControl Class
SiteSeeker.Compatibility Namespace


SiteSeeker.Control Namespace

SiteSeeker.Control Namespace
Namespace for control classes (i.e. Connector).

Classes

Class | Description
Connector | This class constructs the SearchRequest object based on the incoming search parameters. It is also responsible for fetching the SearchContext object and SearchResponse object from the model.
Connector..::.HttpParams | This class defines the names of the HTTP parameters read by the Connector. Parameter names can be prefixed by the Connector.ID in order to make the parameter specific for one Connector instance only. Parameter names prefixed with the id of the Connector overrides the default parameters.
EssUserControlBase |


Connector Class

Connector Class
Members See Also
This class constructs the SearchRequest object based on the incoming search parameters. It is also responsible for fetching the SearchContext object and SearchResponse object from the model.
Connector class.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Connector : UserControl

Remarks

Auto-generated class.

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
SiteSeeker.Control..::.Connector

See Also

Connector Members
SiteSeeker.Control Namespace


Connector Members

[image]

SiteSeeker Search Module SDK (3.3)
Connector Members
Connector Class Constructors Methods Fields Properties Events See Also

The Connector type exposes the following members.

Constructors

Name | Description
Connector | Constructs a new Connector instance.

Methods

Name | Description
GetHitCounterUrl | Full URL to hit counter script (used for click tracking). Includes session information. You should add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.
GetShowCacheUrl | URL to the ShowCache page that displays a cached snapshot of a hit (page/document) with the query terms highlighted. Includes session information. You should add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.
HandleError |
OnInit | Parses the HTTP request parameters, instantiates the SearchEngineFacade and performs a search. Note, since the Connector should only be loaded on non-postback requests, this method throws an exception if called during a postback. (Overrides UserControl ..::. OnInit(EventArgs).)

Fields

Name | Description
DefaultMaxAttachments | Indicates the default number of attachments for each hit. Connector..::.MaxAttachments

Properties

Name Description
AllowPostBack
Indicates whether PostBacks should be allowed, i.e. if a search is to be performed on a PostBack. The default value is false. Normally, this setting should not be changed for ordinary search pages, but if the search is performed automatically (e.g. as a listing of related pages included on everey page), this value should be set to true. If set to false and the connector is instantiated during a PostBack, an execption will be thrown.
AnyFiltersInOverview
Indicates whether any filters should appear in the overview. An any filter is a special kind of search filter that performs no filtering at all. E.g., for category filtering, an any filter is interpreted as "All categories".
Browsable
Indicates if this search page should be browsable, i.e. if an empty search query should return all hits. This may be used if it is desired that the user is shown hits, even if no query has been entered. Combined with categories shown in the overview, this may be used to enable browsing of pages while still allowing search queries.
Config
Returns the SiteSeeker.Environment.GlobalSettings object.
CurrentUrl
An URL for the current search page but without the current batch information. I.e., an HTTP request for this URL would generate an identical search as the current search but always asking for the first batch.
EmptyItemsInOverview
Indicates whether search filters with 0 matching documents should be returned. If this value is set to true, all items reported in the overview will contain at least 1 document.
ErrorMessage
Returns the current error message if an error has occured
HitCounterUrl
Hit counter base URL
InterfaceIdentifier
A string identifying a particular search page, e.g. "News search" or "Employee search". This string is then used to tell different search pages apart in the SiteSeeker Search Statistics tool, so do make sure that the names are meaningful and clear to the web editors who use the Statistics tool. Note! If there are several Connectors in one page, it is usually best to have them share the same Interface Identifier. See also Connector..::.NonInteractive
MatchingAttachmentsOnly
Indicates whether only attachments matching the search query should be shown, or if all attachments should be shown. Default is

Field Value

false.
MaxAttachments
Maximum number of attachments to be shown for each hit. The actual number of attachments may be equal or lower than this value. The default count is DefaultMaxAttachments, which lets the search engine determine the apropriate attachment count.
MaxQueryRefinements
Maximum number of query refinements to return with search response. Please note that this is a add-on service to SiteSeeker, which may require an additional service agreement and/or further configuration in SiteSeeker.
MetaAttributesEnabled
Indicates whether typed meta attributes are to be returned for each hit. This property must be set to true in order to get meta attributes from the search engine.
ModuleContext
Returns the module parameters configured in the admin view of this module.
NoFilterUrl
A URL containing the search query, session id and sort order but with all search filters disabled.
NonInteractive
Defines whether this Connector is used in an interactive search page (i.e. a normal search page, where the user enter some search terms) or non-interactively, for example in a "related pages" listing included in every page. This information can then be used by web editos in order to filter search statistics in the SiteSeeker Search Statistics tool. See also Connector..::.InterfaceIdentifier. This setting may also be used for improving search performance by using a suitable caching strategy.
QueryExtension
Query extension string. The search query will be extended with the value of this string. The default value of the query extension is read from the ModuleContext instance. Set this value in order to override the default value for the search page. It is also possible to specify the QueryExtension in the URL using the QueryExtension parameter.
SearchContext
Retrieves the search context parameters from the search engine.
SearchRequest
Returns the search requst that was constructed by parsing the current request parameters. The search request fully describes the request parameters sent to the search engine.
SearchResponse
Returns the search result fetched from the search engine using the SearchRequest object.
SearchSession
The search session holds an unique identifier for each search session. The identifier is used for relating user queries with clicks on the search page.
ShowCacheUrl
Base URL for cache display

Events

Name | Description
BeforeSearch | This event fires before the search is performed but after the initialization of SearchContext and SearchRequest.

See Also

Connector Class
SiteSeeker.Control Namespace


Connector Constructor

Connector Constructor
Connector Class See Also
Constructs a new Connector instance.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Connector(
    string id,
    ModuleContext moduleContext,
    Session session
)

Parameters

id
Type: System..::.String
moduleContext
Type: SiteSeeker.Environment..::.ModuleContext
session
Type: SiteSeeker.Util..::.Session

See Also

Connector Class
SiteSeeker.Control Namespace


Connector Fields

[image]

SiteSeeker Search Module SDK (3.3)
Connector Fields
Connector Class See Also

The Connector type exposes the following fields.

Fields

Name | Description
DefaultMaxAttachments | Indicates the default number of attachments for each hit. Connector..::.MaxAttachments

See Also

Connector Class
SiteSeeker.Control Namespace


DefaultMaxAttachments Field

Connector..::.DefaultMaxAttachments Field
Connector Class See Also
Indicates the default number of attachments for each hit. Connector..::.MaxAttachments

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const int DefaultMaxAttachments

See Also

Connector Class
SiteSeeker.Control Namespace
Connector..::.MaxAttachments


Connector Methods

[image]

SiteSeeker Search Module SDK (3.3)
Connector Methods
Connector Class See Also

The Connector type exposes the following methods.

Methods

Name | Description
GetHitCounterUrl | Full URL to hit counter script (used for click tracking). Includes session information. You should add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.
GetShowCacheUrl | URL to the ShowCache page that displays a cached snapshot of a hit (page/document) with the query terms highlighted. Includes session information. You should add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.
HandleError |
OnInit | Parses the HTTP request parameters, instantiates the SearchEngineFacade and performs a search. Note, since the Connector should only be loaded on non-postback requests, this method throws an exception if called during a postback. (Overrides UserControl ..::. OnInit(EventArgs).)

See Also

Connector Class
SiteSeeker.Control Namespace


GetHitCounterUrl Method

Connector..::.GetHitCounterUrl Method
Connector Class See Also
Full URL to hit counter script (used for click tracking). Includes session information. You should add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder GetHitCounterUrl()

See Also

Connector Class
SiteSeeker.Control Namespace


GetShowCacheUrl Method

Connector..::.GetShowCacheUrl Method
Connector Class See Also
URL to the ShowCache page that displays a cached snapshot of a hit (page/document) with the query terms highlighted. Includes session information. You should add necessary URL parameters for the current hit, i.e. HitNumber and Url to the hit page.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder GetShowCacheUrl()

See Also

Connector Class
SiteSeeker.Control Namespace


HandleError Method

Connector..::.HandleError Method
Connector Class See Also

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public virtual void HandleError(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Connector Class
SiteSeeker.Control Namespace


OnInit Method

Connector..::.OnInit Method
Connector Class See Also
Parses the HTTP request parameters, instantiates the SearchEngineFacade and performs a search. Note, since the Connector should only be loaded on non-postback requests, this method throws an exception if called during a postback.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

See Also

Connector Class
SiteSeeker.Control Namespace


Connector Properties

[image]

SiteSeeker Search Module SDK (3.3)
Connector Properties
Connector Class See Also

The Connector type exposes the following properties.

Properties

Name Description
AllowPostBack
Indicates whether PostBacks should be allowed, i.e. if a search is to be performed on a PostBack. The default value is false. Normally, this setting should not be changed for ordinary search pages, but if the search is performed automatically (e.g. as a listing of related pages included on everey page), this value should be set to true. If set to false and the connector is instantiated during a PostBack, an execption will be thrown.
AnyFiltersInOverview
Indicates whether any filters should appear in the overview. An any filter is a special kind of search filter that performs no filtering at all. E.g., for category filtering, an any filter is interpreted as "All categories".
Browsable
Indicates if this search page should be browsable, i.e. if an empty search query should return all hits. This may be used if it is desired that the user is shown hits, even if no query has been entered. Combined with categories shown in the overview, this may be used to enable browsing of pages while still allowing search queries.
Config
Returns the SiteSeeker.Environment.GlobalSettings object.
CurrentUrl
An URL for the current search page but without the current batch information. I.e., an HTTP request for this URL would generate an identical search as the current search but always asking for the first batch.
EmptyItemsInOverview
Indicates whether search filters with 0 matching documents should be returned. If this value is set to true, all items reported in the overview will contain at least 1 document.
ErrorMessage
Returns the current error message if an error has occured
HitCounterUrl
Hit counter base URL
InterfaceIdentifier
A string identifying a particular search page, e.g. "News search" or "Employee search". This string is then used to tell different search pages apart in the SiteSeeker Search Statistics tool, so do make sure that the names are meaningful and clear to the web editors who use the Statistics tool. Note! If there are several Connectors in one page, it is usually best to have them share the same Interface Identifier. See also Connector..::.NonInteractive
MatchingAttachmentsOnly
Indicates whether only attachments matching the search query should be shown, or if all attachments should be shown. Default is

Field Value

false.
MaxAttachments
Maximum number of attachments to be shown for each hit. The actual number of attachments may be equal or lower than this value. The default count is DefaultMaxAttachments, which lets the search engine determine the apropriate attachment count.
MaxQueryRefinements
Maximum number of query refinements to return with search response. Please note that this is a add-on service to SiteSeeker, which may require an additional service agreement and/or further configuration in SiteSeeker.
MetaAttributesEnabled
Indicates whether typed meta attributes are to be returned for each hit. This property must be set to true in order to get meta attributes from the search engine.
ModuleContext
Returns the module parameters configured in the admin view of this module.
NoFilterUrl
A URL containing the search query, session id and sort order but with all search filters disabled.
NonInteractive
Defines whether this Connector is used in an interactive search page (i.e. a normal search page, where the user enter some search terms) or non-interactively, for example in a "related pages" listing included in every page. This information can then be used by web editos in order to filter search statistics in the SiteSeeker Search Statistics tool. See also Connector..::.InterfaceIdentifier. This setting may also be used for improving search performance by using a suitable caching strategy.
QueryExtension
Query extension string. The search query will be extended with the value of this string. The default value of the query extension is read from the ModuleContext instance. Set this value in order to override the default value for the search page. It is also possible to specify the QueryExtension in the URL using the QueryExtension parameter.
SearchContext
Retrieves the search context parameters from the search engine.
SearchRequest
Returns the search requst that was constructed by parsing the current request parameters. The search request fully describes the request parameters sent to the search engine.
SearchResponse
Returns the search result fetched from the search engine using the SearchRequest object.
SearchSession
The search session holds an unique identifier for each search session. The identifier is used for relating user queries with clicks on the search page.
ShowCacheUrl
Base URL for cache display

See Also

Connector Class
SiteSeeker.Control Namespace


AllowPostBack Property

Connector..::.AllowPostBack Property
Connector Class See Also
Indicates whether PostBacks should be allowed, i.e. if a search is to be performed on a PostBack. The default value is false. Normally, this setting should not be changed for ordinary search pages, but if the search is performed automatically (e.g. as a listing of related pages included on everey page), this value should be set to true. If set to false and the connector is instantiated during a PostBack, an execption will be thrown.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool AllowPostBack { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


AnyFiltersInOverview Property

Connector..::.AnyFiltersInOverview Property
Connector Class See Also
Indicates whether any filters should appear in the overview. An any filter is a special kind of search filter that performs no filtering at all. E.g., for category filtering, an any filter is interpreted as "All categories".

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool AnyFiltersInOverview { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


Browsable Property

Connector..::.Browsable Property
Connector Class See Also
Indicates if this search page should be browsable, i.e. if an empty search query should return all hits. This may be used if it is desired that the user is shown hits, even if no query has been entered. Combined with categories shown in the overview, this may be used to enable browsing of pages while still allowing search queries.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool Browsable { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


Config Property

Connector..::.Config Property
Connector Class See Also
Returns the SiteSeeker.Environment.GlobalSettings object.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettings Config { get; }

Return Value

The SiteSeeker.Environment.GlobalSettings object

See Also

Connector Class
SiteSeeker.Control Namespace


CurrentUrl Property

Connector..::.CurrentUrl Property
Connector Class See Also
An URL for the current search page but without the current batch information. I.e., an HTTP request for this URL would generate an identical search as the current search but always asking for the first batch.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder CurrentUrl { get; }

See Also

Connector Class
SiteSeeker.Control Namespace


EmptyItemsInOverview Property

Connector..::.EmptyItemsInOverview Property
Connector Class See Also
Indicates whether search filters with 0 matching documents should be returned. If this value is set to true, all items reported in the overview will contain at least 1 document.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool EmptyItemsInOverview { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


ErrorMessage Property

Connector..::.ErrorMessage Property
Connector Class See Also
Returns the current error message if an error has occured

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ErrorMessage { get; }

Return Value

The error message

See Also

Connector Class
SiteSeeker.Control Namespace


HitCounterUrl Property

Connector..::.HitCounterUrl Property
Connector Class Example See Also
Hit counter base URL

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string HitCounterUrl { set; }

Examples

/SiteSeeker/HitCounter.aspx

See Also

Connector Class
SiteSeeker.Control Namespace


InterfaceIdentifier Property

Connector..::.InterfaceIdentifier Property
Connector Class See Also
A string identifying a particular search page, e.g. "News search" or "Employee search". This string is then used to tell different search pages apart in the SiteSeeker Search Statistics tool, so do make sure that the names are meaningful and clear to the web editors who use the Statistics tool. Note! If there are several Connectors in one page, it is usually best to have them share the same Interface Identifier. See also Connector..::.NonInteractive

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string InterfaceIdentifier { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace
Connector..::.NonInteractive


MatchingAttachmentsOnly Property

Connector..::.MatchingAttachmentsOnly Property
Connector Class See Also
Indicates whether only attachments matching the search query should be shown, or if all attachments should be shown. Default is

Field Value

false.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool MatchingAttachmentsOnly { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


MaxAttachments Property

Connector..::.MaxAttachments Property
Connector Class See Also
Maximum number of attachments to be shown for each hit. The actual number of attachments may be equal or lower than this value. The default count is DefaultMaxAttachments, which lets the search engine determine the apropriate attachment count.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int MaxAttachments { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


MaxQueryRefinements Property

Connector..::.MaxQueryRefinements Property
Connector Class See Also
Maximum number of query refinements to return with search response. Please note that this is a add-on service to SiteSeeker, which may require an additional service agreement and/or further configuration in SiteSeeker.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int MaxQueryRefinements { get; set; }

Remarks

Please contact sales@euroling.se for more information on this feature.

See Also

Connector Class
SiteSeeker.Control Namespace


MetaAttributesEnabled Property

Connector..::.MetaAttributesEnabled Property
Connector Class See Also
Indicates whether typed meta attributes are to be returned for each hit. This property must be set to true in order to get meta attributes from the search engine.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool MetaAttributesEnabled { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


ModuleContext Property

Connector..::.ModuleContext Property
Connector Class See Also
Returns the module parameters configured in the admin view of this module.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ModuleContext ModuleContext { get; }

Return Value

The module context

See Also

Connector Class
SiteSeeker.Control Namespace


NoFilterUrl Property

Connector..::.NoFilterUrl Property
Connector Class See Also
A URL containing the search query, session id and sort order but with all search filters disabled.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder NoFilterUrl { get; }

See Also

Connector Class
SiteSeeker.Control Namespace


NonInteractive Property

Connector..::.NonInteractive Property
Connector Class See Also
Defines whether this Connector is used in an interactive search page (i.e. a normal search page, where the user enter some search terms) or non-interactively, for example in a "related pages" listing included in every page. This information can then be used by web editos in order to filter search statistics in the SiteSeeker Search Statistics tool. See also Connector..::.InterfaceIdentifier. This setting may also be used for improving search performance by using a suitable caching strategy.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool NonInteractive { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace
Connector..::.InterfaceIdentifier


QueryExtension Property

Connector..::.QueryExtension Property
Connector Class Example See Also
Query extension string. The search query will be extended with the value of this string. The default value of the query extension is read from the ModuleContext instance. Set this value in order to override the default value for the search page. It is also possible to specify the QueryExtension in the URL using the QueryExtension parameter.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string QueryExtension { get; set; }

Examples

The following extension limit the query to documents contained in the category "Cars" or "Bicycles".
CopyC#
(hidden:meta:category:Cars OR hidden:meta:category:Bicycles)

See Also

Connector Class
SiteSeeker.Control Namespace


SearchContext Property

Connector..::.SearchContext Property
Connector Class See Also
Retrieves the search context parameters from the search engine.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchContext SearchContext { get; }

Return Value

The SearchContext object on success, null otherwise.

See Also

Connector Class
SiteSeeker.Control Namespace


SearchRequest Property

Connector..::.SearchRequest Property
Connector Class See Also
Returns the search requst that was constructed by parsing the current request parameters. The search request fully describes the request parameters sent to the search engine.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchRequest SearchRequest { get; set; }

Return Value

The search request describing the parameters sent to the search engine in order to retreive the search result

See Also

Connector Class
SiteSeeker.Control Namespace


SearchResponse Property

Connector..::.SearchResponse Property
Connector Class See Also
Returns the search result fetched from the search engine using the SearchRequest object.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchResponse SearchResponse { get; }

Return Value

The search result represented by the SearchResponse object

See Also

Connector Class
SiteSeeker.Control Namespace


SearchSession Property

Connector..::.SearchSession Property
Connector Class See Also
The search session holds an unique identifier for each search session. The identifier is used for relating user queries with clicks on the search page.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Session SearchSession { get; set; }

See Also

Connector Class
SiteSeeker.Control Namespace


ShowCacheUrl Property

Connector..::.ShowCacheUrl Property
Connector Class See Also
Base URL for cache display

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ShowCacheUrl { set; }

See Also

Connector Class
SiteSeeker.Control Namespace


Connector Events

[image]

SiteSeeker Search Module SDK (3.3)
Connector Events
Connector Class See Also

The Connector type exposes the following events.

Events

Name | Description
BeforeSearch | This event fires before the search is performed but after the initialization of SearchContext and SearchRequest.

See Also

Connector Class
SiteSeeker.Control Namespace


BeforeSearch Event

Connector..::.BeforeSearch Event
Connector Class See Also
This event fires before the search is performed but after the initialization of SearchContext and SearchRequest.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public event EventHandler BeforeSearch

See Also

Connector Class
SiteSeeker.Control Namespace


Connector.HttpParams Class

Connector..::.HttpParams Class
Connector Class Members See Also
This class defines the names of the HTTP parameters read by the Connector. Parameter names can be prefixed by the Connector.ID in order to make the parameter specific for one Connector instance only. Parameter names prefixed with the id of the Connector overrides the default parameters.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static class HttpParams

Inheritance Hierarchy

System..::.Object
SiteSeeker.Control..::.Connector..::.HttpParams

See Also

Connector..::.HttpParams Members
SiteSeeker.Control Namespace
SiteSeeker.Util..::.UrlBuilder


Connector.HttpParams Members

[image]

SiteSeeker Search Module SDK (3.3)
Connector..::.HttpParams Members
Connector..::.HttpParams Class Fields See Also

This class constructs the SearchRequest object based on the incoming search parameters. It is also responsible for fetching the SearchContext object and SearchResponse object from the model.
Connector class.

The Connector..::.HttpParams type exposes the following members.

Fields

Name | Description
Age | Age refers to custom intervals defined for a specific client.
BatchNumber | The number of the batch/page to be returned.
Categories | Limit query to documents in the specified category(ies). Multiple categories are separated by commas.
DateTimeFrom | Limit query to documents modified after this date.
DateTimeTo | Limit query to documents modified before this date.
FileFormat | Limit query to documents of the specified file format.
IsSpellingSuggestion | Indicates if the query is a spelling suggestion supplied by the search engine. Must be set to true when the user has clicked on a spelling suggestion, false otherwise.
Language | Limit query to documents in the specified language.
NHitsPerBatch | Number of hits desired in each batch.
Params | A comma separated list of generic key-value pairs sent to the search engine. Keys and names should be separated by colon (':').
Query | The name of the search query parameter.
QueryExtension | Query extension string. The search query will be extended with the value of this string.
QuickSearchCategory | The name of the category parameter used from other pages than the search page. This parameter overrides the value of the Categories parameter.
QuickSearchQuery | The name of the query parameter used from other pages than the search page. This parameter overrides the value of the Query parameter.
ResponseID | The id of the last search response, see SearchResponse.
SessionID | The id of the user search session
SortOrder | Sort order for hits in the result list. Note, it is also possible to define a sort order for typed meta attributes using the query extension.
UniqueCategory | Limit query to documents in the specified category. Multiple categories are not allowed. This parameter overrides the value of the Categories parameter.
UseStemming | Specifies whether stemming should be used when evaluating query. Default value is true, i.e. stemming is enabled.

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


Connector.HttpParams Fields

[image]

SiteSeeker Search Module SDK (3.3)
Connector..::.HttpParams Fields
Connector..::.HttpParams Class See Also

The Connector..::.HttpParams type exposes the following fields.

Fields

Name | Description
Age | Age refers to custom intervals defined for a specific client.
BatchNumber | The number of the batch/page to be returned.
Categories | Limit query to documents in the specified category(ies). Multiple categories are separated by commas.
DateTimeFrom | Limit query to documents modified after this date.
DateTimeTo | Limit query to documents modified before this date.
FileFormat | Limit query to documents of the specified file format.
IsSpellingSuggestion | Indicates if the query is a spelling suggestion supplied by the search engine. Must be set to true when the user has clicked on a spelling suggestion, false otherwise.
Language | Limit query to documents in the specified language.
NHitsPerBatch | Number of hits desired in each batch.
Params | A comma separated list of generic key-value pairs sent to the search engine. Keys and names should be separated by colon (':').
Query | The name of the search query parameter.
QueryExtension | Query extension string. The search query will be extended with the value of this string.
QuickSearchCategory | The name of the category parameter used from other pages than the search page. This parameter overrides the value of the Categories parameter.
QuickSearchQuery | The name of the query parameter used from other pages than the search page. This parameter overrides the value of the Query parameter.
ResponseID | The id of the last search response, see SearchResponse.
SessionID | The id of the user search session
SortOrder | Sort order for hits in the result list. Note, it is also possible to define a sort order for typed meta attributes using the query extension.
UniqueCategory | Limit query to documents in the specified category. Multiple categories are not allowed. This parameter overrides the value of the Categories parameter.
UseStemming | Specifies whether stemming should be used when evaluating query. Default value is true, i.e. stemming is enabled.

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


Age Field

Connector..::.HttpParams..::.Age Field
Connector..::.HttpParams Class See Also
Age refers to custom intervals defined for a specific client.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Age

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


BatchNumber Field

Connector..::.HttpParams..::.BatchNumber Field
Connector..::.HttpParams Class See Also
The number of the batch/page to be returned.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string BatchNumber

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


Categories Field

Connector..::.HttpParams..::.Categories Field
Connector..::.HttpParams Class See Also
Limit query to documents in the specified category(ies). Multiple categories are separated by commas.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Categories

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


DateTimeFrom Field

Connector..::.HttpParams..::.DateTimeFrom Field
Connector..::.HttpParams Class See Also
Limit query to documents modified after this date.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string DateTimeFrom

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


DateTimeTo Field

Connector..::.HttpParams..::.DateTimeTo Field
Connector..::.HttpParams Class See Also
Limit query to documents modified before this date.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string DateTimeTo

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


FileFormat Field

Connector..::.HttpParams..::.FileFormat Field
Connector..::.HttpParams Class See Also
Limit query to documents of the specified file format.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string FileFormat

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


IsSpellingSuggestion Field

Connector..::.HttpParams..::.IsSpellingSuggestion Field
Connector..::.HttpParams Class See Also
Indicates if the query is a spelling suggestion supplied by the search engine. Must be set to true when the user has clicked on a spelling suggestion, false otherwise.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string IsSpellingSuggestion

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


Language Field

Connector..::.HttpParams..::.Language Field
Connector..::.HttpParams Class See Also
Limit query to documents in the specified language.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Language

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


NHitsPerBatch Field

Connector..::.HttpParams..::.NHitsPerBatch Field
Connector..::.HttpParams Class See Also
Number of hits desired in each batch.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string NHitsPerBatch

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


Params Field

Connector..::.HttpParams..::.Params Field
Connector..::.HttpParams Class See Also
A comma separated list of generic key-value pairs sent to the search engine. Keys and names should be separated by colon (':').

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Params

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


Query Field

Connector..::.HttpParams..::.Query Field
Connector..::.HttpParams Class See Also
The name of the search query parameter.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Query

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


QueryExtension Field

Connector..::.HttpParams..::.QueryExtension Field
Connector..::.HttpParams Class See Also
Query extension string. The search query will be extended with the value of this string.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string QueryExtension

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


QuickSearchCategory Field

Connector..::.HttpParams..::.QuickSearchCategory Field
Connector..::.HttpParams Class See Also
The name of the category parameter used from other pages than the search page. This parameter overrides the value of the Categories parameter.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string QuickSearchCategory

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


QuickSearchQuery Field

Connector..::.HttpParams..::.QuickSearchQuery Field
Connector..::.HttpParams Class See Also
The name of the query parameter used from other pages than the search page. This parameter overrides the value of the Query parameter.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string QuickSearchQuery

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


ResponseID Field

Connector..::.HttpParams..::.ResponseID Field
Connector..::.HttpParams Class See Also
The id of the last search response, see SearchResponse.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string ResponseID

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


SessionID Field

Connector..::.HttpParams..::.SessionID Field
Connector..::.HttpParams Class See Also
The id of the user search session

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string SessionID

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


SortOrder Field

Connector..::.HttpParams..::.SortOrder Field
Connector..::.HttpParams Class See Also
Sort order for hits in the result list. Note, it is also possible to define a sort order for typed meta attributes using the query extension.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string SortOrder

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


UniqueCategory Field

Connector..::.HttpParams..::.UniqueCategory Field
Connector..::.HttpParams Class See Also
Limit query to documents in the specified category. Multiple categories are not allowed. This parameter overrides the value of the Categories parameter.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string UniqueCategory

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


UseStemming Field

Connector..::.HttpParams..::.UseStemming Field
Connector..::.HttpParams Class See Also
Specifies whether stemming should be used when evaluating query. Default value is true, i.e. stemming is enabled.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string UseStemming

See Also

Connector..::.HttpParams Class
SiteSeeker.Control Namespace


EssUserControlBase Class

EssUserControlBase Class
Members See Also

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public abstract class EssUserControlBase : UserControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.UserControl
SiteSeeker.Control..::.EssUserControlBase
development.search..::.Form
development.search..::.Result
development.search..::.Overview
development.search.Extras..::.Cloud

See Also

EssUserControlBase Members
SiteSeeker.Control Namespace


EssUserControlBase Members

[image]

SiteSeeker Search Module SDK (3.3)
EssUserControlBase Members
EssUserControlBase Class Constructors Methods Properties See Also

The EssUserControlBase type exposes the following members.

Constructors

Name | Description
EssUserControlBase |

Methods

Name | Description
Page_Load | Handles the page load event. If the current request is a non-postback request, update the view with the updated model.
Translate | Translate the key into a language specific text.
UpdateView | Updates the view. This method is invoked during Page_Load event on non-postback request.

Properties

Name | Description
Connector | The connetor to use for this user control.
ConnectorID | The identifier of the connetor to use for this user control.

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


EssUserControlBase Constructor

EssUserControlBase Constructor
EssUserControlBase Class See Also
Initializes a new instance of the EssUserControlBase class.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected EssUserControlBase()

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


EssUserControlBase Methods

[image]

SiteSeeker Search Module SDK (3.3)
EssUserControlBase Methods
EssUserControlBase Class See Also

The EssUserControlBase type exposes the following methods.

Methods

Name | Description
Page_Load | Handles the page load event. If the current request is a non-postback request, update the view with the updated model.
Translate | Translate the key into a language specific text.
UpdateView | Updates the view. This method is invoked during Page_Load event on non-postback request.

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


Page_Load Method

EssUserControlBase..::.Page_Load Method
EssUserControlBase Class See Also
Handles the page load event. If the current request is a non-postback request, update the view with the updated model.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void Page_Load(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


Translate Method

EssUserControlBase..::.Translate Method
EssUserControlBase Class See Also
Translate the key into a language specific text.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Translate(
    string s
)

Parameters

s
Type: System..::.String
Key for string to translate.

Return Value

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


UpdateView Method

EssUserControlBase..::.UpdateView Method
EssUserControlBase Class See Also
Updates the view. This method is invoked during Page_Load event on non-postback request.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected virtual void UpdateView()

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


EssUserControlBase Properties

[image]

SiteSeeker Search Module SDK (3.3)
EssUserControlBase Properties
EssUserControlBase Class See Also

The EssUserControlBase type exposes the following properties.

Properties

Name | Description
Connector | The connetor to use for this user control.
ConnectorID | The identifier of the connetor to use for this user control.

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


Connector Property

EssUserControlBase..::.Connector Property
EssUserControlBase Class See Also
The connetor to use for this user control.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Connector Connector { get; set; }

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


ConnectorID Property

EssUserControlBase..::.ConnectorID Property
EssUserControlBase Class See Also
The identifier of the connetor to use for this user control.

Namespace: SiteSeeker.Control
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ConnectorID { get; set; }

See Also

EssUserControlBase Class
SiteSeeker.Control Namespace


SiteSeeker.Environment Namespace

SiteSeeker.Environment Namespace
Classes defining the module environment, i.e. global settings for SiteSeeker connectability and settings local to the current search page.

Classes

Class | Description
GlobalSettings |
ModuleContext |


GlobalSettings Class

GlobalSettings Class
Members See Also

Namespace: SiteSeeker.Environment
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class GlobalSettings : GlobalSettings

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.GlobalSettingsBase
SiteSeeker.Compatibility..::.GlobalSettings
SiteSeeker.Environment..::.GlobalSettings

See Also

GlobalSettings Members
SiteSeeker.Environment Namespace


GlobalSettings Members

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Members
GlobalSettings Class Constructors See Also

Constructors

Name | Description
GlobalSettings | Overloaded.

See Also

GlobalSettings Class
SiteSeeker.Environment Namespace


GlobalSettings Constructor

[image]

SiteSeeker Search Module SDK (3.3)
GlobalSettings Constructor
GlobalSettings Class See Also

Overload List

Name | Description
GlobalSettings()()() | Create a new settings object, and load plugin configuration.
GlobalSettings(String, String, String) | Create a new settings object, load plugin configuration, and then override url, username and password. May be used to test the web service connection. If any argument is null, the corresponding value from the plugin configuration will be used.

See Also

GlobalSettings Class
GlobalSettings Members
SiteSeeker.Environment Namespace


GlobalSettings Constructor

GlobalSettings Constructor
GlobalSettings Class See Also
Create a new settings object, and load plugin configuration.

Namespace: SiteSeeker.Environment
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettings()

See Also

GlobalSettings Class
GlobalSettings Overload
SiteSeeker.Environment Namespace


GlobalSettings Constructor (String, String, String)

GlobalSettings Constructor (String, String, String)
GlobalSettings Class See Also
Create a new settings object, load plugin configuration, and then override url, username and password. May be used to test the web service connection. If any argument is null, the corresponding value from the plugin configuration will be used.

Namespace: SiteSeeker.Environment
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public GlobalSettings(
    string url,
    string username,
    string password
)

Parameters

url
Type: System..::.String
Web service URL, including protocol and port number.
username
Type: System..::.String
Web service username.
password
Type: System..::.String
Web service password.

See Also

GlobalSettings Class
GlobalSettings Overload
SiteSeeker.Environment Namespace


ModuleContext Class

ModuleContext Class
Members See Also

Namespace: SiteSeeker.Environment
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class ModuleContext : ModuleContext

Inheritance Hierarchy

System..::.Object
SiteSeeker.Compatibility..::.ModuleContext
SiteSeeker.Environment..::.ModuleContext

See Also

ModuleContext Members
SiteSeeker.Environment Namespace


ModuleContext Members

[image]

SiteSeeker Search Module SDK (3.3)
ModuleContext Members
ModuleContext Class Constructors See Also

The ModuleContext type exposes the following members.

Constructors

Name | Description
ModuleContext |

See Also

ModuleContext Class
SiteSeeker.Environment Namespace


ModuleContext Constructor

ModuleContext Constructor
ModuleContext Class See Also
Initializes a new instance of the ModuleContext class.

Namespace: SiteSeeker.Environment
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ModuleContext(
    Object searchPage
)

Parameters

searchPage
Type: System..::.Object

See Also

ModuleContext Class
SiteSeeker.Environment Namespace


SiteSeeker.HttpHandlers Namespace

SiteSeeker.HttpHandlers Namespace

Classes

Class | Description
QueryCompletion | Provides query completions for a given string. This HTTP Handler must be specified in web.config.


QueryCompletion Class

QueryCompletion Class
Members See Also
Provides query completions for a given string. This HTTP Handler must be specified in web.config.

Namespace: SiteSeeker.HttpHandlers
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class QueryCompletion : IHttpHandler

Remarks

The default name for this handler is SiteSeeker/QueryCompletion.axd.

Inheritance Hierarchy

System..::.Object
SiteSeeker.HttpHandlers..::.QueryCompletion

See Also

QueryCompletion Members
SiteSeeker.HttpHandlers Namespace


QueryCompletion Members

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletion Members
QueryCompletion Class Constructors Methods Properties See Also

The QueryCompletion type exposes the following members.

Constructors

Name | Description
QueryCompletion |

Methods

Name | Description
ProcessRequest | Prints a json or jsonp string containing query completions for a given string.
WriteJsonResponse | Prints the actual json response. If the parameter callback is non-empty, the response will be wrapped in a jsonp-style function with the same name as the parameter value.

Properties

Name | Description
Config | Returns a global configuration object for this server instance. The configuration object contains information about the SiteSeeker web service endpoint, along with login credentials for the web service.
IsReusable | This handler is reusable, i.e. returns true.

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


QueryCompletion Constructor

QueryCompletion Constructor
QueryCompletion Class See Also
Initializes a new instance of the QueryCompletion class.

Namespace: SiteSeeker.HttpHandlers
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public QueryCompletion()

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


QueryCompletion Methods

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletion Methods
QueryCompletion Class See Also

The QueryCompletion type exposes the following methods.

Methods

Name | Description
ProcessRequest | Prints a json or jsonp string containing query completions for a given string.
WriteJsonResponse | Prints the actual json response. If the parameter callback is non-empty, the response will be wrapped in a jsonp-style function with the same name as the parameter value.

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


ProcessRequest Method

QueryCompletion..::.ProcessRequest Method
QueryCompletion Class See Also
Prints a json or jsonp string containing query completions for a given string.

Namespace: SiteSeeker.HttpHandlers
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void ProcessRequest(
    HttpContext context
)

Parameters

context
Type: System.Web..::.HttpContext
HttpContext object.

Implements

IHttpHandler..::.ProcessRequest(HttpContext)

Remarks

The following parameters must be set in the HTTP GET request: ilang, the interface language; q, the user-entered query string; and optionally callback, the jsonp callback name.

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


WriteJsonResponse Method

QueryCompletion..::.WriteJsonResponse Method
QueryCompletion Class See Also
Prints the actual json response. If the parameter callback is non-empty, the response will be wrapped in a jsonp-style function with the same name as the parameter value.

Namespace: SiteSeeker.HttpHandlers
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected void WriteJsonResponse(
    HttpResponse response,
    string jsonResponse,
    string callback
)

Parameters

response
Type: System.Web..::.HttpResponse
HTTP Response object, for printing the json string.
jsonResponse
Type: System..::.String
The json response string to be printed.
callback
Type: System..::.String
The name of the jsonp callback function. Leave empty (or set to null) for no callback.

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


QueryCompletion Properties

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletion Properties
QueryCompletion Class See Also

The QueryCompletion type exposes the following properties.

Properties

Name | Description
Config | Returns a global configuration object for this server instance. The configuration object contains information about the SiteSeeker web service endpoint, along with login credentials for the web service.
IsReusable | This handler is reusable, i.e. returns true.

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


Config Property

QueryCompletion..::.Config Property
QueryCompletion Class See Also
Returns a global configuration object for this server instance. The configuration object contains information about the SiteSeeker web service endpoint, along with login credentials for the web service.

Namespace: SiteSeeker.HttpHandlers
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected GlobalSettings Config { get; }

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


IsReusable Property

QueryCompletion..::.IsReusable Property
QueryCompletion Class See Also
This handler is reusable, i.e. returns true.

Namespace: SiteSeeker.HttpHandlers
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsReusable { get; }

Implements

IHttpHandler..::.IsReusable

See Also

QueryCompletion Class
SiteSeeker.HttpHandlers Namespace


SiteSeeker.Model Namespace

SiteSeeker.Model Namespace
Classes encapsulating the SiteSeeker web service API.

Classes

Class | Description
Age |
Bet | This class represents a best bet, a special kind of hit comparable to a sponsored link.
Category | This class represents a certain category of documents.
CategoryGroup | This class represents a certain group of document categories.
Click | This class represents a user click to b
DateTimeInfo |
DateTimeRange |
DefaultAccessController |
FileFormat |
FileFormatCollection |
Hit | A search hit, describing the document found.
Language |
MetaAttributes | A class that represents a set of meta attributes related to a particular document.
QueryCompletionResponse |
QueryRefinement |
SearchContext | The search context holds information about the current index.
SearchContextExpiredException | This exception is thrown if the search context has expired, i.e. is older than the modification time of the index that is beeing used while handling search queries.
SearchEngineFacade | This class encapsulates all communication with the search engine using the SiteSeeker Web Service API.
SearchFilter | Base class for all entities that can be used for filtering a search result.
SearchFilterCollection<(Of <(T>)>) | A collection of related search filters, e.g., categories, file formats.
SearchRequest | A SearchRequest object provides the entire search request information sent to the search engine. Use the SearchRequest object to determine the properties of the current search.
SearchRequest..::.ParameterNames | The names (i.e. keys) of the available search request parameters.
SearchResponse | Contains the data returned from the search engine in response to a particular search request. The number of docs reported in the search filters included in this instance denotes the number of documents that were found for the issued search request.
SpellingSuggestion | Describes a spelling suggestion. Spelling suggestions

Interfaces

Interface | Description
IAccessController | An instance of this interface is responsible for controlling the access to pages. SearchEngineFacade uses this interface to determine which pages (hits) to remove from the list of retreived hits.

Enumerations

Enumeration | Description
ClickMode | Describes the type of click.
SortOrder | Sort order for hits in result list. Note that CategoryCatBatch is not recommended when using access control.


Age Class

Age Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Age : SearchFilter

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchFilter
SiteSeeker.Model..::.Age

See Also

Age Members
SiteSeeker.Model Namespace


Age Members

[image]

SiteSeeker Search Module SDK (3.3)
Age Members
Age Class Constructors Fields Properties See Also

The Age type exposes the following members.

Constructors

Name | Description
Age | Overloaded.

Fields

Name | Description
Empty |

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)
DateTimeRange |

See Also

Age Class
SiteSeeker.Model Namespace


Age Constructor

[image]

SiteSeeker Search Module SDK (3.3)
Age Constructor
Age Class See Also

Overload List

Name | Description
Age(Age) |
Age(Int32, String, String, Int32, DateTimeRange) |

See Also

Age Class
Age Members
SiteSeeker.Model Namespace


Age Constructor (Age)

Age Constructor (Age)
Age Class See Also
Initializes a new instance of the Age class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Age(
    Age age
)

Parameters

age
Type: SiteSeeker.Model..::.Age

See Also

Age Class
Age Overload
SiteSeeker.Model Namespace


Age Constructor (Int32, String, String, Int32, DateTimeRange)

Age Constructor (Int32, String, String, Int32, DateTimeRange)
Age Class See Also
Initializes a new instance of the Age class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Age(
    int id,
    string key,
    string name,
    int nDocs,
    DateTimeRange dateTimeRange
)

Parameters

id
Type: System..::.Int32
key
Type: System..::.String
name
Type: System..::.String
nDocs
Type: System..::.Int32
dateTimeRange
Type: SiteSeeker.Model..::.DateTimeRange

See Also

Age Class
Age Overload
SiteSeeker.Model Namespace


Age Fields

[image]

SiteSeeker Search Module SDK (3.3)
Age Fields
Age Class See Also

The Age type exposes the following fields.

Fields

Name | Description
Empty |

See Also

Age Class
SiteSeeker.Model Namespace


Empty Field

Age..::.Empty Field
Age Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static Age Empty

See Also

Age Class
SiteSeeker.Model Namespace


Age Properties

[image]

SiteSeeker Search Module SDK (3.3)
Age Properties
Age Class See Also

The Age type exposes the following properties.

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)
DateTimeRange |

See Also

Age Class
SiteSeeker.Model Namespace


AnyID Property

Age..::.AnyID Property
Age Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override int AnyID { get; }

See Also

Age Class
SiteSeeker.Model Namespace


DateTimeRange Property

Age..::.DateTimeRange Property
Age Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTimeRange DateTimeRange { get; }

See Also

Age Class
SiteSeeker.Model Namespace


Bet Class

Bet Class
Members See Also
This class represents a best bet, a special kind of hit comparable to a sponsored link.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Bet

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.Bet

See Also

Bet Members
SiteSeeker.Model Namespace


Bet Members

[image]

SiteSeeker Search Module SDK (3.3)
Bet Members
Bet Class Constructors Fields Properties See Also

The Bet type exposes the following members.

Constructors

Name | Description
Bet | Constructs a new best bet.

Fields

Name | Description
betNumber |
description |
isExternal |
keywords |
language |
title |
url |

Properties

Name | Description
BetNumber | Ordinal number of returned best bet, starting with 1.
Description | Description of the bet. The description may contain HTML code.
IsExternal | Indicates whether the URL of best bet is an external server or not. External servers are servers that are not indexed by the search engine.
Keywords | A list of strings, where each string contains either one or more keywords for this best bet.
Language | The language of the best bet.
Title | Title of the best bet. Should be displayed as link text.
Url | The complete URL, including protocol prefix, of the best bet.

See Also

Bet Class
SiteSeeker.Model Namespace


Bet Constructor

Bet Constructor
Bet Class See Also
Constructs a new best bet.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Bet(
    int betNumber,
    string url,
    string title,
    string description,
    Language language,
    List<string> keywords,
    bool isExternal
)

Parameters

betNumber
Type: System..::.Int32
url
Type: System..::.String
title
Type: System..::.String
description
Type: System..::.String
language
Type: SiteSeeker.Model..::.Language
keywords
Type: System.Collections.Generic..::.List <(Of <( String >)>)
isExternal
Type: System..::.Boolean

See Also

Bet Class
SiteSeeker.Model Namespace


Bet Fields

[image]

SiteSeeker Search Module SDK (3.3)
Bet Fields
Bet Class See Also

The Bet type exposes the following fields.

Fields

Name | Description
betNumber |
description |
isExternal |
keywords |
language |
title |
url |

See Also

Bet Class
SiteSeeker.Model Namespace


betNumber Field

Bet..::.betNumber Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected int betNumber

See Also

Bet Class
SiteSeeker.Model Namespace


description Field

Bet..::.description Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string description

See Also

Bet Class
SiteSeeker.Model Namespace


isExternal Field

Bet..::.isExternal Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected bool isExternal

See Also

Bet Class
SiteSeeker.Model Namespace


keywords Field

Bet..::.keywords Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected List<string> keywords

See Also

Bet Class
SiteSeeker.Model Namespace


language Field

Bet..::.language Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected Language language

See Also

Bet Class
SiteSeeker.Model Namespace


title Field

Bet..::.title Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string title

See Also

Bet Class
SiteSeeker.Model Namespace


url Field

Bet..::.url Field
Bet Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string url

See Also

Bet Class
SiteSeeker.Model Namespace


Bet Properties

[image]

SiteSeeker Search Module SDK (3.3)
Bet Properties
Bet Class See Also

The Bet type exposes the following properties.

Properties

Name | Description
BetNumber | Ordinal number of returned best bet, starting with 1.
Description | Description of the bet. The description may contain HTML code.
IsExternal | Indicates whether the URL of best bet is an external server or not. External servers are servers that are not indexed by the search engine.
Keywords | A list of strings, where each string contains either one or more keywords for this best bet.
Language | The language of the best bet.
Title | Title of the best bet. Should be displayed as link text.
Url | The complete URL, including protocol prefix, of the best bet.

See Also

Bet Class
SiteSeeker.Model Namespace


BetNumber Property

Bet..::.BetNumber Property
Bet Class See Also
Ordinal number of returned best bet, starting with 1.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int BetNumber { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


Description Property

Bet..::.Description Property
Bet Class See Also
Description of the bet. The description may contain HTML code.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Description { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


IsExternal Property

Bet..::.IsExternal Property
Bet Class See Also
Indicates whether the URL of best bet is an external server or not. External servers are servers that are not indexed by the search engine.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsExternal { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


Keywords Property

Bet..::.Keywords Property
Bet Class See Also
A list of strings, where each string contains either one or more keywords for this best bet.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<string> Keywords { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


Language Property

Bet..::.Language Property
Bet Class See Also
The language of the best bet.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Language Language { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


Title Property

Bet..::.Title Property
Bet Class See Also
Title of the best bet. Should be displayed as link text.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Title { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


Url Property

Bet..::.Url Property
Bet Class See Also
The complete URL, including protocol prefix, of the best bet.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Url { get; }

See Also

Bet Class
SiteSeeker.Model Namespace


Category Class

Category Class
Members See Also
This class represents a certain category of documents.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Category : SearchFilter

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchFilter
SiteSeeker.Model..::.Category

See Also

Category Members
SiteSeeker.Model Namespace


Category Members

[image]

SiteSeeker Search Module SDK (3.3)
Category Members
Category Class Constructors Fields Properties See Also

The Category type exposes the following members.

Constructors

Name | Description
Category | Constructs a new cateogory object.

Fields

Name | Description
Empty |

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)
Group | The group of which this category is a member.

See Also

Category Class
SiteSeeker.Model Namespace


Category Constructor

Category Constructor
Category Class See Also
Constructs a new cateogory object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Category(
    int id,
    string name,
    int nDocs,
    CategoryGroup group
)

Parameters

id
Type: System..::.Int32
The id of the category
name
Type: System..::.String
The name of the category
nDocs
Type: System..::.Int32
Number of documents that this category contains
group
Type: SiteSeeker.Model..::.CategoryGroup
The group of which this category is a member

See Also

Category Class
SiteSeeker.Model Namespace


Category Fields

[image]

SiteSeeker Search Module SDK (3.3)
Category Fields
Category Class See Also

The Category type exposes the following fields.

Fields

Name | Description
Empty |

See Also

Category Class
SiteSeeker.Model Namespace


Empty Field

Category..::.Empty Field
Category Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static Category Empty

See Also

Category Class
SiteSeeker.Model Namespace


Category Properties

[image]

SiteSeeker Search Module SDK (3.3)
Category Properties
Category Class See Also

The Category type exposes the following properties.

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)
Group | The group of which this category is a member.

See Also

Category Class
SiteSeeker.Model Namespace


AnyID Property

Category..::.AnyID Property
Category Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override int AnyID { get; }

See Also

Category Class
SiteSeeker.Model Namespace


Group Property

Category..::.Group Property
Category Class See Also
The group of which this category is a member.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public CategoryGroup Group { get; }

See Also

Category Class
SiteSeeker.Model Namespace


CategoryGroup Class

CategoryGroup Class
Members See Also
This class represents a certain group of document categories.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class CategoryGroup : SearchFilter

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchFilter
SiteSeeker.Model..::.CategoryGroup

See Also

CategoryGroup Members
SiteSeeker.Model Namespace


CategoryGroup Members

[image]

SiteSeeker Search Module SDK (3.3)
CategoryGroup Members
CategoryGroup Class Constructors Methods Fields Properties See Also

The CategoryGroup type exposes the following members.

Constructors

Name | Description
CategoryGroup | Overloaded.

Methods

Name | Description
AddCategory | Adds a category to the collection of categories in this group and adds the number of documents in the category to the NDocs property.

Fields

Name | Description
Empty |

Properties

Name | Description
Categories | The categories in this group.

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


CategoryGroup Constructor

[image]

SiteSeeker Search Module SDK (3.3)
CategoryGroup Constructor
CategoryGroup Class See Also

Overload List

Name | Description
CategoryGroup(Int32, String) | Constructs a new CategoryGroup object.
CategoryGroup(Int32, String, Int32) | Constructs a new CategoryGroup object.

See Also

CategoryGroup Class
CategoryGroup Members
SiteSeeker.Model Namespace


CategoryGroup Constructor (Int32, String)

CategoryGroup Constructor (Int32, String)
CategoryGroup Class See Also
Constructs a new CategoryGroup object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public CategoryGroup(
    int id,
    string name
)

Parameters

id
Type: System..::.Int32
The id of the group
name
Type: System..::.String
The name of the group

See Also

CategoryGroup Class
CategoryGroup Overload
SiteSeeker.Model Namespace


CategoryGroup Constructor (Int32, String, Int32)

CategoryGroup Constructor (Int32, String, Int32)
CategoryGroup Class See Also
Constructs a new CategoryGroup object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public CategoryGroup(
    int id,
    string name,
    int nDocs
)

Parameters

id
Type: System..::.Int32
The id of the group
name
Type: System..::.String
The name of the group
nDocs
Type: System..::.Int32
The number of documents contained in this groups categories

See Also

CategoryGroup Class
CategoryGroup Overload
SiteSeeker.Model Namespace


CategoryGroup Fields

[image]

SiteSeeker Search Module SDK (3.3)
CategoryGroup Fields
CategoryGroup Class See Also

The CategoryGroup type exposes the following fields.

Fields

Name | Description
Empty |

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


Empty Field

CategoryGroup..::.Empty Field
CategoryGroup Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static CategoryGroup Empty

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


CategoryGroup Methods

[image]

SiteSeeker Search Module SDK (3.3)
CategoryGroup Methods
CategoryGroup Class See Also

The CategoryGroup type exposes the following methods.

Methods

Name | Description
AddCategory | Adds a category to the collection of categories in this group and adds the number of documents in the category to the NDocs property.

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


AddCategory Method

CategoryGroup..::.AddCategory Method
CategoryGroup Class See Also
Adds a category to the collection of categories in this group and adds the number of documents in the category to the NDocs property.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void AddCategory(
    Category c
)

Parameters

c
Type: SiteSeeker.Model..::.Category
The category object

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


CategoryGroup Properties

[image]

SiteSeeker Search Module SDK (3.3)
CategoryGroup Properties
CategoryGroup Class See Also

The CategoryGroup type exposes the following properties.

Properties

Name | Description
Categories | The categories in this group.

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


Categories Property

CategoryGroup..::.Categories Property
CategoryGroup Class See Also
The categories in this group.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Category> Categories { get; }

See Also

CategoryGroup Class
SiteSeeker.Model Namespace


Click Class

Click Class
Members See Also
This class represents a user click to b

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Click

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.Click

See Also

Click Members
SiteSeeker.Model Namespace


Click Members

[image]

SiteSeeker Search Module SDK (3.3)
Click Members
Click Class Constructors Properties See Also

The Click type exposes the following members.

Constructors

Name | Description
Click | Constructs a new Click object.

Properties

Name | Description
Mode | Indicates type of click; ordinary hit, best bet or page load.
Position | Ordinal number in result list of clicked hits or best bet, starting with 1.
ResponseID | Identifier for current result.
Url | Target URL, the URL to which the user is directed.
UserID | User identifier, a hexadecimal session id, 32 characters. The session id for each user must be invariant, but may change between access occasions.

See Also

Click Class
SiteSeeker.Model Namespace


Click Constructor

Click Constructor
Click Class See Also
Constructs a new Click object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Click()

See Also

Click Class
SiteSeeker.Model Namespace


Click Properties

[image]

SiteSeeker Search Module SDK (3.3)
Click Properties
Click Class See Also

The Click type exposes the following properties.

Properties

Name | Description
Mode | Indicates type of click; ordinary hit, best bet or page load.
Position | Ordinal number in result list of clicked hits or best bet, starting with 1.
ResponseID | Identifier for current result.
Url | Target URL, the URL to which the user is directed.
UserID | User identifier, a hexadecimal session id, 32 characters. The session id for each user must be invariant, but may change between access occasions.

See Also

Click Class
SiteSeeker.Model Namespace


Mode Property

Click..::.Mode Property
Click Class See Also
Indicates type of click; ordinary hit, best bet or page load.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ClickMode Mode { get; set; }

See Also

Click Class
SiteSeeker.Model Namespace


Position Property

Click..::.Position Property
Click Class See Also
Ordinal number in result list of clicked hits or best bet, starting with 1.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int Position { get; set; }

See Also

Click Class
SiteSeeker.Model Namespace


ResponseID Property

Click..::.ResponseID Property
Click Class See Also
Identifier for current result.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int ResponseID { get; set; }

See Also

Click Class
SiteSeeker.Model Namespace


Url Property

Click..::.Url Property
Click Class See Also
Target URL, the URL to which the user is directed.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Url { get; set; }

See Also

Click Class
SiteSeeker.Model Namespace


UserID Property

Click..::.UserID Property
Click Class See Also
User identifier, a hexadecimal session id, 32 characters. The session id for each user must be invariant, but may change between access occasions.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string UserID { get; set; }

See Also

Click Class
SiteSeeker.Model Namespace


ClickMode Enumeration

ClickMode Enumeration
See Also
Describes the type of click.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public enum ClickMode

Members

Member name | Description
Hit | User clicked on a hit from the result list.
BestBet | User clicked on a best bet.
PageLoad | User loaded the search page.

See Also

SiteSeeker.Model Namespace


DateTimeInfo Class

DateTimeInfo Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class DateTimeInfo

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.DateTimeInfo

See Also

DateTimeInfo Members
SiteSeeker.Model Namespace


DateTimeInfo Members

[image]

SiteSeeker Search Module SDK (3.3)
DateTimeInfo Members
DateTimeInfo Class Constructors Properties See Also

The DateTimeInfo type exposes the following members.

Constructors

Name | Description
DateTimeInfo |

Properties

Name | Description
AllDocsHaveDates |
DateTimeRange |

See Also

DateTimeInfo Class
SiteSeeker.Model Namespace


DateTimeInfo Constructor

DateTimeInfo Constructor
DateTimeInfo Class See Also
Initializes a new instance of the DateTimeInfo class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTimeInfo(
    DateTime from,
    DateTime to,
    bool allDocsHaveDates
)

Parameters

from
Type: System..::.DateTime
to
Type: System..::.DateTime
allDocsHaveDates
Type: System..::.Boolean

See Also

DateTimeInfo Class
SiteSeeker.Model Namespace


DateTimeInfo Properties

[image]

SiteSeeker Search Module SDK (3.3)
DateTimeInfo Properties
DateTimeInfo Class See Also

The DateTimeInfo type exposes the following properties.

Properties

Name | Description
AllDocsHaveDates |
DateTimeRange |

See Also

DateTimeInfo Class
SiteSeeker.Model Namespace


AllDocsHaveDates Property

DateTimeInfo..::.AllDocsHaveDates Property
DateTimeInfo Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool AllDocsHaveDates { get; }

See Also

DateTimeInfo Class
SiteSeeker.Model Namespace


DateTimeRange Property

DateTimeInfo..::.DateTimeRange Property
DateTimeInfo Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTimeRange DateTimeRange { get; }

See Also

DateTimeInfo Class
SiteSeeker.Model Namespace


DateTimeRange Class

DateTimeRange Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class DateTimeRange

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.DateTimeRange

See Also

DateTimeRange Members
SiteSeeker.Model Namespace


DateTimeRange Members

[image]

SiteSeeker Search Module SDK (3.3)
DateTimeRange Members
DateTimeRange Class Constructors Fields Properties See Also

The DateTimeRange type exposes the following members.

Constructors

Name | Description
DateTimeRange |

Fields

Name | Description
Month |
Week |
Year |

Properties

Name | Description
From |
NDays |
To |

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


DateTimeRange Constructor

DateTimeRange Constructor
DateTimeRange Class See Also
Initializes a new instance of the DateTimeRange class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTimeRange(
    DateTime from,
    DateTime to
)

Parameters

from
Type: System..::.DateTime
to
Type: System..::.DateTime

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


DateTimeRange Fields

[image]

SiteSeeker Search Module SDK (3.3)
DateTimeRange Fields
DateTimeRange Class See Also

The DateTimeRange type exposes the following fields.

Fields

Name | Description
Month |
Week |
Year |

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


Month Field

DateTimeRange..::.Month Field
DateTimeRange Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const int Month

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


Week Field

DateTimeRange..::.Week Field
DateTimeRange Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const int Week

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


Year Field

DateTimeRange..::.Year Field
DateTimeRange Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const int Year

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


DateTimeRange Properties

[image]

SiteSeeker Search Module SDK (3.3)
DateTimeRange Properties
DateTimeRange Class See Also

The DateTimeRange type exposes the following properties.

Properties

Name | Description
From |
NDays |
To |

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


From Property

DateTimeRange..::.From Property
DateTimeRange Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTime From { get; }

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


NDays Property

DateTimeRange..::.NDays Property
DateTimeRange Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NDays { get; }

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


To Property

DateTimeRange..::.To Property
DateTimeRange Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTime To { get; }

See Also

DateTimeRange Class
SiteSeeker.Model Namespace


DefaultAccessController Class

DefaultAccessController Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class DefaultAccessController : IAccessController

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.DefaultAccessController

See Also

DefaultAccessController Members
SiteSeeker.Model Namespace


DefaultAccessController Members

[image]

SiteSeeker Search Module SDK (3.3)
DefaultAccessController Members
DefaultAccessController Class Constructors Methods See Also

The DefaultAccessController type exposes the following members.

Constructors

Name | Description
DefaultAccessController |

Methods

Name | Description
IsPageAccessible |

See Also

DefaultAccessController Class
SiteSeeker.Model Namespace


DefaultAccessController Constructor

DefaultAccessController Constructor
DefaultAccessController Class See Also
Initializes a new instance of the DefaultAccessController class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DefaultAccessController(
    bool acceptPages
)

Parameters

acceptPages
Type: System..::.Boolean

See Also

DefaultAccessController Class
SiteSeeker.Model Namespace


DefaultAccessController Methods

[image]

SiteSeeker Search Module SDK (3.3)
DefaultAccessController Methods
DefaultAccessController Class See Also

The DefaultAccessController type exposes the following methods.

Methods

Name | Description
IsPageAccessible |

See Also

DefaultAccessController Class
SiteSeeker.Model Namespace


IsPageAccessible Method

DefaultAccessController..::.IsPageAccessible Method
DefaultAccessController Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsPageAccessible(
    string url,
    string documentId
)

Parameters

url
Type: System..::.String
documentId
Type: System..::.String

Implements

IAccessController..::.IsPageAccessible(String, String)

See Also

DefaultAccessController Class
SiteSeeker.Model Namespace


FileFormat Class

FileFormat Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class FileFormat : SearchFilter

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchFilter
SiteSeeker.Model..::.FileFormat

See Also

FileFormat Members
SiteSeeker.Model Namespace


FileFormat Members

[image]

SiteSeeker Search Module SDK (3.3)
FileFormat Members
FileFormat Class Constructors Fields Properties See Also

The FileFormat type exposes the following members.

Constructors

Name | Description
FileFormat | Overloaded.

Fields

Name | Description
Empty |
ImageID |

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)
IsImage |

See Also

FileFormat Class
SiteSeeker.Model Namespace


FileFormat Constructor

[image]

SiteSeeker Search Module SDK (3.3)
FileFormat Constructor
FileFormat Class See Also

Overload List

Name | Description
FileFormat(FileFormat) |
FileFormat(Int32, String, String, Int32, Boolean) |

See Also

FileFormat Class
FileFormat Members
SiteSeeker.Model Namespace


FileFormat Constructor (FileFormat)

FileFormat Constructor (FileFormat)
FileFormat Class See Also
Initializes a new instance of the FileFormat class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormat(
    FileFormat fileFormat
)

Parameters

fileFormat
Type: SiteSeeker.Model..::.FileFormat

See Also

FileFormat Class
FileFormat Overload
SiteSeeker.Model Namespace


FileFormat Constructor (Int32, String, String, Int32, Boolean)

FileFormat Constructor (Int32, String, String, Int32, Boolean)
FileFormat Class See Also
Initializes a new instance of the FileFormat class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormat(
    int id,
    string key,
    string name,
    int nHits,
    bool isImage
)

Parameters

id
Type: System..::.Int32
key
Type: System..::.String
name
Type: System..::.String
nHits
Type: System..::.Int32
isImage
Type: System..::.Boolean

See Also

FileFormat Class
FileFormat Overload
SiteSeeker.Model Namespace


FileFormat Fields

[image]

SiteSeeker Search Module SDK (3.3)
FileFormat Fields
FileFormat Class See Also

The FileFormat type exposes the following fields.

Fields

Name | Description
Empty |
ImageID |

See Also

FileFormat Class
SiteSeeker.Model Namespace


Empty Field

FileFormat..::.Empty Field
FileFormat Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static FileFormat Empty

See Also

FileFormat Class
SiteSeeker.Model Namespace


ImageID Field

FileFormat..::.ImageID Field
FileFormat Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const int ImageID

See Also

FileFormat Class
SiteSeeker.Model Namespace


FileFormat Properties

[image]

SiteSeeker Search Module SDK (3.3)
FileFormat Properties
FileFormat Class See Also

The FileFormat type exposes the following properties.

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)
IsImage |

See Also

FileFormat Class
SiteSeeker.Model Namespace


AnyID Property

FileFormat..::.AnyID Property
FileFormat Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override int AnyID { get; }

See Also

FileFormat Class
SiteSeeker.Model Namespace


IsImage Property

FileFormat..::.IsImage Property
FileFormat Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsImage { get; set; }

See Also

FileFormat Class
SiteSeeker.Model Namespace


FileFormatCollection Class

FileFormatCollection Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class FileFormatCollection : SearchFilterCollection<FileFormat>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( FileFormat >)>)
SiteSeeker.Model..::.SearchFilterCollection <(Of <( FileFormat >)>)
SiteSeeker.Model..::.FileFormatCollection

See Also

FileFormatCollection Members
SiteSeeker.Model Namespace


FileFormatCollection Members

[image]

SiteSeeker Search Module SDK (3.3)
FileFormatCollection Members
FileFormatCollection Class Constructors Methods Properties See Also

The FileFormatCollection type exposes the following members.

Constructors

Name | Description
FileFormatCollection |

Methods

Name | Description
Add |
AddRange |
ContainsDocumentFormats |
ContainsImageFormats |

Properties

Name | Description
DocumentFormats |
ImageFormats |

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


FileFormatCollection Constructor

FileFormatCollection Constructor
FileFormatCollection Class See Also
Initializes a new instance of the FileFormatCollection class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormatCollection()

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


FileFormatCollection Methods

[image]

SiteSeeker Search Module SDK (3.3)
FileFormatCollection Methods
FileFormatCollection Class See Also

The FileFormatCollection type exposes the following methods.

Methods

Name | Description
Add |
AddRange |
ContainsDocumentFormats |
ContainsImageFormats |

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


Add Method

FileFormatCollection..::.Add Method
FileFormatCollection Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void Add(
    FileFormat f
)

Parameters

f
Type: SiteSeeker.Model..::.FileFormat

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


AddRange Method

FileFormatCollection..::.AddRange Method
FileFormatCollection Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void AddRange(
    IEnumerable<FileFormat> e
)

Parameters

e
Type: System.Collections.Generic..::.IEnumerable <(Of <( FileFormat >)>)

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


ContainsDocumentFormats Method

FileFormatCollection..::.ContainsDocumentFormats Method
FileFormatCollection Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ContainsDocumentFormats()

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


ContainsImageFormats Method

FileFormatCollection..::.ContainsImageFormats Method
FileFormatCollection Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ContainsImageFormats()

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


FileFormatCollection Properties

[image]

SiteSeeker Search Module SDK (3.3)
FileFormatCollection Properties
FileFormatCollection Class See Also

The FileFormatCollection type exposes the following properties.

Properties

Name | Description
DocumentFormats |
ImageFormats |

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


DocumentFormats Property

FileFormatCollection..::.DocumentFormats Property
FileFormatCollection Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<FileFormat> DocumentFormats { get; }

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


ImageFormats Property

FileFormatCollection..::.ImageFormats Property
FileFormatCollection Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<FileFormat> ImageFormats { get; }

See Also

FileFormatCollection Class
SiteSeeker.Model Namespace


Hit Class

Hit Class
Members See Also
A search hit, describing the document found.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Hit

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.Hit

See Also

Hit Members
SiteSeeker.Model Namespace


Hit Members

[image]

SiteSeeker Search Module SDK (3.3)
Hit Members
Hit Class Constructors Properties See Also

The Hit type exposes the following members.

Constructors

Name | Description
Hit |

Properties

Name | Description
Attachments | List of attachments for this hit.
AttachmentsTotalCount | Total number of attachments for this hit. Please note that the returned number of attachments (i.e. Hit.Attachments.Count) may be lower than the total number of attachments.
Categories | List of categories in which the hit is a member.
ContextLink | URL of the document containing the image (including protocol prefix). This property is only defined when the hit is an image.
CoverPage | A reference to the cover page if this hit is an attachment, null otherwise.
Description | Text extract from document containing query terms if present. Occurrences of query terms are marked with the HTML tag <strong>.
DocumentID | The identifier of the document. The id is used for access control of the hit.
FileFormat | The file format of the hit.
FileSize | The size in bytes of the document of the hit.
Groups | A list of category groups of which this hit is a member.
HitNumber | The ordinal number of the hit in the result, starting with 1.
InFrame | Indicates whether indexed document was found in a frame or not.
Language | The language of document of the hit.
MetaAttributes | A map of meta attributes contained in the document.
MetaDescription | The meta description of the document of the hit (or other meta data defined to be used as decription).
ModificationDate | The modification date of the document.
Rank | The rank of the hit. Value between 0 and 30, higher value corresponds to higher ranking.
SourceLink | URL of the document (including protocol prefix).
SpecialText | Special text extract from the document of the hit. Such extracts can be defined using certain HTML comments in the document. May contain HTML code.
Title | The title of the document of the hit. Occurrences of query terms are marked with the HTML tag <strong>.

See Also

Hit Class
SiteSeeker.Model Namespace


Hit Constructor

Hit Constructor
Hit Class See Also
Initializes a new instance of the Hit class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Hit()

See Also

Hit Class
SiteSeeker.Model Namespace


Hit Properties

[image]

SiteSeeker Search Module SDK (3.3)
Hit Properties
Hit Class See Also

The Hit type exposes the following properties.

Properties

Name | Description
Attachments | List of attachments for this hit.
AttachmentsTotalCount | Total number of attachments for this hit. Please note that the returned number of attachments (i.e. Hit.Attachments.Count) may be lower than the total number of attachments.
Categories | List of categories in which the hit is a member.
ContextLink | URL of the document containing the image (including protocol prefix). This property is only defined when the hit is an image.
CoverPage | A reference to the cover page if this hit is an attachment, null otherwise.
Description | Text extract from document containing query terms if present. Occurrences of query terms are marked with the HTML tag <strong>.
DocumentID | The identifier of the document. The id is used for access control of the hit.
FileFormat | The file format of the hit.
FileSize | The size in bytes of the document of the hit.
Groups | A list of category groups of which this hit is a member.
HitNumber | The ordinal number of the hit in the result, starting with 1.
InFrame | Indicates whether indexed document was found in a frame or not.
Language | The language of document of the hit.
MetaAttributes | A map of meta attributes contained in the document.
MetaDescription | The meta description of the document of the hit (or other meta data defined to be used as decription).
ModificationDate | The modification date of the document.
Rank | The rank of the hit. Value between 0 and 30, higher value corresponds to higher ranking.
SourceLink | URL of the document (including protocol prefix).
SpecialText | Special text extract from the document of the hit. Such extracts can be defined using certain HTML comments in the document. May contain HTML code.
Title | The title of the document of the hit. Occurrences of query terms are marked with the HTML tag <strong>.

See Also

Hit Class
SiteSeeker.Model Namespace


Attachments Property

Hit..::.Attachments Property
Hit Class See Also
List of attachments for this hit.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<Hit> Attachments { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


AttachmentsTotalCount Property

Hit..::.AttachmentsTotalCount Property
Hit Class See Also
Total number of attachments for this hit. Please note that the returned number of attachments (i.e. Hit.Attachments.Count) may be lower than the total number of attachments.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int AttachmentsTotalCount { get; set; }

Remarks

Value cannot be negative.

See Also

Hit Class
SiteSeeker.Model Namespace


Categories Property

Hit..::.Categories Property
Hit Class See Also
List of categories in which the hit is a member.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Category> Categories { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


ContextLink Property

Hit..::.ContextLink Property
Hit Class See Also
URL of the document containing the image (including protocol prefix). This property is only defined when the hit is an image.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string ContextLink { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


CoverPage Property

Hit..::.CoverPage Property
Hit Class See Also
A reference to the cover page if this hit is an attachment, null otherwise.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Hit CoverPage { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


Description Property

Hit..::.Description Property
Hit Class See Also
Text extract from document containing query terms if present. Occurrences of query terms are marked with the HTML tag <strong>.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Description { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


DocumentID Property

Hit..::.DocumentID Property
Hit Class See Also
The identifier of the document. The id is used for access control of the hit.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string DocumentID { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


FileFormat Property

Hit..::.FileFormat Property
Hit Class See Also
The file format of the hit.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormat FileFormat { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


FileSize Property

Hit..::.FileSize Property
Hit Class See Also
The size in bytes of the document of the hit.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int FileSize { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


Groups Property

Hit..::.Groups Property
Hit Class See Also
A list of category groups of which this hit is a member.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<CategoryGroup> Groups { get; }

See Also

Hit Class
SiteSeeker.Model Namespace


HitNumber Property

Hit..::.HitNumber Property
Hit Class See Also
The ordinal number of the hit in the result, starting with 1.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int HitNumber { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


InFrame Property

Hit..::.InFrame Property
Hit Class See Also
Indicates whether indexed document was found in a frame or not.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool InFrame { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


Language Property

Hit..::.Language Property
Hit Class See Also
The language of document of the hit.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Language Language { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


MetaAttributes Property

Hit..::.MetaAttributes Property
Hit Class See Also
A map of meta attributes contained in the document.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public MetaAttributes MetaAttributes { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


MetaDescription Property

Hit..::.MetaDescription Property
Hit Class See Also
The meta description of the document of the hit (or other meta data defined to be used as decription).

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string MetaDescription { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


ModificationDate Property

Hit..::.ModificationDate Property
Hit Class See Also
The modification date of the document.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTime ModificationDate { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


Rank Property

Hit..::.Rank Property
Hit Class See Also
The rank of the hit. Value between 0 and 30, higher value corresponds to higher ranking.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int Rank { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


SourceLink Property

Hit..::.SourceLink Property
Hit Class See Also
URL of the document (including protocol prefix).

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SourceLink { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


SpecialText Property

Hit..::.SpecialText Property
Hit Class See Also
Special text extract from the document of the hit. Such extracts can be defined using certain HTML comments in the document. May contain HTML code.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SpecialText { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


Title Property

Hit..::.Title Property
Hit Class See Also
The title of the document of the hit. Occurrences of query terms are marked with the HTML tag <strong>.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Title { get; set; }

See Also

Hit Class
SiteSeeker.Model Namespace


IAccessController Interface

IAccessController Interface
Members See Also
An instance of this interface is responsible for controlling the access to pages. SearchEngineFacade uses this interface to determine which pages (hits) to remove from the list of retreived hits.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public interface IAccessController

See Also

IAccessController Members
SiteSeeker.Model Namespace


IAccessController Members

[image]

SiteSeeker Search Module SDK (3.3)
IAccessController Members
IAccessController Interface Methods See Also

The IAccessController type exposes the following members.

Methods

Name | Description
IsPageAccessible | Determines whether a page with the specified URL and document id is accessible or not.

See Also

IAccessController Interface
SiteSeeker.Model Namespace


IAccessController Methods

[image]

SiteSeeker Search Module SDK (3.3)
IAccessController Methods
IAccessController Interface See Also

The IAccessController type exposes the following methods.

Methods

Name | Description
IsPageAccessible | Determines whether a page with the specified URL and document id is accessible or not.

See Also

IAccessController Interface
SiteSeeker.Model Namespace


IsPageAccessible Method

IAccessController..::.IsPageAccessible Method
IAccessController Interface See Also
Determines whether a page with the specified URL and document id is accessible or not.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
bool IsPageAccessible(
    string url,
    string documentId
)

Parameters

url
Type: System..::.String
The url to the page
documentId
Type: System..::.String
The unique identifier of the page

Return Value

True if the page is accessible, false otherwise.

See Also

IAccessController Interface
SiteSeeker.Model Namespace


Language Class

Language Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Language : SearchFilter

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchFilter
SiteSeeker.Model..::.Language

See Also

Language Members
SiteSeeker.Model Namespace


Language Members

[image]

SiteSeeker Search Module SDK (3.3)
Language Members
Language Class Constructors Fields Properties See Also

The Language type exposes the following members.

Constructors

Name | Description
Language | Overloaded.

Fields

Name | Description
Empty |

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)

See Also

Language Class
SiteSeeker.Model Namespace


Language Constructor

[image]

SiteSeeker Search Module SDK (3.3)
Language Constructor
Language Class See Also

Overload List

Name | Description
Language()()() |
Language(Language) |
Language(Int32, String, String, Int32) |

See Also

Language Class
Language Members
SiteSeeker.Model Namespace


Language Constructor

Language Constructor
Language Class See Also
Initializes a new instance of the Language class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Language()

See Also

Language Class
Language Overload
SiteSeeker.Model Namespace


Language Constructor (Language)

Language Constructor (Language)
Language Class See Also
Initializes a new instance of the Language class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Language(
    Language language
)

Parameters

language
Type: SiteSeeker.Model..::.Language

See Also

Language Class
Language Overload
SiteSeeker.Model Namespace


Language Constructor (Int32, String, String, Int32)

Language Constructor (Int32, String, String, Int32)
Language Class See Also
Initializes a new instance of the Language class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Language(
    int id,
    string key,
    string name,
    int nDocs
)

Parameters

id
Type: System..::.Int32
key
Type: System..::.String
name
Type: System..::.String
nDocs
Type: System..::.Int32

See Also

Language Class
Language Overload
SiteSeeker.Model Namespace


Language Fields

[image]

SiteSeeker Search Module SDK (3.3)
Language Fields
Language Class See Also

The Language type exposes the following fields.

Fields

Name | Description
Empty |

See Also

Language Class
SiteSeeker.Model Namespace


Empty Field

Language..::.Empty Field
Language Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static Language Empty

See Also

Language Class
SiteSeeker.Model Namespace


Language Properties

[image]

SiteSeeker Search Module SDK (3.3)
Language Properties
Language Class See Also

The Language type exposes the following properties.

Properties

Name | Description
AnyID | (Overrides SearchFilter ..::. AnyID.)

See Also

Language Class
SiteSeeker.Model Namespace


AnyID Property

Language..::.AnyID Property
Language Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override int AnyID { get; }

See Also

Language Class
SiteSeeker.Model Namespace


MetaAttributes Class

MetaAttributes Class
Members See Also
A class that represents a set of meta attributes related to a particular document.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class MetaAttributes : Dictionary<string, string>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)
SiteSeeker.Model..::.MetaAttributes

See Also

MetaAttributes Members
SiteSeeker.Model Namespace


MetaAttributes Members

[image]

SiteSeeker Search Module SDK (3.3)
MetaAttributes Members
MetaAttributes Class Constructors Methods See Also

The MetaAttributes type exposes the following members.

Constructors

Name | Description
MetaAttributes |

Methods

Name | Description
GetDateTimeValue | Returns the DateTime value of the specified meta attribute.
GetFloatValue | Returns the float value of the specified meta attribute.
GetIntegerValue | Returns the integer value of the specified meta attribute.
GetStringValue | Returns the string value of the specified meta attribute.
IsDateTimeValue | Indicates whether the value of the specified meta attribute is a DateTime object.
IsFloatValue | Indicates whether the value of the specified meta attribute is a float.
IsIntegerValue | Indicates whether the value of the specified meta attribute is an integer.
IsStringValue | Indicates whether the value of the specified meta attribute is a string.

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


MetaAttributes Constructor

MetaAttributes Constructor
MetaAttributes Class See Also
Initializes a new instance of the MetaAttributes class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public MetaAttributes()

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


MetaAttributes Methods

[image]

SiteSeeker Search Module SDK (3.3)
MetaAttributes Methods
MetaAttributes Class See Also

The MetaAttributes type exposes the following methods.

Methods

Name | Description
GetDateTimeValue | Returns the DateTime value of the specified meta attribute.
GetFloatValue | Returns the float value of the specified meta attribute.
GetIntegerValue | Returns the integer value of the specified meta attribute.
GetStringValue | Returns the string value of the specified meta attribute.
IsDateTimeValue | Indicates whether the value of the specified meta attribute is a DateTime object.
IsFloatValue | Indicates whether the value of the specified meta attribute is a float.
IsIntegerValue | Indicates whether the value of the specified meta attribute is an integer.
IsStringValue | Indicates whether the value of the specified meta attribute is a string.

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


GetDateTimeValue Method

MetaAttributes..::.GetDateTimeValue Method
MetaAttributes Class See Also
Returns the DateTime value of the specified meta attribute.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTime GetDateTimeValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


GetFloatValue Method

MetaAttributes..::.GetFloatValue Method
MetaAttributes Class See Also
Returns the float value of the specified meta attribute.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public float GetFloatValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


GetIntegerValue Method

MetaAttributes..::.GetIntegerValue Method
MetaAttributes Class See Also
Returns the integer value of the specified meta attribute.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int GetIntegerValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


GetStringValue Method

MetaAttributes..::.GetStringValue Method
MetaAttributes Class See Also
Returns the string value of the specified meta attribute.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string GetStringValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


IsDateTimeValue Method

MetaAttributes..::.IsDateTimeValue Method
MetaAttributes Class See Also
Indicates whether the value of the specified meta attribute is a DateTime object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsDateTimeValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


IsFloatValue Method

MetaAttributes..::.IsFloatValue Method
MetaAttributes Class See Also
Indicates whether the value of the specified meta attribute is a float.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsFloatValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


IsIntegerValue Method

MetaAttributes..::.IsIntegerValue Method
MetaAttributes Class See Also
Indicates whether the value of the specified meta attribute is an integer.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsIntegerValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


IsStringValue Method

MetaAttributes..::.IsStringValue Method
MetaAttributes Class See Also
Indicates whether the value of the specified meta attribute is a string.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsStringValue(
    string key
)

Parameters

key
Type: System..::.String
The name of the meta attribute

See Also

MetaAttributes Class
SiteSeeker.Model Namespace


QueryCompletionResponse Class

QueryCompletionResponse Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class QueryCompletionResponse

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.QueryCompletionResponse

See Also

QueryCompletionResponse Members
SiteSeeker.Model Namespace


QueryCompletionResponse Members

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletionResponse Members
QueryCompletionResponse Class Properties See Also

The QueryCompletionResponse type exposes the following members.

Properties

Name | Description
JsonResponse |

See Also

QueryCompletionResponse Class
SiteSeeker.Model Namespace


QueryCompletionResponse Properties

[image]

SiteSeeker Search Module SDK (3.3)
QueryCompletionResponse Properties
QueryCompletionResponse Class See Also

The QueryCompletionResponse type exposes the following properties.

Properties

Name | Description
JsonResponse |

See Also

QueryCompletionResponse Class
SiteSeeker.Model Namespace


JsonResponse Property

QueryCompletionResponse..::.JsonResponse Property
QueryCompletionResponse Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string JsonResponse { get; }

See Also

QueryCompletionResponse Class
SiteSeeker.Model Namespace


QueryRefinement Class

QueryRefinement Class
Members See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class QueryRefinement

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.QueryRefinement

See Also

QueryRefinement Members
SiteSeeker.Model Namespace


QueryRefinement Members

[image]

SiteSeeker Search Module SDK (3.3)
QueryRefinement Members
QueryRefinement Class Constructors Properties See Also

The QueryRefinement type exposes the following members.

Constructors

Name | Description
QueryRefinement |

Properties

Name | Description
NewTerms |
Query |

See Also

QueryRefinement Class
SiteSeeker.Model Namespace


QueryRefinement Constructor

QueryRefinement Constructor
QueryRefinement Class See Also
Initializes a new instance of the QueryRefinement class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public QueryRefinement(
    string query,
    string newTerms
)

Parameters

query
Type: System..::.String
newTerms
Type: System..::.String

See Also

QueryRefinement Class
SiteSeeker.Model Namespace


QueryRefinement Properties

[image]

SiteSeeker Search Module SDK (3.3)
QueryRefinement Properties
QueryRefinement Class See Also

The QueryRefinement type exposes the following properties.

Properties

Name | Description
NewTerms |
Query |

See Also

QueryRefinement Class
SiteSeeker.Model Namespace


NewTerms Property

QueryRefinement..::.NewTerms Property
QueryRefinement Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string NewTerms { get; set; }

See Also

QueryRefinement Class
SiteSeeker.Model Namespace


Query Property

QueryRefinement..::.Query Property
QueryRefinement Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Query { get; set; }

See Also

QueryRefinement Class
SiteSeeker.Model Namespace


SearchContext Class

SearchContext Class
Members See Also
The search context holds information about the current index.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchContext

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchContext

See Also

SearchContext Members
SiteSeeker.Model Namespace


SearchContext Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchContext Members
SearchContext Class Constructors Properties See Also

The SearchContext type exposes the following members.

Constructors

Name | Description
SearchContext |

Properties

Name | Description
Ages | A list of available ages in the current index. The nDocs property of each age denotes the total number of documents per age.
Categories | A list of available categories in the current index. The nDocs property of each category denotes the total number of documents within each category.
DateTimeInfo |
FileFormats | A list of available file formats in the current index. The nDocs property of each file format denotes the total number of documents per file format.
Groups | A list of category groups in the current index. The nDocs property of each category group denotes the total number of documents within each group. Note, nDocs is only valid if the categories in the group do not overlap.
IndexName | A logical name of the current index, e.g., "Entire web site".
Languages | A list of available languages in the current index. The nDocs property of each language denotes the total number of documents in each language.
Timestamp | A timestamp of the fetched SearchContext. SearchEngineFacade uses this timestamp to determine if the SearchCOntext has expired while retrieving search responses from the search engine.

See Also

SearchContext Class
SiteSeeker.Model Namespace


SearchContext Constructor

SearchContext Constructor
SearchContext Class See Also
Initializes a new instance of the SearchContext class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchContext()

See Also

SearchContext Class
SiteSeeker.Model Namespace


SearchContext Properties

[image]

SiteSeeker Search Module SDK (3.3)
SearchContext Properties
SearchContext Class See Also

The SearchContext type exposes the following properties.

Properties

Name | Description
Ages | A list of available ages in the current index. The nDocs property of each age denotes the total number of documents per age.
Categories | A list of available categories in the current index. The nDocs property of each category denotes the total number of documents within each category.
DateTimeInfo |
FileFormats | A list of available file formats in the current index. The nDocs property of each file format denotes the total number of documents per file format.
Groups | A list of category groups in the current index. The nDocs property of each category group denotes the total number of documents within each group. Note, nDocs is only valid if the categories in the group do not overlap.
IndexName | A logical name of the current index, e.g., "Entire web site".
Languages | A list of available languages in the current index. The nDocs property of each language denotes the total number of documents in each language.
Timestamp | A timestamp of the fetched SearchContext. SearchEngineFacade uses this timestamp to determine if the SearchCOntext has expired while retrieving search responses from the search engine.

See Also

SearchContext Class
SiteSeeker.Model Namespace


Ages Property

SearchContext..::.Ages Property
SearchContext Class See Also
A list of available ages in the current index. The nDocs property of each age denotes the total number of documents per age.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Age> Ages { get; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


Categories Property

SearchContext..::.Categories Property
SearchContext Class See Also
A list of available categories in the current index. The nDocs property of each category denotes the total number of documents within each category.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Category> Categories { get; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


DateTimeInfo Property

SearchContext..::.DateTimeInfo Property
SearchContext Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTimeInfo DateTimeInfo { get; set; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


FileFormats Property

SearchContext..::.FileFormats Property
SearchContext Class See Also
A list of available file formats in the current index. The nDocs property of each file format denotes the total number of documents per file format.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormatCollection FileFormats { get; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


Groups Property

SearchContext..::.Groups Property
SearchContext Class See Also
A list of category groups in the current index. The nDocs property of each category group denotes the total number of documents within each group. Note, nDocs is only valid if the categories in the group do not overlap.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<CategoryGroup> Groups { get; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


IndexName Property

SearchContext..::.IndexName Property
SearchContext Class See Also
A logical name of the current index, e.g., "Entire web site".

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string IndexName { get; set; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


Languages Property

SearchContext..::.Languages Property
SearchContext Class See Also
A list of available languages in the current index. The nDocs property of each language denotes the total number of documents in each language.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Language> Languages { get; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


Timestamp Property

SearchContext..::.Timestamp Property
SearchContext Class See Also
A timestamp of the fetched SearchContext. SearchEngineFacade uses this timestamp to determine if the SearchCOntext has expired while retrieving search responses from the search engine.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTime Timestamp { get; set; }

See Also

SearchContext Class
SiteSeeker.Model Namespace


SearchContextExpiredException Class

SearchContextExpiredException Class
Members See Also
This exception is thrown if the search context has expired, i.e. is older than the modification time of the index that is beeing used while handling search queries.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchContextExpiredException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
SiteSeeker.Model..::.SearchContextExpiredException

See Also

SearchContextExpiredException Members
SiteSeeker.Model Namespace


SearchContextExpiredException Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchContextExpiredException Members
SearchContextExpiredException Class Constructors See Also

The SearchContextExpiredException type exposes the following members.

Constructors

Name | Description
SearchContextExpiredException |

See Also

SearchContextExpiredException Class
SiteSeeker.Model Namespace


SearchContextExpiredException Constructor

SearchContextExpiredException Constructor
SearchContextExpiredException Class See Also
Initializes a new instance of the SearchContextExpiredException class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchContextExpiredException()

See Also

SearchContextExpiredException Class
SiteSeeker.Model Namespace


SearchEngineFacade Class

SearchEngineFacade Class
Members See Also
This class encapsulates all communication with the search engine using the SiteSeeker Web Service API.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchEngineFacade

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchEngineFacade

See Also

SearchEngineFacade Members
SiteSeeker.Model Namespace


SearchEngineFacade Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchEngineFacade Members
SearchEngineFacade Class Constructors Methods See Also

The SearchEngineFacade type exposes the following members.

Constructors

Name | Description
SearchEngineFacade | Overloaded.

Methods

Name | Description
GetQueryCompletionResponse |
GetSearchContext | Retrieves the search context parameters from the search engine. The search context is comprised of static data for the current search index, e.g. all the available file formats and languages. I.e., the data in the search context is not dependent on a particular search. And hence, this object can preferably be cached and shared by many client requests in order to avoid superflous calls to the search engine. Note that GetSearchContext does not store results in this object, so SetSearchContext must be called to set the search context. If SetSearchContext is not called explictly, caching will be disabled and a new search context will be created on each request.
GetSearchResponse | Performs a search and returns the fetched result. All search settings are given in the SearchRequest object.
Notify | Overloaded.
RegisterClick | Registers a user click on a hit or on a best bet. Registered clicks are used for click tracking and search statistics.
SetSearchContext | Sets the SearchContext object to be used by this facade. The SearchContext object passed to this method is typically a cached copy of the context. The interface language of the context must match the facades current interface language in order to return correct SearchResponse objects.

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


SearchEngineFacade Constructor

[image]

SiteSeeker Search Module SDK (3.3)
SearchEngineFacade Constructor
SearchEngineFacade Class See Also

Overload List

Name | Description
SearchEngineFacade(SiteSeeker, String) | Constructs a new instance of a SearchEngineFacade using a particular interface language. Will not return any hits for this server if access control is enabled.
SearchEngineFacade(SiteSeeker, String, IAccessController) | Constructs a new instance of a SearchEngineFacade with the specified interface language.

See Also

SearchEngineFacade Class
SearchEngineFacade Members
SiteSeeker.Model Namespace


SearchEngineFacade Constructor (, String)

SearchEngineFacade Constructor (, String)
SearchEngineFacade Class See Also
Constructs a new instance of a SearchEngineFacade using a particular interface language. Will not return any hits for this server if access control is enabled.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchEngineFacade(
    SiteSeeker seeker,
    string interfaceLanguage
)

Parameters

seeker
Type: SiteSeeker
The web service object to use for communicating with the search engine.
interfaceLanguage
Type: System..::.String
Specifies user interface language for messages from search engine displayable for user. Valid values ere ISO language codes (such as the strings sv and en for Swedish and English, respectively). Default value is sv (Swedish). Fallback language is English. Specified interface language may affect ranking of hits (typically higher rank for hits in matching language or related language).

See Also

SearchEngineFacade Class
SearchEngineFacade Overload
SiteSeeker.Model Namespace


SearchEngineFacade Constructor (, String, IAccessController)

SearchEngineFacade Constructor (, String, IAccessController)
SearchEngineFacade Class See Also
Constructs a new instance of a SearchEngineFacade with the specified interface language.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchEngineFacade(
    SiteSeeker seeker,
    string interfaceLanguage,
    IAccessController accessController
)

Parameters

seeker
Type: SiteSeeker
The web service object to use for communicating with the search engine.
interfaceLanguage
Type: System..::.String
Specifies user interface language for messages from search engine displayable for user. Valid values ere ISO language codes (such as the strings sv and en for Swedish and English, respectively). Default value is sv (Swedish). Fallback language is English. Specified interface language may affect ranking of hits (typically higher rank for hits in matching language or related language).
accessController
Type: SiteSeeker.Model..::.IAccessController
The access controller which determines which pages that are accessible or not.

See Also

SearchEngineFacade Class
SearchEngineFacade Overload
SiteSeeker.Model Namespace


SearchEngineFacade Methods

[image]

SiteSeeker Search Module SDK (3.3)
SearchEngineFacade Methods
SearchEngineFacade Class See Also

The SearchEngineFacade type exposes the following methods.

Methods

Name | Description
GetQueryCompletionResponse |
GetSearchContext | Retrieves the search context parameters from the search engine. The search context is comprised of static data for the current search index, e.g. all the available file formats and languages. I.e., the data in the search context is not dependent on a particular search. And hence, this object can preferably be cached and shared by many client requests in order to avoid superflous calls to the search engine. Note that GetSearchContext does not store results in this object, so SetSearchContext must be called to set the search context. If SetSearchContext is not called explictly, caching will be disabled and a new search context will be created on each request.
GetSearchResponse | Performs a search and returns the fetched result. All search settings are given in the SearchRequest object.
Notify | Overloaded.
RegisterClick | Registers a user click on a hit or on a best bet. Registered clicks are used for click tracking and search statistics.
SetSearchContext | Sets the SearchContext object to be used by this facade. The SearchContext object passed to this method is typically a cached copy of the context. The interface language of the context must match the facades current interface language in order to return correct SearchResponse objects.

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


GetQueryCompletionResponse Method

SearchEngineFacade..::.GetQueryCompletionResponse Method
SearchEngineFacade Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public QueryCompletionResponse GetQueryCompletionResponse(
    string query
)

Parameters

query
Type: System..::.String

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


GetSearchContext Method

SearchEngineFacade..::.GetSearchContext Method
SearchEngineFacade Class See Also
Retrieves the search context parameters from the search engine. The search context is comprised of static data for the current search index, e.g. all the available file formats and languages. I.e., the data in the search context is not dependent on a particular search. And hence, this object can preferably be cached and shared by many client requests in order to avoid superflous calls to the search engine. Note that GetSearchContext does not store results in this object, so SetSearchContext must be called to set the search context. If SetSearchContext is not called explictly, caching will be disabled and a new search context will be created on each request.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchContext GetSearchContext()

Return Value

The search context represented by the SearchContext object

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


GetSearchResponse Method

SearchEngineFacade..::.GetSearchResponse Method
SearchEngineFacade Class See Also
Performs a search and returns the fetched result. All search settings are given in the SearchRequest object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchResponse GetSearchResponse(
    SearchRequest request
)

Parameters

request
Type: SiteSeeker.Model..::.SearchRequest
The search settings including the search query

Return Value

The search result represented by the SearchResponse object

Exceptions

Exception | Condition
SiteSeeker.Model..::.SearchContextExpiredException | If the SearchContext.Timestamp is greater than the modification timestamp of the index.

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


Notify Method

[image]

SiteSeeker Search Module SDK (3.3)
SearchEngineFacade..::.Notify Method
SearchEngineFacade Class See Also

Overload List

Name | Description
Notify(List<(Of <(String>)>)) | Notifies the search engine about updated or added URL:s.
Notify(String) | Notifies the search engine about an updated or added URL.

See Also

SearchEngineFacade Class
SearchEngineFacade Members
SiteSeeker.Model Namespace


Notify Method (List(String))

SearchEngineFacade..::.Notify Method (List<(Of <(String>)>))
SearchEngineFacade Class See Also
Notifies the search engine about updated or added URL:s.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool Notify(
    List<string> urls
)

Parameters

urls
Type: System.Collections.Generic..::.List <(Of <( String >)>)
A list of URL:s

Return Value

True or false for success or failure.

See Also

SearchEngineFacade Class
Notify Overload
SiteSeeker.Model Namespace


Notify Method (String)

SearchEngineFacade..::.Notify Method (String)
SearchEngineFacade Class See Also
Notifies the search engine about an updated or added URL.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool Notify(
    string url
)

Parameters

url
Type: System..::.String
A string containing an URL.

Return Value

True or false for success or failure.

See Also

SearchEngineFacade Class
Notify Overload
SiteSeeker.Model Namespace


RegisterClick Method

SearchEngineFacade..::.RegisterClick Method
SearchEngineFacade Class See Also
Registers a user click on a hit or on a best bet. Registered clicks are used for click tracking and search statistics.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void RegisterClick(
    Click c
)

Parameters

c
Type: SiteSeeker.Model..::.Click
Contains the information about the click to be registered.

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


SetSearchContext Method

SearchEngineFacade..::.SetSearchContext Method
SearchEngineFacade Class See Also
Sets the SearchContext object to be used by this facade. The SearchContext object passed to this method is typically a cached copy of the context. The interface language of the context must match the facades current interface language in order to return correct SearchResponse objects.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void SetSearchContext(
    SearchContext context
)

Parameters

context
Type: SiteSeeker.Model..::.SearchContext

See Also

SearchEngineFacade Class
SiteSeeker.Model Namespace


SearchFilter Class

SearchFilter Class
Members See Also
Base class for all entities that can be used for filtering a search result.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchFilter

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchFilter
SiteSeeker.Model..::.Language
SiteSeeker.Model..::.Category
SiteSeeker.Model..::.FileFormat
SiteSeeker.Model..::.Age
SiteSeeker.Model..::.CategoryGroup

See Also

SearchFilter Members
SiteSeeker.Model Namespace


SearchFilter Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilter Members
SearchFilter Class Constructors Methods Fields Properties See Also

The SearchFilter type exposes the following members.

Constructors

Name | Description
SearchFilter | Overloaded.

Methods

Name | Description
Equals | Compares the id value of the search filters. (Overrides Object ..::. Equals(Object).)
GetHashCode | Returns the hash code of this object. (Overrides Object ..::. GetHashCode()()().)

Fields

Name | Description
Empty |
id |
key |
name |
nDocs |

Properties

Name | Description
AnyID |
ID | The id of this SearchFilter
IsAny |
Key | A normalized name for this search filter.
Name | The name of this SearchFilter
NDocs | The number of documents that this search filter contains in its current context (SearchResponse or SearchContext). I.e., if this SearchFilter is in the context of a SearchResponse, it indicates the number of hits/documents that matches this filter for a particular query. If this filter is in the context of a SearchContext, it indicates the number documents that match this filter in the entire index.

See Also

SearchFilter Class
SiteSeeker.Model Namespace


SearchFilter Constructor

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilter Constructor
SearchFilter Class See Also

Overload List

Name | Description
SearchFilter()()() | Constructs a new SearchFilter. Must have a public parameterless constructor in order to use it as parameter 'T' in a generic type or method (i.e. SearchFilterCollection>T<)
SearchFilter(Int32, String, Int32) | Constructs a new SearchFilter.
SearchFilter(Int32, String, String, Int32) | Constructs a new SearchFilter.

See Also

SearchFilter Class
SearchFilter Members
SiteSeeker.Model Namespace


SearchFilter Constructor

SearchFilter Constructor
SearchFilter Class See Also
Constructs a new SearchFilter. Must have a public parameterless constructor in order to use it as parameter 'T' in a generic type or method (i.e. SearchFilterCollection>T<)

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilter()

See Also

SearchFilter Class
SearchFilter Overload
SiteSeeker.Model Namespace


SearchFilter Constructor (Int32, String, Int32)

SearchFilter Constructor (Int32, String, Int32)
SearchFilter Class See Also
Constructs a new SearchFilter.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilter(
    int id,
    string name,
    int nDocs
)

Parameters

id
Type: System..::.Int32
The id of the search filter
name
Type: System..::.String
The search filter value
nDocs
Type: System..::.Int32
The number of documents that this search filter contains in its current context (SearchResponse or SearchContext)

See Also

SearchFilter Class
SearchFilter Overload
SiteSeeker.Model Namespace


SearchFilter Constructor (Int32, String, String, Int32)

SearchFilter Constructor (Int32, String, String, Int32)
SearchFilter Class See Also
Constructs a new SearchFilter.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilter(
    int id,
    string key,
    string name,
    int nDocs
)

Parameters

id
Type: System..::.Int32
The id of the search filter
key
Type: System..::.String
A symbolic name of the search filter value
name
Type: System..::.String
The search filter value
nDocs
Type: System..::.Int32
The number of documents that this search filter contains in its current context (SearchResponse or SearchContext)

See Also

SearchFilter Class
SearchFilter Overload
SiteSeeker.Model Namespace


SearchFilter Fields

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilter Fields
SearchFilter Class See Also

The SearchFilter type exposes the following fields.

Fields

Name | Description
Empty |
id |
key |
name |
nDocs |

See Also

SearchFilter Class
SiteSeeker.Model Namespace


Empty Field

SearchFilter..::.Empty Field
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static SearchFilter Empty

See Also

SearchFilter Class
SiteSeeker.Model Namespace


id Field

SearchFilter..::.id Field
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected int id

See Also

SearchFilter Class
SiteSeeker.Model Namespace


key Field

SearchFilter..::.key Field
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string key

See Also

SearchFilter Class
SiteSeeker.Model Namespace


name Field

SearchFilter..::.name Field
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected string name

See Also

SearchFilter Class
SiteSeeker.Model Namespace


nDocs Field

SearchFilter..::.nDocs Field
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
protected int nDocs

See Also

SearchFilter Class
SiteSeeker.Model Namespace


SearchFilter Methods

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilter Methods
SearchFilter Class See Also

The SearchFilter type exposes the following methods.

Methods

Name | Description
Equals | Compares the id value of the search filters. (Overrides Object ..::. Equals(Object).)
GetHashCode | Returns the hash code of this object. (Overrides Object ..::. GetHashCode()()().)

See Also

SearchFilter Class
SiteSeeker.Model Namespace


Equals Method

SearchFilter..::.Equals Method
SearchFilter Class See Also
Compares the id value of the search filters.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

See Also

SearchFilter Class
SiteSeeker.Model Namespace


GetHashCode Method

SearchFilter..::.GetHashCode Method
SearchFilter Class See Also
Returns the hash code of this object.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override int GetHashCode()

See Also

SearchFilter Class
SiteSeeker.Model Namespace


SearchFilter Properties

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilter Properties
SearchFilter Class See Also

The SearchFilter type exposes the following properties.

Properties

Name | Description
AnyID |
ID | The id of this SearchFilter
IsAny |
Key | A normalized name for this search filter.
Name | The name of this SearchFilter
NDocs | The number of documents that this search filter contains in its current context (SearchResponse or SearchContext). I.e., if this SearchFilter is in the context of a SearchResponse, it indicates the number of hits/documents that matches this filter for a particular query. If this filter is in the context of a SearchContext, it indicates the number documents that match this filter in the entire index.

See Also

SearchFilter Class
SiteSeeker.Model Namespace


AnyID Property

SearchFilter..::.AnyID Property
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public virtual int AnyID { get; }

See Also

SearchFilter Class
SiteSeeker.Model Namespace


ID Property

SearchFilter..::.ID Property
SearchFilter Class See Also
The id of this SearchFilter

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int ID { get; set; }

See Also

SearchFilter Class
SiteSeeker.Model Namespace


IsAny Property

SearchFilter..::.IsAny Property
SearchFilter Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsAny { get; }

See Also

SearchFilter Class
SiteSeeker.Model Namespace


Key Property

SearchFilter..::.Key Property
SearchFilter Class See Also
A normalized name for this search filter.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Key { get; set; }

See Also

SearchFilter Class
SiteSeeker.Model Namespace


Name Property

SearchFilter..::.Name Property
SearchFilter Class See Also
The name of this SearchFilter

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Name { get; set; }

See Also

SearchFilter Class
SiteSeeker.Model Namespace


NDocs Property

SearchFilter..::.NDocs Property
SearchFilter Class See Also
The number of documents that this search filter contains in its current context (SearchResponse or SearchContext). I.e., if this SearchFilter is in the context of a SearchResponse, it indicates the number of hits/documents that matches this filter for a particular query. If this filter is in the context of a SearchContext, it indicates the number documents that match this filter in the entire index.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NDocs { get; set; }

See Also

SearchFilter Class
SiteSeeker.Model Namespace


SearchFilterCollection(T) Generic Class

SearchFilterCollection<(Of <(T>)>) Generic Class
Members See Also
A collection of related search filters, e.g., categories, file formats.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchFilterCollection<T> : List<T> where T : SearchFilter

Type Parameters

T
A search filter

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <(T>)>)
SiteSeeker.Model..::.SearchFilterCollection<(Of <(T>)>)
SiteSeeker.Model..::.FileFormatCollection

See Also

SearchFilterCollection<(Of <(T>)>) Members
SiteSeeker.Model Namespace


SearchFilterCollection(T) Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilterCollection<(Of <(T>)>) Members
SearchFilterCollection<(Of <(T>)>) Class Constructors Methods Properties See Also

The SearchFilterCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
SearchFilterCollection<(Of <(T>)>) | Constructs a new empty SearchFilterCollection.

Methods

Name | Description
Add | Adds a filter to the collection of search filters.
AllElementsExcept | Returns the search filters in the collection except search filters having an id matching the specifed parameter values
ContainsID | Overloaded.
IsEmpty |

Properties

Name | Description
Item | Overloaded.

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


SearchFilterCollection(T) Constructor

SearchFilterCollection<(Of <(T>)>) Constructor
SearchFilterCollection<(Of <(T>)>) Class See Also
Constructs a new empty SearchFilterCollection.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection()

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


SearchFilterCollection(T) Methods

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilterCollection<(Of <(T>)>) Methods
SearchFilterCollection<(Of <(T>)>) Class See Also

The SearchFilterCollection<(Of <(T>)>) type exposes the following methods.

Methods

Name | Description
Add | Adds a filter to the collection of search filters.
AllElementsExcept | Returns the search filters in the collection except search filters having an id matching the specifed parameter values
ContainsID | Overloaded.
IsEmpty |

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


Add Method

SearchFilterCollection<(Of <(T>)>)..::.Add Method
SearchFilterCollection<(Of <(T>)>) Class See Also
Adds a filter to the collection of search filters.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void Add(
    T filter
)

Parameters

filter
Type: T
The filter to add in the collection

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


AllElementsExcept Method

SearchFilterCollection<(Of <(T>)>)..::.AllElementsExcept Method
SearchFilterCollection<(Of <(T>)>) Class See Also
Returns the search filters in the collection except search filters having an id matching the specifed parameter values

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<T> AllElementsExcept(
    params int[] ids
)

Parameters

ids
Type: array< System..::.Int32 >[]()[]
One or more ids of the search filters to be excluded in the list to be returned.

Return Value

All the search filters except filters having an id matching the specifed parameter values.

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


ContainsID Method

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilterCollection<(Of <(T>)>)..::.ContainsID Method
SearchFilterCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
ContainsID(Int32) |
ContainsID(String) | Determines whether a search filter is in the SearchFilterCollection.

See Also

SearchFilterCollection<(Of <(T>)>) Class
SearchFilterCollection<(Of <(T>)>) Members
SiteSeeker.Model Namespace


ContainsID Method (Int32)

SearchFilterCollection<(Of <(T>)>)..::.ContainsID Method (Int32)
SearchFilterCollection<(Of <(T>)>) Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ContainsID(
    int id
)

Parameters

id
Type: System..::.Int32

See Also

SearchFilterCollection<(Of <(T>)>) Class
ContainsID Overload
SiteSeeker.Model Namespace


ContainsID Method (String)

SearchFilterCollection<(Of <(T>)>)..::.ContainsID Method (String)
SearchFilterCollection<(Of <(T>)>) Class See Also
Determines whether a search filter is in the SearchFilterCollection.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool ContainsID(
    string id
)

Parameters

id
Type: System..::.String
A search filter id

Return Value

True if the SearchFilterCollection contains a filter with the specified id, False otherwise.

See Also

SearchFilterCollection<(Of <(T>)>) Class
ContainsID Overload
SiteSeeker.Model Namespace


IsEmpty Method

SearchFilterCollection<(Of <(T>)>)..::.IsEmpty Method
SearchFilterCollection<(Of <(T>)>) Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsEmpty()

Return Value

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


SearchFilterCollection(T) Properties

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilterCollection<(Of <(T>)>) Properties
SearchFilterCollection<(Of <(T>)>) Class See Also

Properties

Name | Description
Item | Overloaded.

See Also

SearchFilterCollection<(Of <(T>)>) Class
SiteSeeker.Model Namespace


Item Property

[image]

SiteSeeker Search Module SDK (3.3)
SearchFilterCollection<(Of <(T>)>)..::.Item Property
SearchFilterCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) |

See Also

SearchFilterCollection<(Of <(T>)>) Class
SearchFilterCollection<(Of <(T>)>) Members
SiteSeeker.Model Namespace


Item Property (Int32)

SearchFilterCollection<(Of <(T>)>)..::.Item Property (Int32)
SearchFilterCollection<(Of <(T>)>) Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public T this[
    int id
] { get; }

Parameters

id
Type: System..::.Int32

See Also

SearchFilterCollection<(Of <(T>)>) Class
Item Overload
SiteSeeker.Model Namespace


Item Property (String)

SearchFilterCollection<(Of <(T>)>)..::.Item Property (String)
SearchFilterCollection<(Of <(T>)>) Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public T this[
    string name
] { get; }

Parameters

name
Type: System..::.String

See Also

SearchFilterCollection<(Of <(T>)>) Class
Item Overload
SiteSeeker.Model Namespace


SearchRequest Class

SearchRequest Class
Members See Also
A SearchRequest object provides the entire search request information sent to the search engine. Use the SearchRequest object to determine the properties of the current search.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchRequest

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchRequest

See Also

SearchRequest Members
SiteSeeker.Model Namespace


SearchRequest Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchRequest Members
SearchRequest Class Constructors Properties See Also

The SearchRequest type exposes the following members.

Constructors

Name | Description
SearchRequest |

Properties

Name | Description
Age | Limit query to documents which has the specified age, where age is defined as one of several pre-defined age brackets.
BatchNumber | Which batch of hits to be collected. The number of batches of each query is given in the response object of the performed search. First batch has number 1.
Categories | Limit query to documents in the specified category(ies). If the categories are in the same category group, documents in either category will be queried. If the categories are in different category groups, documents in both categories will be queried.
DateTimeRange | Limit query to documents whose modification date is in the specified range. Available dates are given in SearchContext.
FileFormat | Limit query to documents of the specified file format.
FiltersEnabled | Returns true if any filter is enabled, otherwise false.
IsSellingSuggestion | Indicates if the query is a spelling suggestion supplied by the search engine. Must be set to true when the user has clicked on a spelling suggestion, false otherwise. Can be applied when click tracking is beeing used.
Language | Limit query to documents in the specified language.
NHitsPerBatch | Number of hits desired in each batch.
Parameters | An associative array of search parameters. Refer to the inner class
Query | Query string.
QueryExtension | Query extension string. The search query will be extended with the value of this string.
SessionID | User identifier, a hexadecimal session id, 32 characters. The session id for each user must be invariant, but may change between access occasions.
SortOrder | Sort order for hits in the result list.
UserTokens | A comma separated list of access keys of current user. The keys may be user id:s and/or group id:s. The keys must correspond to access keys specified in the ACL attribute in the indexed documents. Must be specified when Access Control is used (or you will get no hits).
UseStemming | Specifies whether stemming should be used when evaluating query. Default value is true, i.e. stemming is enabled.

See Also

SearchRequest Class
SiteSeeker.Model Namespace


SearchRequest Constructor

SearchRequest Constructor
SearchRequest Class See Also
Initializes a new instance of the SearchRequest class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchRequest()

See Also

SearchRequest Class
SiteSeeker.Model Namespace


SearchRequest Properties

[image]

SiteSeeker Search Module SDK (3.3)
SearchRequest Properties
SearchRequest Class See Also

The SearchRequest type exposes the following properties.

Properties

Name | Description
Age | Limit query to documents which has the specified age, where age is defined as one of several pre-defined age brackets.
BatchNumber | Which batch of hits to be collected. The number of batches of each query is given in the response object of the performed search. First batch has number 1.
Categories | Limit query to documents in the specified category(ies). If the categories are in the same category group, documents in either category will be queried. If the categories are in different category groups, documents in both categories will be queried.
DateTimeRange | Limit query to documents whose modification date is in the specified range. Available dates are given in SearchContext.
FileFormat | Limit query to documents of the specified file format.
FiltersEnabled | Returns true if any filter is enabled, otherwise false.
IsSellingSuggestion | Indicates if the query is a spelling suggestion supplied by the search engine. Must be set to true when the user has clicked on a spelling suggestion, false otherwise. Can be applied when click tracking is beeing used.
Language | Limit query to documents in the specified language.
NHitsPerBatch | Number of hits desired in each batch.
Parameters | An associative array of search parameters. Refer to the inner class
Query | Query string.
QueryExtension | Query extension string. The search query will be extended with the value of this string.
SessionID | User identifier, a hexadecimal session id, 32 characters. The session id for each user must be invariant, but may change between access occasions.
SortOrder | Sort order for hits in the result list.
UserTokens | A comma separated list of access keys of current user. The keys may be user id:s and/or group id:s. The keys must correspond to access keys specified in the ACL attribute in the indexed documents. Must be specified when Access Control is used (or you will get no hits).
UseStemming | Specifies whether stemming should be used when evaluating query. Default value is true, i.e. stemming is enabled.

See Also

SearchRequest Class
SiteSeeker.Model Namespace


Age Property

SearchRequest..::.Age Property
SearchRequest Class See Also
Limit query to documents which has the specified age, where age is defined as one of several pre-defined age brackets.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Age Age { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


BatchNumber Property

SearchRequest..::.BatchNumber Property
SearchRequest Class See Also
Which batch of hits to be collected. The number of batches of each query is given in the response object of the performed search. First batch has number 1.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int BatchNumber { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


Categories Property

SearchRequest..::.Categories Property
SearchRequest Class See Also
Limit query to documents in the specified category(ies). If the categories are in the same category group, documents in either category will be queried. If the categories are in different category groups, documents in both categories will be queried.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Category> Categories { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


DateTimeRange Property

SearchRequest..::.DateTimeRange Property
SearchRequest Class See Also
Limit query to documents whose modification date is in the specified range. Available dates are given in SearchContext.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public DateTimeRange DateTimeRange { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


FileFormat Property

SearchRequest..::.FileFormat Property
SearchRequest Class See Also
Limit query to documents of the specified file format.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormat FileFormat { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


FiltersEnabled Property

SearchRequest..::.FiltersEnabled Property
SearchRequest Class See Also
Returns true if any filter is enabled, otherwise false.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool FiltersEnabled { get; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


IsSellingSuggestion Property

SearchRequest..::.IsSellingSuggestion Property
SearchRequest Class See Also
Indicates if the query is a spelling suggestion supplied by the search engine. Must be set to true when the user has clicked on a spelling suggestion, false otherwise. Can be applied when click tracking is beeing used.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsSellingSuggestion { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


Language Property

SearchRequest..::.Language Property
SearchRequest Class See Also
Limit query to documents in the specified language.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Language Language { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


NHitsPerBatch Property

SearchRequest..::.NHitsPerBatch Property
SearchRequest Class See Also
Number of hits desired in each batch.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NHitsPerBatch { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


Parameters Property

SearchRequest..::.Parameters Property
SearchRequest Class See Also
An associative array of search parameters. Refer to the inner class

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Dictionary<string, string> Parameters { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


Query Property

SearchRequest..::.Query Property
SearchRequest Class See Also
Query string.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Query { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


QueryExtension Property

SearchRequest..::.QueryExtension Property
SearchRequest Class Example See Also
Query extension string. The search query will be extended with the value of this string.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string QueryExtension { get; set; }

Examples

E.g., the following extension limit the query to documents contained in the category "Cars" or "Bicycles".
CopyC#
(hidden:meta:category:Cars OR hidden:meta:category:Bicycles)

See Also

SearchRequest Class
SiteSeeker.Model Namespace


SessionID Property

SearchRequest..::.SessionID Property
SearchRequest Class See Also
User identifier, a hexadecimal session id, 32 characters. The session id for each user must be invariant, but may change between access occasions.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SessionID { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


SortOrder Property

SearchRequest..::.SortOrder Property
SearchRequest Class See Also
Sort order for hits in the result list.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SortOrder SortOrder { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


UserTokens Property

SearchRequest..::.UserTokens Property
SearchRequest Class See Also
A comma separated list of access keys of current user. The keys may be user id:s and/or group id:s. The keys must correspond to access keys specified in the ACL attribute in the indexed documents. Must be specified when Access Control is used (or you will get no hits).

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string UserTokens { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


UseStemming Property

SearchRequest..::.UseStemming Property
SearchRequest Class See Also
Specifies whether stemming should be used when evaluating query. Default value is true, i.e. stemming is enabled.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool UseStemming { get; set; }

See Also

SearchRequest Class
SiteSeeker.Model Namespace


SearchRequest.ParameterNames Class

SearchRequest..::.ParameterNames Class
SearchRequest Class Members See Also
The names (i.e. keys) of the available search request parameters.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class ParameterNames

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchRequest..::.ParameterNames

See Also

SearchRequest..::.ParameterNames Members
SiteSeeker.Model Namespace


SearchRequest.ParameterNames Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchRequest..::.ParameterNames Members
SearchRequest..::.ParameterNames Class Fields See Also

A SearchRequest object provides the entire search request information sent to the search engine. Use the SearchRequest object to determine the properties of the current search.

The SearchRequest..::.ParameterNames type exposes the following members.

Fields

Name Description
AnyFiltersInOverview
Include items in overview that matches any/all filters, i.e. disables the other filters. Default behavior is not to include any items.
ClientIpAddress
The IP address of the user performing the search.
ClientReferrer
The contents of the refererrer field, which may be sent by the client in the HTTP headers.
EmptyItemsInOverview
Include empty items in overview, e.g. categories with zero hits. Default behavior is not to include empty items.
IncludeMetaAttributes
Return related meta attributes for each hit in the search response
InterfaceIdentifier
A symbolic name for the current search page, used by the SiteSeeker Search Statistics Tool.
InterfaceVersion
Version of the interface, e.g. the version number if the SiteSeeker Search Module. The value is only used for logging, statistics and debugging, and have no effect on the actual search performed.
MatchingAttachmentsOnly
Indicates whether only attachments matching the search query should be shown, or if all attachments should be shown. Default is

Field Value

false.
MaxAttachments
Maximum number of attachments to be shown for each hit. The actual number of attachments may be equal or lower than this value. The default count is -1, which lets the search engine determine the apropriate attachment count.
MaxQueryRefinements
Maximum number of query refinements to return with search response. Please note that this is a add-on service to SiteSeeker, which may require an additional service agreement and/or further configuration in SiteSeeker. Default is

Field Value

0.
NonInteractive
Indicates wheter this search query is generated non-interactively, i.e. not as the result of user input.
PageUrl
The URL of the current page (i.e. the search page, or the page in which the results are shown). Arguments should be left out if not essential to tell different pages apart. This value may be used for search statistics.

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


SearchRequest.ParameterNames Fields

[image]

SiteSeeker Search Module SDK (3.3)
SearchRequest..::.ParameterNames Fields
SearchRequest..::.ParameterNames Class See Also

The SearchRequest..::.ParameterNames type exposes the following fields.

Fields

Name Description
AnyFiltersInOverview
Include items in overview that matches any/all filters, i.e. disables the other filters. Default behavior is not to include any items.
ClientIpAddress
The IP address of the user performing the search.
ClientReferrer
The contents of the refererrer field, which may be sent by the client in the HTTP headers.
EmptyItemsInOverview
Include empty items in overview, e.g. categories with zero hits. Default behavior is not to include empty items.
IncludeMetaAttributes
Return related meta attributes for each hit in the search response
InterfaceIdentifier
A symbolic name for the current search page, used by the SiteSeeker Search Statistics Tool.
InterfaceVersion
Version of the interface, e.g. the version number if the SiteSeeker Search Module. The value is only used for logging, statistics and debugging, and have no effect on the actual search performed.
MatchingAttachmentsOnly
Indicates whether only attachments matching the search query should be shown, or if all attachments should be shown. Default is

Field Value

false.
MaxAttachments
Maximum number of attachments to be shown for each hit. The actual number of attachments may be equal or lower than this value. The default count is -1, which lets the search engine determine the apropriate attachment count.
MaxQueryRefinements
Maximum number of query refinements to return with search response. Please note that this is a add-on service to SiteSeeker, which may require an additional service agreement and/or further configuration in SiteSeeker. Default is

Field Value

0.
NonInteractive
Indicates wheter this search query is generated non-interactively, i.e. not as the result of user input.
PageUrl
The URL of the current page (i.e. the search page, or the page in which the results are shown). Arguments should be left out if not essential to tell different pages apart. This value may be used for search statistics.

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


AnyFiltersInOverview Field

SearchRequest..::.ParameterNames..::.AnyFiltersInOverview Field
SearchRequest..::.ParameterNames Class See Also
Include items in overview that matches any/all filters, i.e. disables the other filters. Default behavior is not to include any items.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string AnyFiltersInOverview

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


ClientIpAddress Field

SearchRequest..::.ParameterNames..::.ClientIpAddress Field
SearchRequest..::.ParameterNames Class See Also
The IP address of the user performing the search.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string ClientIpAddress

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


ClientReferrer Field

SearchRequest..::.ParameterNames..::.ClientReferrer Field
SearchRequest..::.ParameterNames Class See Also
The contents of the refererrer field, which may be sent by the client in the HTTP headers.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string ClientReferrer

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


EmptyItemsInOverview Field

SearchRequest..::.ParameterNames..::.EmptyItemsInOverview Field
SearchRequest..::.ParameterNames Class See Also
Include empty items in overview, e.g. categories with zero hits. Default behavior is not to include empty items.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string EmptyItemsInOverview

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


IncludeMetaAttributes Field

SearchRequest..::.ParameterNames..::.IncludeMetaAttributes Field
SearchRequest..::.ParameterNames Class See Also
Return related meta attributes for each hit in the search response

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string IncludeMetaAttributes

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


InterfaceIdentifier Field

SearchRequest..::.ParameterNames..::.InterfaceIdentifier Field
SearchRequest..::.ParameterNames Class See Also
A symbolic name for the current search page, used by the SiteSeeker Search Statistics Tool.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string InterfaceIdentifier

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


InterfaceVersion Field

SearchRequest..::.ParameterNames..::.InterfaceVersion Field
SearchRequest..::.ParameterNames Class See Also
Version of the interface, e.g. the version number if the SiteSeeker Search Module. The value is only used for logging, statistics and debugging, and have no effect on the actual search performed.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string InterfaceVersion

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


MatchingAttachmentsOnly Field

SearchRequest..::.ParameterNames..::.MatchingAttachmentsOnly Field
SearchRequest..::.ParameterNames Class See Also
Indicates whether only attachments matching the search query should be shown, or if all attachments should be shown. Default is

Field Value

false.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string MatchingAttachmentsOnly

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


MaxAttachments Field

SearchRequest..::.ParameterNames..::.MaxAttachments Field
SearchRequest..::.ParameterNames Class See Also
Maximum number of attachments to be shown for each hit. The actual number of attachments may be equal or lower than this value. The default count is -1, which lets the search engine determine the apropriate attachment count.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string MaxAttachments

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


MaxQueryRefinements Field

SearchRequest..::.ParameterNames..::.MaxQueryRefinements Field
SearchRequest..::.ParameterNames Class See Also
Maximum number of query refinements to return with search response. Please note that this is a add-on service to SiteSeeker, which may require an additional service agreement and/or further configuration in SiteSeeker. Default is

Field Value

0.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string MaxQueryRefinements

Remarks

Please contact sales@euroling.se for more information on this feature.

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


NonInteractive Field

SearchRequest..::.ParameterNames..::.NonInteractive Field
SearchRequest..::.ParameterNames Class See Also
Indicates wheter this search query is generated non-interactively, i.e. not as the result of user input.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string NonInteractive

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


PageUrl Field

SearchRequest..::.ParameterNames..::.PageUrl Field
SearchRequest..::.ParameterNames Class See Also
The URL of the current page (i.e. the search page, or the page in which the results are shown). Arguments should be left out if not essential to tell different pages apart. This value may be used for search statistics.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string PageUrl

See Also

SearchRequest..::.ParameterNames Class
SiteSeeker.Model Namespace


SearchResponse Class

SearchResponse Class
Members See Also
Contains the data returned from the search engine in response to a particular search request. The number of docs reported in the search filters included in this instance denotes the number of documents that were found for the issued search request.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SearchResponse

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SearchResponse

See Also

SearchResponse Members
SiteSeeker.Model Namespace


SearchResponse Members

[image]

SiteSeeker Search Module SDK (3.3)
SearchResponse Members
SearchResponse Class Constructors Fields Properties See Also

The SearchResponse type exposes the following members.

Constructors

Name | Description
SearchResponse |

Fields

Name | Description
Empty |

Properties

Name Description
Ages
A list of ages. The nDocs property of each age denotes the number of hits per age and for the current query.
BatchNumber
Ordinal nuber of the returned hit batch, starting with batch number 1.
BestBets
A list of Bet objects matching the query. If a matching best bet exists, it is always returned with batch number 1. Subsequent batches may or may not contain the same bet bets, depending on the current configuration of the search engine.
Categories
A list of categories. The nDocs property of each category denotes the number of hits within each category and for the current query.
FileFormats
A list of file formats. The nDocs property of each file format denotes the number of hits per file format and for the current query.
Groups
A list of category groups. The nDocs property of each category group denotes the number of hits within each group and for the current query. Note, nDocs is only valid if the categories in the group do not overlap.
Hits
The list of hits in the requested batch. The number of hits returned for each batch is specified with the nHitsPerPage property in SearchRequest.
Languages
A list of languages. The nDocs property of each language denotes the number of hits in each language and for the current query.
Message

A message in semi-natural language describing the search engine’s interpretation of the query and the result. Strongly recommended to be displayed for user. The degree of natural language description varies and depends on query complexity and user interface language. The user interface language is specified with the InterfaceLanguage property in SearchRequest.

The message contains HTML tags: <strong> to denote bold-faced text and <span id=”essi-hitcount”> and <span id=”hitname”> to denote number of hits and the word “hit(s)” (Swedish ”träff(ar)”), respectively. The latter two tags are given in order to enable a final change in number of hits and singular/plural form of the word “hit” when using access control and performing an additional filtering of hits, which may alter (decrease) the number of hits. Furthermore, the name of the special “all” category is denoted with the tag <strong id=”essi-wholesite”>, thereby enabling dynamic rewriting of this category name.

NBatches
Number of batches for the current query.
NHits
Total number of hits for the current query.
NHitsPerBatch
Number of hits per batch for the current query. Note that the actual number of hits may be lower in the last batch, but also higher, as in the case when using sort order CategoryCatBatch.
NoHits
Returns
CopyC#
true
 if the response does not contain any hits nor any best bets, otherwise
CopyC#
false
.
Offset
Ordinal number of first hit in this batch. Ordinal numbers start with 1; Offset 1 is the same as omitting the Offset.
Query
The query submitted in the request excluding query terms prefixed by "hidden:" or other characters not handled or accepted by the search engine.
QueryRefinements
ResponseID
Identifier for current search response.
SpellingSuggestions
A list of spelling suggestions.
StatusCode
A status code which indicates whether the query could be evaluated normally, or if an error occurred. TODO: Not implemented.
SupplementalHits
Supplemental hits, e.g. image hits. Supplemental hits are return only under special circumstances, and can only be enabled by Euroling.

See Also

SearchResponse Class
SiteSeeker.Model Namespace


SearchResponse Constructor

SearchResponse Constructor
SearchResponse Class See Also
Initializes a new instance of the SearchResponse class.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchResponse()

See Also

SearchResponse Class
SiteSeeker.Model Namespace


SearchResponse Fields

[image]

SiteSeeker Search Module SDK (3.3)
SearchResponse Fields
SearchResponse Class See Also

The SearchResponse type exposes the following fields.

Fields

Name | Description
Empty |

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Empty Field

SearchResponse..::.Empty Field
SearchResponse Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static readonly SearchResponse Empty

See Also

SearchResponse Class
SiteSeeker.Model Namespace


SearchResponse Properties

[image]

SiteSeeker Search Module SDK (3.3)
SearchResponse Properties
SearchResponse Class See Also

The SearchResponse type exposes the following properties.

Properties

Name Description
Ages
A list of ages. The nDocs property of each age denotes the number of hits per age and for the current query.
BatchNumber
Ordinal nuber of the returned hit batch, starting with batch number 1.
BestBets
A list of Bet objects matching the query. If a matching best bet exists, it is always returned with batch number 1. Subsequent batches may or may not contain the same bet bets, depending on the current configuration of the search engine.
Categories
A list of categories. The nDocs property of each category denotes the number of hits within each category and for the current query.
FileFormats
A list of file formats. The nDocs property of each file format denotes the number of hits per file format and for the current query.
Groups
A list of category groups. The nDocs property of each category group denotes the number of hits within each group and for the current query. Note, nDocs is only valid if the categories in the group do not overlap.
Hits
The list of hits in the requested batch. The number of hits returned for each batch is specified with the nHitsPerPage property in SearchRequest.
Languages
A list of languages. The nDocs property of each language denotes the number of hits in each language and for the current query.
Message

A message in semi-natural language describing the search engine’s interpretation of the query and the result. Strongly recommended to be displayed for user. The degree of natural language description varies and depends on query complexity and user interface language. The user interface language is specified with the InterfaceLanguage property in SearchRequest.

The message contains HTML tags: <strong> to denote bold-faced text and <span id=”essi-hitcount”> and <span id=”hitname”> to denote number of hits and the word “hit(s)” (Swedish ”träff(ar)”), respectively. The latter two tags are given in order to enable a final change in number of hits and singular/plural form of the word “hit” when using access control and performing an additional filtering of hits, which may alter (decrease) the number of hits. Furthermore, the name of the special “all” category is denoted with the tag <strong id=”essi-wholesite”>, thereby enabling dynamic rewriting of this category name.

NBatches
Number of batches for the current query.
NHits
Total number of hits for the current query.
NHitsPerBatch
Number of hits per batch for the current query. Note that the actual number of hits may be lower in the last batch, but also higher, as in the case when using sort order CategoryCatBatch.
NoHits
Returns
CopyC#
true
 if the response does not contain any hits nor any best bets, otherwise
CopyC#
false
.
Offset
Ordinal number of first hit in this batch. Ordinal numbers start with 1; Offset 1 is the same as omitting the Offset.
Query
The query submitted in the request excluding query terms prefixed by "hidden:" or other characters not handled or accepted by the search engine.
QueryRefinements
ResponseID
Identifier for current search response.
SpellingSuggestions
A list of spelling suggestions.
StatusCode
A status code which indicates whether the query could be evaluated normally, or if an error occurred. TODO: Not implemented.
SupplementalHits
Supplemental hits, e.g. image hits. Supplemental hits are return only under special circumstances, and can only be enabled by Euroling.

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Ages Property

SearchResponse..::.Ages Property
SearchResponse Class See Also
A list of ages. The nDocs property of each age denotes the number of hits per age and for the current query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Age> Ages { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


BatchNumber Property

SearchResponse..::.BatchNumber Property
SearchResponse Class See Also
Ordinal nuber of the returned hit batch, starting with batch number 1.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int BatchNumber { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


BestBets Property

SearchResponse..::.BestBets Property
SearchResponse Class See Also
A list of Bet objects matching the query. If a matching best bet exists, it is always returned with batch number 1. Subsequent batches may or may not contain the same bet bets, depending on the current configuration of the search engine.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<Bet> BestBets { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Categories Property

SearchResponse..::.Categories Property
SearchResponse Class See Also
A list of categories. The nDocs property of each category denotes the number of hits within each category and for the current query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Category> Categories { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


FileFormats Property

SearchResponse..::.FileFormats Property
SearchResponse Class See Also
A list of file formats. The nDocs property of each file format denotes the number of hits per file format and for the current query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public FileFormatCollection FileFormats { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Groups Property

SearchResponse..::.Groups Property
SearchResponse Class See Also
A list of category groups. The nDocs property of each category group denotes the number of hits within each group and for the current query. Note, nDocs is only valid if the categories in the group do not overlap.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<CategoryGroup> Groups { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Hits Property

SearchResponse..::.Hits Property
SearchResponse Class See Also
The list of hits in the requested batch. The number of hits returned for each batch is specified with the nHitsPerPage property in SearchRequest.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<Hit> Hits { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Languages Property

SearchResponse..::.Languages Property
SearchResponse Class See Also
A list of languages. The nDocs property of each language denotes the number of hits in each language and for the current query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SearchFilterCollection<Language> Languages { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Message Property

SearchResponse..::.Message Property
SearchResponse Class See Also

A message in semi-natural language describing the search engine’s interpretation of the query and the result. Strongly recommended to be displayed for user. The degree of natural language description varies and depends on query complexity and user interface language. The user interface language is specified with the InterfaceLanguage property in SearchRequest.

The message contains HTML tags: <strong> to denote bold-faced text and <span id=”essi-hitcount”> and <span id=”hitname”> to denote number of hits and the word “hit(s)” (Swedish ”träff(ar)”), respectively. The latter two tags are given in order to enable a final change in number of hits and singular/plural form of the word “hit” when using access control and performing an additional filtering of hits, which may alter (decrease) the number of hits. Furthermore, the name of the special “all” category is denoted with the tag <strong id=”essi-wholesite”>, thereby enabling dynamic rewriting of this category name.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Message { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


NBatches Property

SearchResponse..::.NBatches Property
SearchResponse Class See Also
Number of batches for the current query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NBatches { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


NHits Property

SearchResponse..::.NHits Property
SearchResponse Class See Also
Total number of hits for the current query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NHits { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


NHitsPerBatch Property

SearchResponse..::.NHitsPerBatch Property
SearchResponse Class See Also
Number of hits per batch for the current query. Note that the actual number of hits may be lower in the last batch, but also higher, as in the case when using sort order CategoryCatBatch.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int NHitsPerBatch { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


NoHits Property

SearchResponse..::.NoHits Property
SearchResponse Class See Also
Returns
CopyC#
true
 if the response does not contain any hits nor any best bets, otherwise
CopyC#
false
.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool NoHits { get; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Offset Property

SearchResponse..::.Offset Property
SearchResponse Class See Also
Ordinal number of first hit in this batch. Ordinal numbers start with 1; Offset 1 is the same as omitting the Offset.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int Offset { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


Query Property

SearchResponse..::.Query Property
SearchResponse Class See Also
The query submitted in the request excluding query terms prefixed by "hidden:" or other characters not handled or accepted by the search engine.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Query { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


QueryRefinements Property

SearchResponse..::.QueryRefinements Property
SearchResponse Class See Also

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<QueryRefinement> QueryRefinements { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


ResponseID Property

SearchResponse..::.ResponseID Property
SearchResponse Class See Also
Identifier for current search response.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int ResponseID { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


SpellingSuggestions Property

SearchResponse..::.SpellingSuggestions Property
SearchResponse Class See Also
A list of spelling suggestions.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<SpellingSuggestion> SpellingSuggestions { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


StatusCode Property

SearchResponse..::.StatusCode Property
SearchResponse Class See Also
A status code which indicates whether the query could be evaluated normally, or if an error occurred. TODO: Not implemented.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public int StatusCode { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


SupplementalHits Property

SearchResponse..::.SupplementalHits Property
SearchResponse Class See Also
Supplemental hits, e.g. image hits. Supplemental hits are return only under special circumstances, and can only be enabled by Euroling.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public List<Hit> SupplementalHits { get; set; }

See Also

SearchResponse Class
SiteSeeker.Model Namespace


SortOrder Enumeration

SortOrder Enumeration
See Also
Sort order for hits in result list. Note that CategoryCatBatch is not recommended when using access control.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public enum SortOrder

Members

Member name | Description
Relevance |
Date |
CategoryBatch |
Title |
CategoryCatBatch |

See Also

SiteSeeker.Model Namespace


SpellingSuggestion Class

SpellingSuggestion Class
Members See Also
Describes a spelling suggestion. Spelling suggestions

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class SpellingSuggestion

Inheritance Hierarchy

System..::.Object
SiteSeeker.Model..::.SpellingSuggestion

See Also

SpellingSuggestion Members
SiteSeeker.Model Namespace


SpellingSuggestion Members

[image]

SiteSeeker Search Module SDK (3.3)
SpellingSuggestion Members
SpellingSuggestion Class Constructors Properties See Also

The SpellingSuggestion type exposes the following members.

Constructors

Name | Description
SpellingSuggestion | Constructs a new spelling suggestion.

Properties

Name | Description
Html | The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.
Text | The spelling suggestion to be used as a new query.

See Also

SpellingSuggestion Class
SiteSeeker.Model Namespace


SpellingSuggestion Constructor

SpellingSuggestion Constructor
SpellingSuggestion Class See Also
Constructs a new spelling suggestion.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public SpellingSuggestion(
    string text,
    string html
)

Parameters

text
Type: System..::.String
The suggested spelling
html
Type: System..::.String
The suggested spelling with changes marked with the HTML tag <strong>

See Also

SpellingSuggestion Class
SiteSeeker.Model Namespace


SpellingSuggestion Properties

[image]

SiteSeeker Search Module SDK (3.3)
SpellingSuggestion Properties
SpellingSuggestion Class See Also

The SpellingSuggestion type exposes the following properties.

Properties

Name | Description
Html | The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.
Text | The spelling suggestion to be used as a new query.

See Also

SpellingSuggestion Class
SiteSeeker.Model Namespace


Html Property

SpellingSuggestion..::.Html Property
SpellingSuggestion Class See Also
The spelling suggestion to be used as a new query. Changes are marked with the HTML tag <strong>.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Html { get; set; }

See Also

SpellingSuggestion Class
SiteSeeker.Model Namespace


Text Property

SpellingSuggestion..::.Text Property
SpellingSuggestion Class See Also
The spelling suggestion to be used as a new query.

Namespace: SiteSeeker.Model
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string Text { get; set; }

See Also

SpellingSuggestion Class
SiteSeeker.Model Namespace


SiteSeeker.Util Namespace

SiteSeeker.Util Namespace
Utility classes.

Classes

Class | Description
HexEncoding | Summary description for HexEncoding.
ParameterConv | Utility class for converting parameter values.
ParameterNames | This class defines the valid parameter names used by the UserControls and the Connector.
Session | A class for handling user session identities.
StringUtil | A utility class for handling basic string manipulations.
UrlBuilder | This utility class facilitates the construction of URLs containing URL parameters. One can prefix all or some of the parameters by using the Set/AddPrefixParameter.


HexEncoding Class

HexEncoding Class
Members See Also
Summary description for HexEncoding.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class HexEncoding

Inheritance Hierarchy

System..::.Object
SiteSeeker.Util..::.HexEncoding

See Also

HexEncoding Members
SiteSeeker.Util Namespace


HexEncoding Members

[image]

SiteSeeker Search Module SDK (3.3)
HexEncoding Members
HexEncoding Class Constructors Methods See Also

The HexEncoding type exposes the following members.

Constructors

Name | Description
HexEncoding |

Methods

Name | Description
GetByteCount |
GetBytes | Creates a byte array from the hexadecimal string. Each two characters are combined to create one byte. First two hexadecimal characters become first byte in returned array. Non-hexadecimal characters are ignored.
InHexFormat | Determines if given string is in proper hexadecimal string format
IsHexDigit | Returns true if c is a hexadecimal digit (A-F, a-f, 0-9)
ToString |

See Also

HexEncoding Class
SiteSeeker.Util Namespace


HexEncoding Constructor

HexEncoding Constructor
HexEncoding Class See Also
Initializes a new instance of the HexEncoding class.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public HexEncoding()

See Also

HexEncoding Class
SiteSeeker.Util Namespace


HexEncoding Methods

[image]

SiteSeeker Search Module SDK (3.3)
HexEncoding Methods
HexEncoding Class See Also

The HexEncoding type exposes the following methods.

Methods

Name | Description
GetByteCount |
GetBytes | Creates a byte array from the hexadecimal string. Each two characters are combined to create one byte. First two hexadecimal characters become first byte in returned array. Non-hexadecimal characters are ignored.
InHexFormat | Determines if given string is in proper hexadecimal string format
IsHexDigit | Returns true if c is a hexadecimal digit (A-F, a-f, 0-9)
ToString |

See Also

HexEncoding Class
SiteSeeker.Util Namespace


GetByteCount Method

HexEncoding..::.GetByteCount Method
HexEncoding Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static int GetByteCount(
    string hexString
)

Parameters

hexString
Type: System..::.String

See Also

HexEncoding Class
SiteSeeker.Util Namespace


GetBytes Method

HexEncoding..::.GetBytes Method
HexEncoding Class See Also
Creates a byte array from the hexadecimal string. Each two characters are combined to create one byte. First two hexadecimal characters become first byte in returned array. Non-hexadecimal characters are ignored.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static byte[] GetBytes(
    string hexString,
    out int discarded
)

Parameters

hexString
Type: System..::.String
string to convert to byte array
discarded
Type: System..::.Int32 %
number of characters in string ignored

Return Value

byte array, in the same left-to-right order as the hexString

See Also

HexEncoding Class
SiteSeeker.Util Namespace


InHexFormat Method

HexEncoding..::.InHexFormat Method
HexEncoding Class See Also
Determines if given string is in proper hexadecimal string format

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static bool InHexFormat(
    string hexString
)

Parameters

hexString
Type: System..::.String

Return Value

See Also

HexEncoding Class
SiteSeeker.Util Namespace


IsHexDigit Method

HexEncoding..::.IsHexDigit Method
HexEncoding Class See Also
Returns true if c is a hexadecimal digit (A-F, a-f, 0-9)

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static bool IsHexDigit(
    char c
)

Parameters

c
Type: System..::.Char
Character to test

Return Value

true if hex digit, false if not

See Also

HexEncoding Class
SiteSeeker.Util Namespace


ToString Method

HexEncoding..::.ToString Method
HexEncoding Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string ToString(
    byte[] bytes
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]

See Also

HexEncoding Class
SiteSeeker.Util Namespace


ParameterConv Class

ParameterConv Class
Members See Also
Utility class for converting parameter values.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class ParameterConv

Inheritance Hierarchy

System..::.Object
SiteSeeker.Util..::.ParameterConv

See Also

ParameterConv Members
SiteSeeker.Util Namespace


ParameterConv Members

[image]

SiteSeeker Search Module SDK (3.3)
ParameterConv Members
ParameterConv Class Constructors Methods See Also

The ParameterConv type exposes the following members.

Constructors

Name | Description
ParameterConv |

Methods

Name | Description
AppendToString |
ArrayToString | Converts an int array to a string containing a comma-separated list of integers.
CollectionToString | Overloaded.
GetBool | Overloaded.
GetInt | Overloaded.
GetLong | Overloaded.
IntArrayToString | Converts an object array to a string containing a comma-separated list of objects.

See Also

ParameterConv Class
SiteSeeker.Util Namespace


ParameterConv Constructor

ParameterConv Constructor
ParameterConv Class See Also
Initializes a new instance of the ParameterConv class.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ParameterConv()

See Also

ParameterConv Class
SiteSeeker.Util Namespace


ParameterConv Methods

[image]

SiteSeeker Search Module SDK (3.3)
ParameterConv Methods
ParameterConv Class See Also

The ParameterConv type exposes the following methods.

Methods

Name | Description
AppendToString |
ArrayToString | Converts an int array to a string containing a comma-separated list of integers.
CollectionToString | Overloaded.
GetBool | Overloaded.
GetInt | Overloaded.
GetLong | Overloaded.
IntArrayToString | Converts an object array to a string containing a comma-separated list of objects.

See Also

ParameterConv Class
SiteSeeker.Util Namespace


AppendToString Method

ParameterConv..::.AppendToString Method
ParameterConv Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string AppendToString(
    string element,
    string stringList,
    string quotes
)

Parameters

element
Type: System..::.String
stringList
Type: System..::.String
quotes
Type: System..::.String

See Also

ParameterConv Class
SiteSeeker.Util Namespace


ArrayToString Method

ParameterConv..::.ArrayToString Method
ParameterConv Class See Also
Converts an int array to a string containing a comma-separated list of integers.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string ArrayToString(
    Object[] array,
    string quotes
)

Parameters

array
Type: array< System..::.Object >[]()[]
The int array to be comma-separated
quotes
Type: System..::.String
A string to be used for quoting the values, e.g. ' or ".

Return Value

The comma-separated list of integers

See Also

ParameterConv Class
SiteSeeker.Util Namespace


CollectionToString Method

[image]

SiteSeeker Search Module SDK (3.3)
ParameterConv..::.CollectionToString Method
ParameterConv Class See Also

Overload List

Name | Description
CollectionToString<(Of <(T>)>)(ICollection<(Of <(T>)>)) | Converts a Collection to a string containing a comma-separated list.
CollectionToString<(Of <(T>)>)(ICollection<(Of <(T>)>), String) | Converts a Collection to a string containing a comma-separated list.

See Also

ParameterConv Class
ParameterConv Members
SiteSeeker.Util Namespace


CollectionToString(T) Generic Method (ICollection(T))

ParameterConv..::.CollectionToString<(Of <(T>)>) Generic Method (ICollection<(Of <(T>)>))
ParameterConv Class See Also
Converts a Collection to a string containing a comma-separated list.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string CollectionToString<T>(
    ICollection<T> array
)

Parameters

array
Type: System.Collections.Generic..::.ICollection <(Of <(T>)>)
The Collection to be comma-separated

Type Parameters

T

Return Value

The comma-separated list of Collection elements

See Also

ParameterConv Class
CollectionToString Overload
SiteSeeker.Util Namespace


CollectionToString(T) Generic Method (ICollection(T), String)

ParameterConv..::.CollectionToString<(Of <(T>)>) Generic Method (ICollection<(Of <(T>)>), String)
ParameterConv Class See Also
Converts a Collection to a string containing a comma-separated list.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string CollectionToString<T>(
    ICollection<T> array,
    string quotes
)

Parameters

array
Type: System.Collections.Generic..::.ICollection <(Of <(T>)>)
The Collection to be comma-separated
quotes
Type: System..::.String
A string to be used for quoting the values, e.g. ' or ".

Type Parameters

T

Return Value

The comma-separated list of Collection elements

See Also

ParameterConv Class
CollectionToString Overload
SiteSeeker.Util Namespace


GetBool Method

[image]

SiteSeeker Search Module SDK (3.3)
ParameterConv..::.GetBool Method
ParameterConv Class See Also

Overload List

Name | Description
GetBool(String) | Converts the string reprsentation of a boolean to a bool equivalent.
GetBool(String, Boolean) | Converts the string reprsentation of a boolean to a bool equivalent.

See Also

ParameterConv Class
ParameterConv Members
SiteSeeker.Util Namespace


GetBool Method (String)

ParameterConv..::.GetBool Method (String)
ParameterConv Class See Also
Converts the string reprsentation of a boolean to a bool equivalent.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static bool GetBool(
    string s
)

Parameters

s
Type: System..::.String
A string containing a boolean to convert.

Return Value

false if s cannot be parsed correctly. Otherwise the value of the string converted to a bool.

See Also

ParameterConv Class
GetBool Overload
SiteSeeker.Util Namespace


GetBool Method (String, Boolean)

ParameterConv..::.GetBool Method (String, Boolean)
ParameterConv Class See Also
Converts the string reprsentation of a boolean to a bool equivalent.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static bool GetBool(
    string s,
    bool defaultValue
)

Parameters

s
Type: System..::.String
A string containing a boolean to convert.
defaultValue
Type: System..::.Boolean
The default value to be returned if s cannot be parsed correctly.

Return Value

The default value if s cannot be parsed correctly. Otherwise the value of the string converted to a bool.

See Also

ParameterConv Class
GetBool Overload
SiteSeeker.Util Namespace


GetInt Method

[image]

SiteSeeker Search Module SDK (3.3)
ParameterConv..::.GetInt Method
ParameterConv Class See Also

Overload List

Name | Description
GetInt(String) | Converts the string reprsentation of a number to an integer equivalent.
GetInt(String, Int32) | Converts the string reprsentation of a number to an integer equivalent.

See Also

ParameterConv Class
ParameterConv Members
SiteSeeker.Util Namespace


GetInt Method (String)

ParameterConv..::.GetInt Method (String)
ParameterConv Class See Also
Converts the string reprsentation of a number to an integer equivalent.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static int GetInt(
    string s
)

Parameters

s
Type: System..::.String
A string containing a number to convert.

Return Value

0 if s cannot be parsed correctly. Otherwise the value of the string converted to an integer.

See Also

ParameterConv Class
GetInt Overload
SiteSeeker.Util Namespace


GetInt Method (String, Int32)

ParameterConv..::.GetInt Method (String, Int32)
ParameterConv Class See Also
Converts the string reprsentation of a number to an integer equivalent.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static int GetInt(
    string s,
    int defaultValue
)

Parameters

s
Type: System..::.String
A string containing a number to convert.
defaultValue
Type: System..::.Int32
The default value to be returned if s cannot be parsed correctly.

Return Value

The default value if s cannot be parsed correctly. Otherwise the value of the string converted to an integer.

See Also

ParameterConv Class
GetInt Overload
SiteSeeker.Util Namespace


GetLong Method

[image]

SiteSeeker Search Module SDK (3.3)
ParameterConv..::.GetLong Method
ParameterConv Class See Also

Overload List

Name | Description
GetLong(String) | Converts the string reprsentation of a number to a long equivalent.
GetLong(String, Int64) | Converts the string reprsentation of a number to a long equivalent.

See Also

ParameterConv Class
ParameterConv Members
SiteSeeker.Util Namespace


GetLong Method (String)

ParameterConv..::.GetLong Method (String)
ParameterConv Class See Also
Converts the string reprsentation of a number to a long equivalent.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static long GetLong(
    string s
)

Parameters

s
Type: System..::.String
A string containing a number to convert.

Return Value

0 if s cannot be parsed correctly. Otherwise the value of the string converted to a long.

See Also

ParameterConv Class
GetLong Overload
SiteSeeker.Util Namespace


GetLong Method (String, Int64)

ParameterConv..::.GetLong Method (String, Int64)
ParameterConv Class See Also
Converts the string reprsentation of a number to a long equivalent.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static long GetLong(
    string s,
    long defaultValue
)

Parameters

s
Type: System..::.String
A string containing a number to convert.
defaultValue
Type: System..::.Int64
The default value to be returned if s cannot be parsed correctly.

Return Value

The default value if s cannot be parsed correctly. Otherwise the value of the string converted to a long.

See Also

ParameterConv Class
GetLong Overload
SiteSeeker.Util Namespace


IntArrayToString Method

ParameterConv..::.IntArrayToString Method
ParameterConv Class See Also
Converts an object array to a string containing a comma-separated list of objects.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string IntArrayToString(
    int[] array
)

Parameters

array
Type: array< System..::.Int32 >[]()[]
The object array to be comma-separated

Return Value

The comma-separated list of objects

See Also

ParameterConv Class
SiteSeeker.Util Namespace


ParameterNames Class

ParameterNames Class
Members See Also
This class defines the valid parameter names used by the UserControls and the Connector.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class ParameterNames

Inheritance Hierarchy

System..::.Object
SiteSeeker.Util..::.ParameterNames

See Also

ParameterNames Members
SiteSeeker.Util Namespace


ParameterNames Members

[image]

SiteSeeker Search Module SDK (3.3)
ParameterNames Members
ParameterNames Class Constructors Fields See Also

The ParameterNames type exposes the following members.

Constructors

Name | Description
ParameterNames |

Fields

Name | Description
Age |
BatchNumber |
BetNumber |
Categories |
DateTimeFrom |
DateTimeTo |
FileFormat |
HitNumber |
InterfaceLanguage | Specifies user interface language for messages from search engine displayable for user. See [!:SiteSeeker.Model.SearchRequest.InterfaceLanguage]
IsSpellSuggestion |
Language |
NHitsPerBatch |
Params |
Query |
QueryExtension |
QuickSearchCategory |
QuickSearchQuery |
RedirectUrl |
ResponseID |
SessionID |
SortOrder |
UniqueCategory |
Url |
UserToken |
UseStemming |

See Also

ParameterNames Class
SiteSeeker.Util Namespace


ParameterNames Constructor

ParameterNames Constructor
ParameterNames Class See Also
Initializes a new instance of the ParameterNames class.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public ParameterNames()

See Also

ParameterNames Class
SiteSeeker.Util Namespace


ParameterNames Fields

[image]

SiteSeeker Search Module SDK (3.3)
ParameterNames Fields
ParameterNames Class See Also

The ParameterNames type exposes the following fields.

Fields

Name | Description
Age |
BatchNumber |
BetNumber |
Categories |
DateTimeFrom |
DateTimeTo |
FileFormat |
HitNumber |
InterfaceLanguage | Specifies user interface language for messages from search engine displayable for user. See [!:SiteSeeker.Model.SearchRequest.InterfaceLanguage]
IsSpellSuggestion |
Language |
NHitsPerBatch |
Params |
Query |
QueryExtension |
QuickSearchCategory |
QuickSearchQuery |
RedirectUrl |
ResponseID |
SessionID |
SortOrder |
UniqueCategory |
Url |
UserToken |
UseStemming |

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Age Field

ParameterNames..::.Age Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Age

See Also

ParameterNames Class
SiteSeeker.Util Namespace


BatchNumber Field

ParameterNames..::.BatchNumber Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string BatchNumber

See Also

ParameterNames Class
SiteSeeker.Util Namespace


BetNumber Field

ParameterNames..::.BetNumber Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string BetNumber

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Categories Field

ParameterNames..::.Categories Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Categories

See Also

ParameterNames Class
SiteSeeker.Util Namespace


DateTimeFrom Field

ParameterNames..::.DateTimeFrom Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string DateTimeFrom

See Also

ParameterNames Class
SiteSeeker.Util Namespace


DateTimeTo Field

ParameterNames..::.DateTimeTo Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string DateTimeTo

See Also

ParameterNames Class
SiteSeeker.Util Namespace


FileFormat Field

ParameterNames..::.FileFormat Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string FileFormat

See Also

ParameterNames Class
SiteSeeker.Util Namespace


HitNumber Field

ParameterNames..::.HitNumber Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string HitNumber

See Also

ParameterNames Class
SiteSeeker.Util Namespace


InterfaceLanguage Field

ParameterNames..::.InterfaceLanguage Field
ParameterNames Class See Also
Specifies user interface language for messages from search engine displayable for user. See [!:SiteSeeker.Model.SearchRequest.InterfaceLanguage]

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string InterfaceLanguage

See Also

ParameterNames Class
SiteSeeker.Util Namespace


IsSpellSuggestion Field

ParameterNames..::.IsSpellSuggestion Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string IsSpellSuggestion

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Language Field

ParameterNames..::.Language Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Language

See Also

ParameterNames Class
SiteSeeker.Util Namespace


NHitsPerBatch Field

ParameterNames..::.NHitsPerBatch Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string NHitsPerBatch

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Params Field

ParameterNames..::.Params Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Params

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Query Field

ParameterNames..::.Query Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Query

See Also

ParameterNames Class
SiteSeeker.Util Namespace


QueryExtension Field

ParameterNames..::.QueryExtension Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string QueryExtension

See Also

ParameterNames Class
SiteSeeker.Util Namespace


QuickSearchCategory Field

ParameterNames..::.QuickSearchCategory Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string QuickSearchCategory

See Also

ParameterNames Class
SiteSeeker.Util Namespace


QuickSearchQuery Field

ParameterNames..::.QuickSearchQuery Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string QuickSearchQuery

See Also

ParameterNames Class
SiteSeeker.Util Namespace


RedirectUrl Field

ParameterNames..::.RedirectUrl Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string RedirectUrl

See Also

ParameterNames Class
SiteSeeker.Util Namespace


ResponseID Field

ParameterNames..::.ResponseID Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string ResponseID

See Also

ParameterNames Class
SiteSeeker.Util Namespace


SessionID Field

ParameterNames..::.SessionID Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string SessionID

See Also

ParameterNames Class
SiteSeeker.Util Namespace


SortOrder Field

ParameterNames..::.SortOrder Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string SortOrder

See Also

ParameterNames Class
SiteSeeker.Util Namespace


UniqueCategory Field

ParameterNames..::.UniqueCategory Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string UniqueCategory

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Url Field

ParameterNames..::.Url Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string Url

See Also

ParameterNames Class
SiteSeeker.Util Namespace


UserToken Field

ParameterNames..::.UserToken Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string UserToken

See Also

ParameterNames Class
SiteSeeker.Util Namespace


UseStemming Field

ParameterNames..::.UseStemming Field
ParameterNames Class See Also

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public const string UseStemming

See Also

ParameterNames Class
SiteSeeker.Util Namespace


Session Class

Session Class
Members See Also
A class for handling user session identities.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class Session

Inheritance Hierarchy

System..::.Object
SiteSeeker.Util..::.Session

See Also

Session Members
SiteSeeker.Util Namespace


Session Members

[image]

SiteSeeker Search Module SDK (3.3)
Session Members
Session Class Constructors Methods Properties See Also

The Session type exposes the following members.

Constructors

Name | Description
Session | Constructs a session identifier based on the specified HttpRequest. A new session identifier is generated if: 1) HttpRequest does not contain any session id parameter. 2) The session id parameter from the HttpRequest object has expired or does not match the hostname of the current HTTP client.

Methods

Name | Description
GetSessionID | Extracts the session id from the sessionStr. The sessionStr is typically generated from the ToString-method.
ToString | Generates a string that represents this session instance (including the session id). This string is intended to be used as an URL parameter. The session id can be extracted from the string by using GetSessionID(string s). (Overrides Object ..::. ToString()()().)

Properties

Name | Description
IsNew | Returns true if the session identifier was generated at this request.
SessionID | The session id.

See Also

Session Class
SiteSeeker.Util Namespace


Session Constructor

Session Constructor
Session Class See Also
Constructs a session identifier based on the specified HttpRequest. A new session identifier is generated if: 1) HttpRequest does not contain any session id parameter. 2) The session id parameter from the HttpRequest object has expired or does not match the hostname of the current HTTP client.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public Session(
    HttpRequest request
)

Parameters

request
Type: System.Web..::.HttpRequest
The current HttpRequest object.

See Also

Session Class
SiteSeeker.Util Namespace


Session Methods

[image]

SiteSeeker Search Module SDK (3.3)
Session Methods
Session Class See Also

The Session type exposes the following methods.

Methods

Name | Description
GetSessionID | Extracts the session id from the sessionStr. The sessionStr is typically generated from the ToString-method.
ToString | Generates a string that represents this session instance (including the session id). This string is intended to be used as an URL parameter. The session id can be extracted from the string by using GetSessionID(string s). (Overrides Object ..::. ToString()()().)

See Also

Session Class
SiteSeeker.Util Namespace


GetSessionID Method

Session..::.GetSessionID Method
Session Class See Also
Extracts the session id from the sessionStr. The sessionStr is typically generated from the ToString-method.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string GetSessionID(
    string sessionStr
)

Parameters

sessionStr
Type: System..::.String
The string representing a Session object.

Return Value

The session id if the string is well formed (see ToString), null otherwise.

See Also

Session Class
SiteSeeker.Util Namespace


ToString Method

Session..::.ToString Method
Session Class See Also
Generates a string that represents this session instance (including the session id). This string is intended to be used as an URL parameter. The session id can be extracted from the string by using GetSessionID(string s).

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override string ToString()

Return Value

A string that represents this session

See Also

Session Class
SiteSeeker.Util Namespace


Session Properties

[image]

SiteSeeker Search Module SDK (3.3)
Session Properties
Session Class See Also

The Session type exposes the following properties.

Properties

Name | Description
IsNew | Returns true if the session identifier was generated at this request.
SessionID | The session id.

See Also

Session Class
SiteSeeker.Util Namespace


IsNew Property

Session..::.IsNew Property
Session Class See Also
Returns true if the session identifier was generated at this request.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public bool IsNew { get; }

See Also

Session Class
SiteSeeker.Util Namespace


SessionID Property

Session..::.SessionID Property
Session Class See Also
The session id.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string SessionID { get; }

See Also

Session Class
SiteSeeker.Util Namespace


StringUtil Class

StringUtil Class
Members See Also
A utility class for handling basic string manipulations.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static class StringUtil

Inheritance Hierarchy

System..::.Object
SiteSeeker.Util..::.StringUtil

See Also

StringUtil Members
SiteSeeker.Util Namespace


StringUtil Members

[image]

SiteSeeker Search Module SDK (3.3)
StringUtil Members
StringUtil Class Methods See Also

The StringUtil type exposes the following members.

Methods

Name | Description
Capitalize | Returns a string with the first character of str capitalized.

See Also

StringUtil Class
SiteSeeker.Util Namespace


StringUtil Methods

[image]

SiteSeeker Search Module SDK (3.3)
StringUtil Methods
StringUtil Class See Also

The StringUtil type exposes the following methods.

Methods

Name | Description
Capitalize | Returns a string with the first character of str capitalized.

See Also

StringUtil Class
SiteSeeker.Util Namespace


Capitalize Method

StringUtil..::.Capitalize Method
StringUtil Class See Also
Returns a string with the first character of str capitalized.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string Capitalize(
    string str
)

Parameters

str
Type: System..::.String
The string to be capitalized.

Return Value

The capitalized string

See Also

StringUtil Class
SiteSeeker.Util Namespace


UrlBuilder Class

UrlBuilder Class
Members See Also
This utility class facilitates the construction of URLs containing URL parameters. One can prefix all or some of the parameters by using the Set/AddPrefixParameter.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public class UrlBuilder

Inheritance Hierarchy

System..::.Object
SiteSeeker.Util..::.UrlBuilder

See Also

UrlBuilder Members
SiteSeeker.Util Namespace


UrlBuilder Members

[image]

SiteSeeker Search Module SDK (3.3)
UrlBuilder Members
UrlBuilder Class Constructors Methods Properties See Also

The UrlBuilder type exposes the following members.

Constructors

Name | Description
UrlBuilder | Overloaded.

Methods

Name | Description
AddParam | Adds a value to the parameter with the specified name. Multiple values will be separated by commas.
AddPrefixParam | Adds a value to the parameter with the specified name. Multiple values will be separated by commas. The parameter name will be prefixed by the prefix specified when constructing the UrlBuilder instance.
BuildUrl | Constructs a URL with the parameters specified with Add/Set(Prefix)Param.
HtmlEncode | Converts a string to an HTML-encoded string. Extends HttpUtility..::.HtmlEncode(String), but additionally converts ' to &#39;, for XHTML compatibility.
RemoveHtmlTags | Removes HTML tags from a string. May be used to clean request arguments from malicious HTML/JavaScript code, i.e. to prevent script injection.
RemoveParam | Removes the parameter with the specified name.
RemovePrefixParam | Removes the parameter with the specified name.
SetLastParamName | Sets the name of the last parameter to appear in the query string.
SetParam | Overloaded.
SetPrefixParam | Sets, i.e. replaces, the value of the parameter with the specified name. The parameter name will be prefixed by the prefix specified when constructing the UrlBuilder instance.
ToString | Returns the current URL as a string with URL encoded parameter values. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
BaseUrl | The base URL to use when constructing the new URL. Parameters in the base URL will be treated as non prefixed parameters.

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


UrlBuilder Constructor

[image]

SiteSeeker Search Module SDK (3.3)
UrlBuilder Constructor
UrlBuilder Class See Also

Overload List

Name | Description
UrlBuilder(String) | Constructs a new UrlBuilder object.
UrlBuilder(String, NameValueCollection) | Constructs a new UrlBuilder object.
UrlBuilder(String, String) | Constructs a new UrlBuilder object.
UrlBuilder(String, NameValueCollection, String) | Constructs a new UrlBuilder object.

See Also

UrlBuilder Class
UrlBuilder Members
SiteSeeker.Util Namespace


UrlBuilder Constructor (String)

UrlBuilder Constructor (String)
UrlBuilder Class See Also
Constructs a new UrlBuilder object.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder(
    string baseUrl
)

Parameters

baseUrl
Type: System..::.String
The base URL to use when constructing the new URL.

See Also

UrlBuilder Class
UrlBuilder Overload
SiteSeeker.Util Namespace


UrlBuilder Constructor (String, NameValueCollection)

UrlBuilder Constructor (String, NameValueCollection)
UrlBuilder Class See Also
Constructs a new UrlBuilder object.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder(
    string baseUrl,
    NameValueCollection queryString
)

Parameters

baseUrl
Type: System..::.String
The base URL to use when constructing the new URL.
queryString
Type: System.Collections.Specialized..::.NameValueCollection
A collection of name/value pairs to be appended to the URL

See Also

UrlBuilder Class
UrlBuilder Overload
SiteSeeker.Util Namespace


UrlBuilder Constructor (String, String)

UrlBuilder Constructor (String, String)
UrlBuilder Class See Also
Constructs a new UrlBuilder object.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder(
    string baseUrl,
    string prefix
)

Parameters

baseUrl
Type: System..::.String
The base URL to use when constructing the new URL.
prefix
Type: System..::.String
The string to prefix every prefix parameters

See Also

UrlBuilder Class
UrlBuilder Overload
SiteSeeker.Util Namespace


UrlBuilder Constructor (String, NameValueCollection, String)

UrlBuilder Constructor (String, NameValueCollection, String)
UrlBuilder Class See Also
Constructs a new UrlBuilder object.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public UrlBuilder(
    string baseUrl,
    NameValueCollection queryString,
    string prefix
)

Parameters

baseUrl
Type: System..::.String
The base URL to use when constructing the new URL.
queryString
Type: System.Collections.Specialized..::.NameValueCollection
A collection of name/value pairs to be appended to the URL
prefix
Type: System..::.String
The string to prefix every prefix parameters

See Also

UrlBuilder Class
UrlBuilder Overload
SiteSeeker.Util Namespace


UrlBuilder Methods

[image]

SiteSeeker Search Module SDK (3.3)
UrlBuilder Methods
UrlBuilder Class See Also

The UrlBuilder type exposes the following methods.

Methods

Name | Description
AddParam | Adds a value to the parameter with the specified name. Multiple values will be separated by commas.
AddPrefixParam | Adds a value to the parameter with the specified name. Multiple values will be separated by commas. The parameter name will be prefixed by the prefix specified when constructing the UrlBuilder instance.
BuildUrl | Constructs a URL with the parameters specified with Add/Set(Prefix)Param.
HtmlEncode | Converts a string to an HTML-encoded string. Extends HttpUtility..::.HtmlEncode(String), but additionally converts ' to &#39;, for XHTML compatibility.
RemoveHtmlTags | Removes HTML tags from a string. May be used to clean request arguments from malicious HTML/JavaScript code, i.e. to prevent script injection.
RemoveParam | Removes the parameter with the specified name.
RemovePrefixParam | Removes the parameter with the specified name.
SetLastParamName | Sets the name of the last parameter to appear in the query string.
SetParam | Overloaded.
SetPrefixParam | Sets, i.e. replaces, the value of the parameter with the specified name. The parameter name will be prefixed by the prefix specified when constructing the UrlBuilder instance.
ToString | Returns the current URL as a string with URL encoded parameter values. (Overrides Object ..::. ToString()()().)

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


AddParam Method

UrlBuilder..::.AddParam Method
UrlBuilder Class See Also
Adds a value to the parameter with the specified name. Multiple values will be separated by commas.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void AddParam(
    string name,
    string value
)

Parameters

name
Type: System..::.String
The name of the parameter
value
Type: System..::.String
The parameter value

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


AddPrefixParam Method

UrlBuilder..::.AddPrefixParam Method
UrlBuilder Class See Also
Adds a value to the parameter with the specified name. Multiple values will be separated by commas. The parameter name will be prefixed by the prefix specified when constructing the UrlBuilder instance.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void AddPrefixParam(
    string name,
    string value
)

Parameters

name
Type: System..::.String
The name (prefix excluded) of the parameter
value
Type: System..::.String
The parameter value

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


BuildUrl Method

UrlBuilder..::.BuildUrl Method
UrlBuilder Class See Also
Constructs a URL with the parameters specified with Add/Set(Prefix)Param.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string BuildUrl()

Return Value

The constructed URL

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


HtmlEncode Method

UrlBuilder..::.HtmlEncode Method
UrlBuilder Class See Also
Converts a string to an HTML-encoded string. Extends HttpUtility..::.HtmlEncode(String), but additionally converts ' to &#39;, for XHTML compatibility.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string HtmlEncode(
    string s
)

Parameters

s
Type: System..::.String
The string to encode.

Return Value

An encoded string.

See Also

UrlBuilder Class
SiteSeeker.Util Namespace
HttpUtility..::.HtmlEncode(String)


RemoveHtmlTags Method

UrlBuilder..::.RemoveHtmlTags Method
UrlBuilder Class See Also
Removes HTML tags from a string. May be used to clean request arguments from malicious HTML/JavaScript code, i.e. to prevent script injection.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public static string RemoveHtmlTags(
    string sHtml
)

Parameters

sHtml
Type: System..::.String
The string to be cleaned from HTML code.

Return Value

The clean string.

Remarks

Note that the string may still contain characters that may not be printed directly in an HTML page, so you shoul always use HtmlEncode(String) when printing user submitted strings.

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


RemoveParam Method

UrlBuilder..::.RemoveParam Method
UrlBuilder Class See Also
Removes the parameter with the specified name.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void RemoveParam(
    string name
)

Parameters

name
Type: System..::.String
The name of the parameter

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


RemovePrefixParam Method

UrlBuilder..::.RemovePrefixParam Method
UrlBuilder Class See Also
Removes the parameter with the specified name.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void RemovePrefixParam(
    string name
)

Parameters

name
Type: System..::.String
The name (prefix excluded) of the parameter

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


SetLastParamName Method

UrlBuilder..::.SetLastParamName Method
UrlBuilder Class See Also
Sets the name of the last parameter to appear in the query string.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void SetLastParamName(
    string name
)

Parameters

name
Type: System..::.String
The name of the parameter

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


SetParam Method

[image]

SiteSeeker Search Module SDK (3.3)
UrlBuilder..::.SetParam Method
UrlBuilder Class See Also

Overload List

Name | Description
SetParam(String, String) | Sets, i.e. replaces, the value of the parameter with the specified name.
SetParam(String, String, Boolean) | Sets, i.e. replaces, the value of the parameter with the specified name.

See Also

UrlBuilder Class
UrlBuilder Members
SiteSeeker.Util Namespace


SetParam Method (String, String)

UrlBuilder..::.SetParam Method (String, String)
UrlBuilder Class See Also
Sets, i.e. replaces, the value of the parameter with the specified name.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void SetParam(
    string name,
    string value
)

Parameters

name
Type: System..::.String
The name of the parameter
value
Type: System..::.String
The parameter value

See Also

UrlBuilder Class
SetParam Overload
SiteSeeker.Util Namespace


SetParam Method (String, String, Boolean)

UrlBuilder..::.SetParam Method (String, String, Boolean)
UrlBuilder Class See Also
Sets, i.e. replaces, the value of the parameter with the specified name.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void SetParam(
    string name,
    string value,
    bool isLast
)

Parameters

name
Type: System..::.String
The name of the parameter
value
Type: System..::.String
The parameter value
isLast
Type: System..::.Boolean
Indicates whether this parameter should appear last int the query string

See Also

UrlBuilder Class
SetParam Overload
SiteSeeker.Util Namespace


SetPrefixParam Method

UrlBuilder..::.SetPrefixParam Method
UrlBuilder Class See Also
Sets, i.e. replaces, the value of the parameter with the specified name. The parameter name will be prefixed by the prefix specified when constructing the UrlBuilder instance.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public void SetPrefixParam(
    string name,
    string value
)

Parameters

name
Type: System..::.String
The name (prefix excluded) of the parameter
value
Type: System..::.String
The parameter value

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


ToString Method

UrlBuilder..::.ToString Method
UrlBuilder Class See Also
Returns the current URL as a string with URL encoded parameter values.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public override string ToString()

Return Value

The URL

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


UrlBuilder Properties

[image]

SiteSeeker Search Module SDK (3.3)
UrlBuilder Properties
UrlBuilder Class See Also

The UrlBuilder type exposes the following properties.

Properties

Name | Description
BaseUrl | The base URL to use when constructing the new URL. Parameters in the base URL will be treated as non prefixed parameters.

See Also

UrlBuilder Class
SiteSeeker.Util Namespace


BaseUrl Property

UrlBuilder..::.BaseUrl Property
UrlBuilder Class See Also
The base URL to use when constructing the new URL. Parameters in the base URL will be treated as non prefixed parameters.

Namespace: SiteSeeker.Util
Assembly: SiteSeeker (in SiteSeeker)
Version: 3.4.4076.23736

Syntax

C#
public string BaseUrl { set; }

See Also

UrlBuilder Class
SiteSeeker.Util Namespace